[Stable Update] 2020-07-19 - Kernels, KDE, LibreOffice, Mesa, Cinnamon, Deepin, Pamac, Browsers

Hello community,

Another stable branch update with some interesting updates for you! So far it is one of our biggest updates we prepared so far.

Feel your pulse ryzing! Soonish with Manjaro #Mikah by TUXEDO Computers #stayhome, #staysafe, #stayhealthy

  • We updated all of our Kernels
  • For Linux57 kernel series we added the FSync/Futex patches by Valve to speed up some processes, especially for Proton gaming.
  • Renewed our Firmware for the kernels
  • Worked on our ARM-tools
  • Some Cinnamon and Deepin updates
  • Plasma5 got updated to 5.19.3
  • KDE Frameworks is now at 5.72.0
  • KDE Apps got renewed to 20.04.3
  • A lot of KDE-git package updates to showcase the latest features of KDE software
  • Wine is renewed to 5.10
  • Brave browser has new versions in standard and beta
  • Virtualbox is now at 6.1.10
  • Mesa got updated to 20.1.3
  • PHP is now at 7.4.8
  • Pamac got some fixes and updated to 9.5.6
  • Firefox is now at 78.0.2
  • Firefox developer edition is now at 79.0b7
  • Palemoon got another release
  • Thunderbird updated to 68.10.0
  • Some more fixes to our Jade desktop
  • LibreOffice got renewed to 6.4.5
  • The development IDE Gambas is now at 3.15.0
  • AMD kicks of Q3 with AMDVLK on 2020.Q3.1
  • The usual upstream updates rebuilds/updates including python and haskell by Arch

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest release candidate of Manjaro Mikah 20.1! XFCE, KDE and Gnome

Security updates:

We pushed some security updates to stable.

Xorg-Server 1.20.8-4

Fixes CVE-2020-14347. No manual user intervention needed. Just update regularly.

Avoid leaking un-initalized memory to clients by zeroing the whole pixmap on initial allocation.
This vulnerability was discovered by: Jan-Niklas Sohn working with Trend Micro Zero Day Initiative

Grub 2.04-11.1

Fixes Boot-Hole issue.
You need to re-install grub on your system to complete the security fix: Bios-MBR, UEFI Systems

Our current supported kernels

  • linux44 4.4.230
  • linux49 4.9.230
  • linux414 4.14.188
  • linux419 4.19.133
  • linux54 5.4.52
  • linux56 5.6.19 [EOL]
  • linux57 5.7.9
  • linux58 5.8-rc5
  • linux54-rt 5.4.44_rt27
  • linux56-rt 5.6.17_rt9

Package Changes (Wed Jul 15 22:32:50 CEST 2020)

  • stable community x86_64: 4048 new and 3980 removed package(s)
  • stable core x86_64: 73 new and 71 removed package(s)
  • stable extra x86_64: 1371 new and 1447 removed package(s)
  • stable multilib x86_64: 54 new and 54 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Pamac Update Indicator is black/invisible/blurry

See here for more information. Nothing to be concerned about.

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

telegram is not following gtk theme anymore

Settings > Advanced > System integration > Use system window frame

LibreOffice Fresh (at least Writer) is generally unresponsive (tab & Enter keys not working and other issues)

Leave all configuration files, extensions, etc. in place. Replace LibreOffice Fresh with LibreOffice Still.

Older issues

(2020-05-19) systemd 245.5 and old Plymouth

If you have an older Manjaro installation from 2017 or so, you might still have Plymouth installed. If you hadn’t updated it from AUR, it is recommended to remove Plymouth before you attempt to update systemd. If for some reason you updated already and now have issues, login to a TTY and disable Plymouth:

  • Ctrl + Alt + F3 and login
  • sudo pacman -R plymouth
  • you may want to check if the wanted display manager still works and enable its service if needed.

For more details and possible further steps on Plymouth removal see Plymouth - Manjaro Linux In particular you need to remove the “plymouth” hook from /etc/mkinitcpio.conf and rebuild your initramfs.

Search the forum for additional Plymouth troubleshooting. 0.9.4.r269.g23afdeb-2 should fix the issue.

(2020-04-19) System with amdgpu won’t reboot or power off correctly

This was a kernel regression and has been patched in 5.4.33-2, 5.5.18-2, and 5.6.5-2. Check again for updates.

(2020-04-18) nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention

This should normally been fixed by manjaro-system.

If you were using Pamac GTK and got an error message similar to the following (see screenshot below):
try first to simply restart the update with Pamac GTK. This should be enough to continue and finish the system update. Closing Pamac window may not be necessary. Normally, despite what the error message tells, the file conflict(s) should in fact be handled properly when manjaro-system got upgraded; hence restarting the upgrade right after should do the trick.

If the file conflict was not solved automatically by manjaro-system, update your system in a command-line interface with the following command to get through it:

sudo  pacman -Syu --overwrite /usr/lib\*/p11-kit-trust.so

(2020-04-18) Thunderbird might throw an error of older version available.

Use $ thunderbird --allow-downgrade from a terminal to fix it.

(2020-04-18) Thinkpad T460 (Intel Wireless 8260) bluetooth problems

If you have a Thinkpad T460 with kernel 5.5, Intel Wireless 8260 and experience trouble with bluetooth, just reboot several times.

(2020-04-18) Error: signature invalid

If you get:

Error: linux54: signature from "Bernhard Landauer <oberon@manjaro.org>" is invalid

You should follow the solution here

Reminder for Gnome users: How to upgrade within TTY?

In order to upgrade from Gnome 3.34 to Gnome 3.36, Manjaro devs strongly recommend to upgrade within TTY and not within a graphical session. Read the announcement above for the instructions on how to do the upgrade as recommended. For a more comprehensive guide on this subject, please read the following article in the FAQ: https://forum.manjaro.org/t/how-do-i-do-a-system-upgrade-within-a-tty/77286.

error: failed to commit transaction (conflicting files)

If you get

error: failed to commit transaction (conflicting files)
hplip: /usr/share/hplip/base/__pycache__/__init__.cpython-38.pyc exists in filesystem

Make sure your mirrors are synced and that you have manjaro-system-20200324-4 or newer installed:

$ sudo pacman -S manjaro-system

Sound issues

If you’re having sound issues (e.g. on Firefox, hardware keys, panel slider), try disabling User Themes, restarting and then enabling again.

firewalld>=0.8.1-2 update requires manual intervention

(From arch linux post)
The firewalld package prior to version 0.8.1-2 was missing the compiled python modules. This has been fixed in 0.8.1-2, so the upgrade will need to overwrite the untracked pyc files created. If you get errors like these

firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/__init__.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/client.cpython-38.pyc exists in filesystem
firewalld: /usr/lib/python3.8/site-packages/firewall/__pycache__/dbus_utils.cpython-38.pyc exists in filesystem
...many more...

when updating, use

pacman -Syu --overwrite /usr/lib/python3.8/site-packages/firewall/\*

to perform the upgrade.

Report any AUR breakage here.

1 Like

Since this release post is here I thought it makes sense to link to all the posts to the same thread in the archive.

Obviously new posts should go here and not there :slight_smile:

Let me close this post as we have a new stable announcement already.

1 Like