[Stable Update] 2019-07-03 - Kernels, Systemd, Pamac 8.0, KDE, XFCE, Browser, QT

Updated 2 systems, one VM (KDE) and one on bare metal (Gnome), via TTY. Other than the "audit directory permissions" issue, they updated without any issues. Fixed the "audit directory permissions" issue by following the instructions given in post #2.

 sudo pacman -Rd --nodeps linux50
1 Like

just informational if someone runs firejail:
firejail --overlay doesn't work with kernel 5.1.15 and 4.19.56 LTS
but works with 4.14.130 LTS. it's a known bug. https://github.com/netblue30/firejail/issues/2799

Mike

1 Like
mhwh-kernel -r linux50

or use gui manjaro-settings-manager (but not pacman or pamac)

First thing was that apparmor-profiles were not installed automatically even tough the old packages with all the profiles got removed so no profiles were loaded after reboot.

Now Samba does not start and I get the following message in /var/log/audit/audit.log:

type=AVC msg=audit(1562156219.492:137): apparmor="DENIED" operation="sendmsg" profile="smbd" name="/run/systemd/notify" pid=5829 comm="smbd" requested_mask="w" denied_mask="w" fsuid=0 ouid=0

I need advice how to fix that.

stremio-beta and qbittorrent broke after the latest update (in KDE). stremio-beta (also stremio-legacy does not work at all). From what I read, it is a problem with Qt 5.12.4
qbittorrent starts working properly after maximizing it. Then keeps working unmaximized until minimized.

Just tested my Filco bluetooth keyboard. It finally works!

The bluetooth HID problem on kernel 4.19 happened ever since 2019-05-17 Stable Update, but it is now fixed with this update. :smiley:

Update successfully but the translation in the KDE shutdown menu options (and login screen) are all gone. In last version, only the translation of 'shutdown' is missing.
Besides, for people who use bootsplash, the grub resolution is set to auto again after update, so you may want to adjust the grub resolution to make the bootsplash looks normal.
https://wiki.archlinux.org/index.php/GRUB/Tips_and_tricks#Setting_the_framebuffer_resolution

System information:

Summary
System:    Host: Tu-PC Kernel: 4.19.56-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.2 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASRock model: X299 Gaming K6 serial: <filter> UEFI [Legacy]: American Megatrends v: P1.60 
           date: 02/27/2018 
CPU:       Topology: Quad Core model: Intel Core i7-7740X bits: 64 type: MT MCP arch: Kaby Lake rev: 9 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 68760 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 801 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080] vendor: Gigabyte driver: nvidia v: 430.26 bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 430.26 direct render: Yes 
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Device-3: Logitech Webcam C930e type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-1:2 
           Sound Server: ALSA v: k4.19.56-1-MANJARO 
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: 3.2.6-k port: f000 bus ID: 00:1f.6 
           IF: enp0s31f6 state: down mac: <filter> 
           Device-2: Intel I211 Gigabit Network vendor: ASRock driver: igb v: 5.4.0-k port: d000 bus ID: 03:00.0 
           IF: enp3s0 state: down mac: <filter> 
           Device-3: Edimax type: USB driver: rtl8814au bus ID: 5-2:2 
           IF: wlp2s0u2 state: up mac: <filter> 
Drives:    Local Storage: total: 2.71 TiB used: 1.41 TiB (51.8%) 
           ID-1: /dev/sda vendor: Intel model: SSDSCKKW480H6 size: 447.13 GiB 
           ID-2: /dev/sdb vendor: Samsung model: SSD 860 EVO 500GB size: 465.76 GiB 
           ID-3: /dev/sdc vendor: Seagate model: ST2000DX002-2DV164 size: 1.82 TiB 
Partition: ID-1: / size: 423.26 GiB used: 111.07 GiB (26.2%) fs: ext4 dev: /dev/sda1 
           ID-2: /home size: 1.79 TiB used: 959.82 GiB (52.4%) fs: ext4 dev: /dev/sdc1 
           ID-3: /opt size: 457.45 GiB used: 368.10 GiB (80.5%) fs: ext4 dev: /dev/sdb1 
           ID-4: swap-1 size: 16.10 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 36.0 C mobo: 31.0 C gpu: nvidia temp: 54 C 
           Fan Speeds (RPM): fan-1: 881 fan-2: 2132 fan-3: 2705 fan-4: 966 fan-5: 865 gpu: nvidia fan: 0% 
           Voltages: 12v: N/A 5v: N/A 3.3v: 3.31 vbat: 3.17 
Info:      Processes: 263 Uptime: 2m Memory: 15.68 GiB used: 2.24 GiB (14.3%) Init: systemd Compilers: gcc: 9.1.0 Shell: bash 
           v: 5.0.7 inxi: 3.0.34

Just did the update and rebooted, no issues so far !

I had the same message for breeze dark, reapplied it and now everything seems fine - i didn't look into "get new themes" though

KDE updated fine from the terminal.

Many thanks to the Manjaro team.

I am having the same issue, Could you please tell me how you removed the symlink?

I get:
error: failed to commit transaction (conflicting files)
snapd: /snap exists in filesystem
Errors occurred, no packages were upgraded.

Temporarily, used --ignore to update the rest. What is the way to resolve this? I have snap packages installed, so I cannot not just remove snapd. Thanks.

Solution: I removed the symbolic link /snap. Then upgraded snapd. Snaps still working, so all is good for now.

Everything went smoothly so far... Just that did this "upgrade" just downgrade my kernel from 5.1.18 to 5.1.15? The reason behind it?

Woot, woot.... Mesa 19.1. Do we have Vulkan FreeSync now? :slight_smile:


I've got 2 warnings after the update was done. First one is described in the head post, and I did as was described there. I did a similar thing for the second warning, replaced path and package number respectively, as it seemed like the same problem. Did I do things right or do I need to do something different for the 2nd warning?

1 Like

have you checked in log ?

sudo journalctl -b0 -p4 

I just used sudo rm /snap

However I also disabled snapd.socket by running

sudo systemctl disable snapd.socket

and uninstalled the snapd package using pamac in order to revert to a system without snap at all. Then I updated my system from TTY. Uninstalling snapd may not be necessary but after the update, I installed gnome-software-snap which reinstalled snapd automatically (recreating the symlink too). All I had to do was restart the snapd service by running sudo systemctl enable --now snapd.socket. I now can use gnome software to access the snap store :slight_smile:

Hope this helps

2 Likes

Hi,

every thing went smooth. Just my touchpad settings have been resettet. But that was easy to fix!

Thanks for your work. A Manjaro newbie :slight_smile:

i got this
warning: /etc/lightdm/lightdm.conf installed as /etc/lightdm/lightdm.conf.pacnew

Hei people, I just added the following to /etc/apparmor.d/local/usr.sbin.smbd:

"/run/systemd/notify" rwk,

This fixed my problem, however I like some comment if this procedure is safe? Thanks in advance!

Forum kindly sponsored by Bytemark