No Sound (Temporary Fix) alsamixer MSI Ge75 Raider

Hello, this post is somewhat in reference to another post I was reading online which led me to find a temporary solution to a problem that seems to exist on some MSI laptops. I have figured out a temporary fix to this problem that seems to work on my laptop at least. Since I am a fairly new linux user I am trying to better understand this problem and how, once you see my fix, I could make this a permanent fix.
See similar post here: no-sound-at-all-msi-laptop/40789
Device-1: Intel Comet Lake PCH cAVS vendor: Micro-Star MSI
driver: snd_hda_intel

Key take away: When I boot there is no sound. Every time I start I have to first run alsamixer. Then I have to press F6 to select my sound card (HDA Intel PCH). Then I go to the “Headphones” option and have to turn it all the way up. Then I am able to use my speakers on my laptop as long as the program is running.

After I do these 3 steps upon booting the problem is temporarily fixed and I can play audio using my external speakers.

Is there a permanent solution for this?

You should be able to get the same result with one command

amixer --card=0 sset Headphone 100% unmute

You should also try this command to save the settings for ALSA

sudo alsactl store

I just added it those two lines of code to a then used chmod +x to make it executable then add it to startup programs. It works

amixer --card=0 sset Headphone 100% unmute
sudo alsactl store

Save as
Then make the file executable.

chmod +x /

Add to start up applications.

Should work on all OS.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.