Sshd not starting after update

Hi all, after the latest Manjaro-Update ( it was around 27. of Januray ), i couldn’t connect via ssh to my server anymore. Trying to connect fails with message “PRNG is not seeded”.
Then I tried to start sshd manually with sudo systemctl start sshd.service, but it fails with the error number 255.
I searched some hours, but didn’t find an actual result for this. It seems I’m the only one who has this problem actually!?

I fixed it temporary by going back with timeshift, prior to the update.

Is this a generell known problem which manjaro developers are aware of, or could this be only on my mashine?

Hi @miketuxedoo, and welcome!

Please post the output of:

sudo systemctl status sshd.service

:bangbang: Tip: :bangbang:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

sollicitudin dolor
eget nisl elit id
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

1 Like

I use ssh daily to various servers - no issues - so

Yes and no and perhaps. It depends on the kernel in use.

The message PRNG is not seeded seeems to indicate an issue with entropy.

Search the forum for entropy

Ah ok, i will do it right next time :slightly_smiling_face:

To get the error and a meaningful terminal output, I need to do the current outstanding update, but as this is my working mashine that i need, of course to work with ssh, i have to update at a later time to reproduce the error.

1 Like

Please install 2 kernels (one of them LTS)

This may help to prevent rollbacks in some cases :wink:

Today I tried one more time to update to reproduce the problem, but after this update, the probelm didn’t occure. IMO it has to do something with the update, because i didn’t touch anything related to ssh.

Thanks for your suggestions anyway!

This can be closed now

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.