Spellchecking not working

Hi,

For some reason spellchecking is not working despite having aspell and hunspell installed an apparently active.

TIA

It might depend on the application and the DE. Can you be more specific on what you installed and exactly which steps you take and what you see?

What is “DE”? This has been happening since I first installed Manjaro a few weeks ago.

It is happening in Mousepad , LibreOffice among others.

if i recall correctly i installed the language packs i wanted via pamac then had to go into system settings - language settings and fiddle in there too.

Sorry i cant be more descriptive im not at my manjaro pc right now

1 Like

Thanks, Alfy. If you have time to backtrack the steps you took, please let me know.

A “DE” is a desktop environment (Desktop environment - Wikipedia). In other words @mparillo asked if you are using KDE Plasma, XFCE, Gnome etc as every DE has its specific software installed by default and finding a solution for a given problem might depend on that.

1 Like

In LibreOffice, have you looked at the language preferences?
TOOLS > OPTIONS > LANGUAGE SETTINGS > WRITING AIDS

2 Likes

Ah, thanks. I’m using XFCE.

Thanks. (and also for the screenshot). Yes, dictionaries and modules are in place. I pressed ‘Apply’ and, although spellcheck is now working.

Thanks for your help!

After i installed the spell checker it did not initially show up as above, I had to install it here also:
System settings > language packs.
But this was on kde.

if leebut’s solution is enough then happy days. :slight_smile:

Thanks Alfy. I checked my settings and the screenshot shows language_packs that there are (apparently) packages available, but these additional packages can’t seem to be selected there, to be installed.

Having checked the installed packages, hunspell and aspell are installed, but are not working.spelling-available

hmm I dont know then.
perhaps someone who uses xfce can shed somne light on it for you.

1 Like

Thanks for all your help, Alfy.

I have fresh installation with Gnome DE and with LibreOffice 7.0.2.2 and the problem with spellchecking is same: Cannot modify section ‘Available language modules’, i.e. the ‘Modify’- button opens a new window ‘Modify modules’ and shows desired new language and list of possible spellchecking alternatives, but it is NOT POSSIBLE to select anything from the given alternatives, places for selection tick boxes are missing.

I checked my Ubuntu 20.04.1 LTS machine: there in LibreOffice spellchecking works well and correctly. The language to be checked in Finnish. In this machine I solved this problem by turning this machine from Manjaro machine to a dual-boot Manjaro + Ubuntu machine. All documents which I want to edit continuously, I keep in Ubuntu side. By making link to these documents into Manjaro I can open and work with them also from Manjaro, but spellchecking by LibreOffice is done in Ubuntu side. I little bit complicated but…

Is there anyone who can make a bug report to Manjaro about this this defect in the present Manjaro’s LibreOffice spell checking ?? Now in language modules it is not possible to modify selection of language modules, the tick boxes for selections are missing (in Ubuntu side they are in place and work OK).

I checked, that all 4 required additional software packages for the spellchecking are in place in this directory /var/tpm/pamac-build, but they cannot be opened /installed, because - as the Software loader informs - ‘’ …public key … (numer xyz) … is not recognized … Error: One or more signatures could not be checked. Process is terminated.’’ This is - maybe - why it is not possible to make required spellchecking selections in the Settings/Language settings of this LibreOffice.

Could someone just ask Ubuntu developers how they have solved this question, because there I have never seen this problem (have been using Ubuntu over last 6 years, now Ubuntu 20.04.1 LTS). :slightly_smiling_face:

Please look, how to allow to select correct check language in the LibreOffice 7.1 and 6.4.6.2 Settings/Language settings/Spellchecking. In my Ubuntu this has been Ok since many years, could please just copy how they have enabled it.

@Yochanan, thank you for reply ! Additional info: today 20.10.2020 ap I tried to download from AUR and install a package voikko 2.3-1 ( it is Finnish dictionary for libvoikko based spell chekers). I thought this might be a reason why the Finnish language spell checker Voikko (program package libvoikko 4.3-2) shows only the titles of the libvoikko spell checker program but without enabling any launching or selection possibilities LibreOffice Settings/Language Settings/Writing Asistant Tools sites. But package assembly process of this voikko 2.3-1 failed because (here my translation from Finnish to English:) ‘’…ERROR: One or more PGP signatures could not be checked’. Compiling failed.’’ I hope this info might give you a useful hint where to look for solutions to solve this problem. :slightly_smiling_face:

@ Yochanan, Here is the PGP signatture of voikko 2.3-1 package in form of writing and screenshot:

-----BEGIN PGP SIGNATURE-----

iQIzBAABCgAdFiEErF1l8QyFltfi2uJjPTCbYErjlC4FAlyDtBwACgkQPTCbYErj
lC6IyQ//cg0G4/f4tje9n67e6KBu/6Ipp6ChL+2CGJzCewcwVcBt1Hkd+vdJK1kd
g06qRRbUN6Fqrr8v4S8xx26ZcEGwV6Gv7wG0M+m5MVffOYvunO6tF84Wlw0Pvt8+
aqGZsqT5A5rIVLzCD/V0BEvOnaYyjSpNEpiQupFv1q3OegQO93Ne/MV3ps7uud2a
3FBQv+ZuIOJSY6fkXCxakWP1mLQaTjjoWGimjFOYbEMnapOiSjR9wx90TmisMVco
MaLn4/mcHSn5TDMC2k++k13idQMAm0+K4KsL2IJOU6FLorp47E2XfNaFHgG5FKIR
FjI0tAdKEY2VklzWfzds9hpQXA8fLFISYGuF5TJU6TabUTcf//7fFPrI//8VElrx
nonVKvlzLoXsxUyLjy/stkmEnWNpDCI1tNZCrd3uQBjNp/nxxGo/I2FNgROFCXjJ
EpLUmyqRCpKvD+aMgOq9s+2u2Uqku8I6oK396prIvRPx3cw/JPJIFcfWqFVqT7Rt
NIdZTf/+9fsVIwxuegcPx8pE+UScljs4JxxCTSfuuSnwKaGG6dnt4M2heLyXBMYw
vOF8CmTzlGYcgOrcsbN9RtEHpwhUf0I2vLAyqGj9SXkoVq2fHmdQNTU4uv1Zqwau
1t8VB5LwRe9f40JI3ubU4MrOXVulye/t4yPDkuEQvbouQIjmnWo=
=gcyG
-----END PGP SIGNATURE-----