Speakers quiet in GNOME, can only hear them when turned all the way up, HEADPHONES work fine

I’m trying to get my speakers working in GNOME. I ran alsamixer and turned the speakers all the way up but there’s only faint sound coming out of them. I have switched the soundcard from generic Nvidia to Realtek ALC887-VD and there’s no difference, but there are more settings for the Realtek card. Any help would be greatly appreciated. Thank you!

here’s output from inxi -Aa

Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel 
           v: kernel bus-ID: 08:00.1 chip-ID: 10de:10f1 class-ID: 0403 
           Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403 
           Sound Server-1: ALSA v: k5.10.49-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.31 running: no 

:+1: Welcome back to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

:+1:

P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

Thank you for sharing that tutorial, here’s the information from the terminal

System:
  Kernel: 5.10.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=40809886-d17c-433b-876f-89a03d053b64 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Desktop System: Gigabyte product: AB350-Gaming v: N/A serial: <filter> 
  Mobo: Gigabyte model: AB350-Gaming-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F21 date: 02/08/2018 
Battery:
  Message: No system battery data found. Is one present? 
Memory:
  RAM: total: 15.64 GiB used: 1.84 GiB (11.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001129 cache: L2: 3 MiB 
  bogomips: 76673 
  Speed: 2955 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 
  1: 2955 2: 2964 3: 1375 4: 1372 5: 2722 6: 2876 7: 1355 8: 1355 9: 1373 
  10: 1373 11: 1373 12: 1372 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate irperf lahf_lm lbrv lm mca mce 
  misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl npt 
  nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb 
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36 
  rdrand rdseed rdtscp rep_good sep sev sha_ni skinit smap smca sme smep ssbd 
  sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce topoext 
  tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI 
  driver: nvidia v: 470.42.01 alternate: nouveau,nvidia_drm bus-ID: 08:00.0 
  chip-ID: 10de:1c02 class-ID: 0300 
  Display: x11 server: X.org 1.20.11 compositor: gnome-shell driver: 
  loaded: nvidia resolution: <missing: xdpyinfo> 
  OpenGL: renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2 
  v: 4.6.0 NVIDIA 470.42.01 direct render: Yes 
Audio:
  Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 08:00.1 chip-ID: 10de:10f1 
  class-ID: 0403 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus-ID: 0a:00.3 chip-ID: 1022:1457 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.49-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.31 running: no 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: down mac: <filter> 
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl 
  v: kernel modules: bcma port: f000 bus-ID: 07:00.0 chip-ID: 14e4:43a0 
  class-ID: 0280 
  IF: wlp7s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Message: No bluetooth data found. 
Logical:
  Permissions: Unable to run lvs. Root privileges required. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 698.65 GiB used: 23.51 GiB (3.4%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB 
  size: 232.89 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 3B6Q scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3500312CS 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5900 rpm serial: <filter> rev: CA12 scheme: GPT 
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: BD-RE BH30N rev: A201 
  dev-links: cdrom 
  Features: speed: 40 multisession: yes audio: yes dvd: yes 
  rw: cd-r,cd-rw,dvd-r,dvd-ram state: running 
Partition:
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%) 
  used: 23.51 GiB (10.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 40809886-d17c-433b-876f-89a03d053b64 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: E832-7B45 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/sdb1 maj-min: 8:17 size: 465.76 GiB fs: <superuser required> 
  label: Drive uuid: 5f74d061-937c-4b67-992c-c063e03d7719 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 10 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-5:2 info: Corsair Gaming K70 LUX RGB Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s 
  power: 500mA chip-ID: 1b1c:1b33 class-ID: 0300 serial: <filter> 
  Device-2: 1-6:3 info: Logitech G502 Proteus Spectrum Optical Mouse 
  type: Mouse,HID driver: hid-generic,usbhid interfaces: 2 rev: 2.0 
  speed: 12 Mb/s power: 300mA chip-ID: 046d:c332 class-ID: 0300 
  serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 26.9 C mobo: N/A gpu: nvidia temp: 33 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 317 Uptime: 3m wakeups: 0 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: 1304 pacman: 1300 lib: 409 flatpak: 0 
  snap: 4 Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.05 

Beyond that, how do I edit my profile?

@n_b Go here

@nikgnomic I remember you telling me if I wanted to crank up my speakers about 2 years ago, but I was happy the way they were and as I never did any of that, I don’t know how to boost them…

:scream:

Thank you, I fixed my profile.

@Fabby Was there anything in the printout that looked like it might be the problem?

Only this:

so read this but that is unrelated to your issue…

(so even if you do that, the speakers will not be boosted)

OTOH, can you provide the output to

pacmd dump

:thinking:

You should consider updating motherboard BIOS - GA-AB350-Gaming (rev. 1.x) | GIGABYTE Global
that might improve onboard audio function

You can check ALSA settings for onboard audio device

alsamixer --card=1

or post response to this command to show settings in text format

amixer --card=0

ALSA controls should look similar to this linux-hardware.org scan from another Manjaro user with the same motherboard

Check that controls for audio outputs are unmuted and levels set correctly
Master, Headphone, PCM and Front
You might also need to unmute Surround Centre and LFE even if you are not using surround sound channels

In alsamixer use and to change levels
and M to mute and unmute controls

Make sure that setting IEC958 Default PCM is [off] (or shown as [MM] muted in alsamixer)

Try all 3 settings for Channel Mode - 2 4 and 6
I would suspect this setting in ALSA as the most likely to cause a problem with audio level

Desktop users usually want to change Auto-Mute Mode to Disabled so the rear headphone jacks are not muted when headphones are plugged in, but this setting will only mute the speaker outputs completely and would not cause reduced audio level

If any changes are made to ALSA settings use this command so the new settings are restored when system is restarted

sudo alsactl store
1 Like

@Fabby What is OTOH? Do you know how to select a particular partition for swap? I made a partition on my drive labelled /dev/sdb but when I use the wiki you shared it adds the entire drive as a swap.

Here’s the pacmd dump.

### Configuration dump generated at Tue Jul 27 10:35:20 2021

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_08_00.1" card_name="alsa_card.pci-0000_08_00.1" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_0a_00.3" card_name="alsa_card.pci-0000_0a_00.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0 xauthority=/run/user/1000/gdm/Xauthority
load-module module-x11-xsmp display=:0 xauthority=/run/user/1000/gdm/Xauthority session_manager=local/nicholas-ab350gaming:@/tmp/.ICE-unix/769,unix/nicholas-ab350gaming:/tmp/.ICE-unix/769
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_0a_00.3.analog-stereo 0x947c
set-sink-mute alsa_output.pci-0000_0a_00.3.analog-stereo no
suspend-sink alsa_output.pci-0000_0a_00.3.analog-stereo yes

set-source-volume alsa_output.pci-0000_0a_00.3.analog-stereo.monitor 0x10000
set-source-mute alsa_output.pci-0000_0a_00.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_0a_00.3.analog-stereo.monitor yes

set-card-profile alsa_card.pci-0000_08_00.1 off
set-card-profile alsa_card.pci-0000_0a_00.3 output:analog-stereo

set-default-sink alsa_output.pci-0000_0a_00.3.analog-stereo
set-default-source alsa_output.pci-0000_0a_00.3.analog-stereo.monitor

### EOF

@nikgnomic
My also controls are horizontal and have visual bars that show the volume levels above the numbers. I have unmuted everything and tried varying levels of volume on the speakers. When they’re turned way up I can hear them faintly. I turned off auto-mute. I do not see a Channel Mode.

Thank you both for your help.

https://duckduckgo.com/?t=ffcm&q=OTOH&ia=web

Okay thank you. Did the pacmd dump provide anything useful?

@Fabby

I did a test where I plugged my speakers into the headphone jack on the front and I had the same issue even though my headphones work through that jack. I tried headphones through the rear jack and still get regular sound. This must be a hardware issue. Thank you for all of the help and tips.

1 Like