Soundblaster Creative AE-5 Plus: No 5.1 Surround

Dear Manjarees,
I have recently updated my rack with the new Creative X AE-5 Plus. This caused trouble in the beginning, for it did not output any sound at all:

Fortunately, this problem is resolved! A kernel patch is available since 5.11. From that kernel version onward, the new 2020 version of the AE-5 (the AE-5 Plus) is supported out of the box in Linux. Thanks again to @nikgnomic for pointing that out.

Though the card is basically working in Linux, it does so only “kind of”: There is no analog 5.1 surround output available, also the microphone input is not working.

  • When switching to the “Analog 5.1 Surround + Analog Stero Input” in the audio setup using $ pavucontrol, I get a notification “No output device” and the Output Device tab shows a ports called “Dummy Output” resulting in: No sound.

  • When switching to “Analog Stereo Duplex” the Output Device tab shows the port “Line Out (plugged in)”, the Input Devices shows “Microphone (plugged in)”. This results in a working stereo sound output, but the microphone input does not work - it says plugged in, but does not get any input signal.

  • Knowing from several mentions of the original creator of the driver (conmanx360), $ pavucontrol is not optimal for the AE series. He recommends using $ alsamixer and switching to “Surround” in the “Output Select” tab. So I tried that, but unlike for its predecessor, the AE-5 Plus offers only “Speakers” and “Headphones” as available selection.

I assume, the cards do not differ much in hardware components. So I assume this is some kind of alsa channel mapping problem / driver problem. But I am not really advanced enough, to find the culprit.

Again, bummer. No 5.1 sound and worse, no microphone input.

Ok, I seem to be kind of alone with my problem - no wonder, the Soundblaster X AE-5 is not very common. In fact, having a dedicated soundcard is a niche by itself.
So anyway, if someone a bite more technically sophisticated than me comes across this, here are the tools used by the original author Conmanx360 to reverese engineer the driver:

Maybe that helps anyone.

How to solve this problem? Can anyone please help? Thanks.

Can’t really help if Kernel 5.11 isn’t working for you, but for future purposes if you want to get something that works with Linux 100%, get an external DAC from a company that actually supports Linux such as JDS Labs or Schiit. Any USB Audio Class 2 DACs should work out of the box on Linux.

Damned. Very sadly. I wasted my money . I`m pensioner. Pensioners are poor people in Russia.
No war. Freedom Navalny!

Hope for future fixes? For example, kernel 5.12. Thanks.

Well, because this soundcard have absolutely 0% official support, you’ll have to hope other users would reverse engineer it better.

You can install the release candidate from our repo if you want to try it.

The OP said that kernel 5.11 worked for them (to a limit), did you try that kernel yourself?

Manjaro 21.0.1, x64 - stable branch, kernel - 5.11.10, 5.12 rc5.
Ryzen 3900, DDRIV 64gb, MSI B550 Tomahawk, bios A64 [04/2021]
Creative SB AE-5 Plus, AC - JBL 305P MK II, headphones - AKG 612pro.
JBL are connected to Front & Rear terminals.

On: Front & Surround [4.0]
When output is 2.0 - sound from only one AC.

Players - Deadbeef, Audacious, QMMP.
Output - ALSA.

Is there sound. Customization is possible - alsamixer, qasmixer.

The sound is output through pulseaudio (?), Strong distortion. Including, with the scheme 2.0.

When outputting through headphones, everything is fine. There is no distortion of sound.
Is it distortion due to pulseaudio?
I can not understand anything. Nub. Sorry.

Thank you.

It worked yesterday. DOESN’T WORK today. f uck my brain. f uck off Creative!!! fucking shit.

Hi urgentus,

I did try using an AE-5 a while ago with Kernel 5.3 and it did not work well either.

As far as I can say, the Creative cards just do not work reliably in Linux. There seems to be an issue with the registers in the card itself not resetting properly and since the drivers are closed source, there is not much to do about it.

In my testing, the card sometimes worked, but mostly did not. Just as you were saying…
I did get it to work sometimes by dual booting into Windows and then doing a reboot into Manjaro. But even then only stereo output was working. There was no way to get proper surround sound with my AE-5.
There were issues in Windows as well after rebooting from Manjaro to Windows. So that was the point where I did give up…

I really dont understand your problems. As stated above, the card works fine from kernel 5.11+. The only problem is the stereo output instead of surround.

Yes… Stereo is working. But that isn‘t the point for installing a card like this. The whole thread is about getting 5.1 sound. It‘s in the title. :wink:

1 Like

True. :slight_smile: Unfortunately, this will not happen, unless someone picks up the pieces and keeps developing the reverse engineered driver. This is way too advanced for my skills unfortunately.

1 Like

You are right. And since these cards are way too niche, this is rather unlikely. Especially since they are behaving so strange and Creative does not provide a driver themselves.

1 Like

It is finally here! I don’t know who did it and how, but when using SPDIF, we finally have 5.1 Digital Out with the latest Kernel (5.16.2-1). Yay!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.