Sound Output Coming From Headphones and Internal Speakers

Hi folks,

I have an odd problem whereby the sound from my laptop is coming out through a speaker as well as through the internal laptop speakers. It doesn’t matter what I connect to the audio jack on the laptop. If it’s a speaker or a pair of headphones, the sounds still comes out of the laptop as well. I am not sure what is causing this. What details do I need to provide to help resolve this? Many thanks!

Hello @krabs :wink:

Does removing this module help?

sudo modprobe -r -v pcspkr 
1 Like

Thanks. Unfortunately it seems that this made no difference.

Interestingly, when I select ‘Speaker’ from the Port list as shown in the right of this picture, I get no sound at all. If I select ‘Headphones’, the sound outputs from both the laptop speakers and the external speaker or headphones (whatever is connected to the audio jack). I’m puzzled by this.

Could be a wrong pin mapping for your device.

Could you provide what system you are running?

inxi --admin --verbosity=7 --filter --width 
1 Like

Thanks I was just about to post that :slight_smile:

  Kernel: 5.16.2-2-rt19-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.16-rt-x86_64
    root=UUID=2836a4eb-b853-4176-a54b-316b57a3a67a rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HUAWEI product: HKD-WXX v: M1010
    serial: <superuser required>
  Mobo: HUAWEI model: HKD-WXX-PCB-B1 v: M1010 serial: <superuser required>
    UEFI: HUAWEI v: 1.18 date: 12/29/2021
  ID-1: BAT1 charge: 59.8 Wh (100.0%) condition: 59.8/59.7 Wh (100.3%)
    volts: 13.2 min: 11.6 model: SUNWODA HB5781P1EEW-31T type: Li-ion
    serial: <filter> status: full cycles: 15
  RAM: total: 15.42 GiB used: 3.41 GiB (22.1%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 11th Gen Intel Core i7-11370H bits: 64 type: MT MCP
    arch: Tiger Lake family: 6 model-id: 0x8C (140) stepping: 1 microcode: 0x9A
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 967 high: 1149 min/max: 400/4800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 932 2: 906 3: 966 4: 1051
    5: 1149 6: 823 7: 989 8: 920 bogomips: 52838
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vp2intersect avx512_vpopcntdq avx512bw avx512cd
    avx512dq avx512f avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts cat_l2
    cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16
    cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp hwp_act_window hwp_epp
    hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe movdir64b
    movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdt_a rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd
    sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc
    tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi
    vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: QUANTA
    driver: i915 v: kernel ports: active: DP-3 off: eDP-1
    empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:9a49
    class-ID: 0300
  Device-2: Luxvisions Innotech USB Camera type: USB driver: uvcvideo
    bus-ID: 3-6:4 chip-ID: 30c9:0041 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 676x380mm (26.61x14.96")
    s-diag: 775mm (30.53")
  Monitor-1: DP-3 pos: primary model: Samsung LF27T850 serial: <filter>
    built: 2020 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: eDP-1 note: disabled model: TL142GDXP02-0 built: 2021
    res: 2560x1440 dpi: 213 gamma: 1.2 size: 300x200mm (11.81x7.87")
    diag: 361mm (14.2") ratio: 3:2 modes: 2520x1680
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.3.8
    direct render: Yes
  Device-1: Intel Tiger Lake-LP Smart Sound Audio vendor: QUANTA
    driver: sof-audio-pci-intel-tgl bus-ID: 00:1f.3 chip-ID: 8086:a0c8
    class-ID: 0401
  Sound Server-1: ALSA v: k5.16.2-2-rt19-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:6 chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 32.63 GiB (6.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: 511BS0512GB size: 476.94 GiB
    block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
    type: SSD serial: <filter> rev: ECFO13.3 temp: 25.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 210.27 GiB size: 205.91 GiB (97.93%)
    used: 32.59 GiB (15.8%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: 2836a4eb-b853-4176-a54b-316b57a3a67a
  ID-2: /boot/efi raw-size: 200 MiB size: 196 MiB (98.00%)
    used: 46.4 MiB (23.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: SYSTEM uuid: 862E-ABBE
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 246.95 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 512 MiB fs: vfat label: WINPE
    uuid: 2430-EF1C
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 18 GiB fs: ntfs label: Onekey
    uuid: CAE03321E0331365
  ID-5: /dev/nvme0n1p6 maj-min: 259:6 size: 1024 MiB fs: ntfs label: WinRE
    uuid: CA94352194351185
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 2-3:2 info: VIA Labs USB3.0 Hub ports: 4 rev: 3.1 speed: 5 Gb/s
    chip-ID: 2109:0817 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 3-2:2 info: VIA Labs USB2.0 Hub ports: 5 rev: 2.1 speed: 480 Mb/s
    chip-ID: 2109:2817 class-ID: 0900
  Hub-6: 3-2.4:16 info: Terminus Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 1a40:0101 class-ID: 0900
  Device-1: 3-2.4.1:17 info: Areson Corp 2.4G Receiver type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 25a7:fa23 class-ID: 0301
  Device-2: 3-2.4.2:18 info: Microdia Redragon Mitra RGB Keyboard
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 400mA chip-ID: 0c45:5004 class-ID: 0301
  Device-3: 3-2.5:7 info: VIA Labs USB Billboard Device type: Billboard
    driver: N/A interfaces: 1 rev: 2.0 speed: 480 Mb/s power: 100mA
    chip-ID: 2109:8888 class-ID: 1100 serial: <filter>
  Device-4: 3-4:3 info: Shenzhen Goodix Fingerprint Device
    type: Communication,CDC-Data driver: N/A interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 27c6:5125 class-ID: 0a00
    serial: <filter>
  Device-5: 3-6:4 info: Luxvisions Innotech USB Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 30c9:0041 class-ID: fe01 serial: <filter>
  Device-6: 3-10:6 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-7: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 43.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 297 Uptime: 3h 14m wakeups: 1 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1257
  lib: 361 flatpak: 0 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.15

Ok it is a SOF Driver. No idea how to do that there. snd_hda_intel should also work: Intel Tiger Lake-LP Smart Sound Technology Audio Controller

So try this:

  1. stop pulseaudio:
systemctl --user stop pulseaudio
  1. remove the driver:
sudo modprobe -r -v sof-audio-pci-intel-tgl
  1. add this driver:
sudo modprobe -v snd_hda_intel
  1. check if it is loaded:
inxi -Aazy
  1. and start pulseaudio:
systemctl --user start pulseaudio

Here are models: HD-Audio Codec-Specific Models — The Linux Kernel documentation

Check which codec:

 cat /proc/asound/card*/codec* | grep Codec 

Sometimes it does not detect the correct one. Therefore it needs to be set like this:

sudo modprobe -v snd_hda_intel model=MODELNAME

:notebook: This only for temporary testing at this moment. A reboot will reset this.

1 Like

Instead that is a driver problem have you take a look if “Auto Mute” is enabled in Alsamixer?

You can start ‘alsamixer’ from terminal, choose the right soundcard with ‘F6’ and navigate to the right to the “Auto Mute”-option.

There were similar post in the forum, like this:

or this:

Perhaps it helps. :wink:

1 Like

Thank you! I’ve gone through this, but it still seems to be the same. @kisun may have a point about the auto mute option?

Thanks for this! You may be on to something. From the screenshot below, it looks as though auto-mute is disabled? How do I enable it? Thanks!

Sorry just to answer this as well. I think mine looks correct?

cat /proc/asound/card*/codec* | grep Codec                                                                                                                                                       ✔ 
Codec: Conexant CX8070
Codec: Intel Tigerlake HDMI

Oh ok, that one is really new. Nothing at the documentation. So forget about changing model.

1 Like

Arrow Key RIGHT → until Auto-Mute is highlighted → Press ENTER / Arrow Key Up/Down

1 Like

Thanks! I just enabled it. Now it only plays audio through the laptop speakers, but ONLY when something is connected to the headphone jack. Basically, the opposite of what it’s supposed to do. I’ll restart here and go through the settings again.

So it seems Manjaro thinks my headphones are my internal speakers. When I select the internal speakers, I get no audio. So it seems they are the wrong way around. I might just try a fresh re-install. Very odd problem!

It’s likely due to the ALSA path profiles.

You can find the relevant .conf file, make a backup copy of it, and modify the original file to correct the issue:


The config file of interest might be: analog-output-speaker.conf

You’re going to look for something like “Element Front Speaker” and an option for toggling the device, etc.

It’s convoluted, and the naming scheme is confusing. In fact, it’s different for each computer.

Maybe try this:

For the file analog-output-headphones.conf in the above directory, make a copy of it (for backup).

Then look for the section [Jack Front Headphone]

And change it to appear like this:

[Jack Front Headphone]
required-any = any
state.plugged = yes
state.unplugged = unknown

Then restart the pulseaudio service and/or reboot the computer.

See if you can now manually select between ports, to change which device outputs audio.

(Disable “auto-mute” which you did earlier, since you might not need it now. It’s up to you.)

1 Like

The problem for me was that my inputs for microphones and speakers weren’t correctly recognized.

Here’s the solution that I referenced that worked on Linux Mint and also later on Manjaro.

1 Like

Thanks for that. I edited the file (and backed it up), then restarted. It didn’t appear to make any difference. I then decided to go ahead and do a fresh install. The issue is the same. Incidentally, I dual boot this machine with Windows 11 and it works fine there.

I’ll have a read through the possible solution that @francois072 posted and see how that one goes. Thanks a lot for the help with this!

Thanks. I’ll have a read throught his!

The problem is, each laptop/desktop will require a different file / section to edit. That’s what makes it tricky. :confused:

Yes it’s a bit of a headache alright! Would be great if I could get this sorted. I really don’t like Windows 11, but find myself using it most of the time, purely because of this sound issue. I guess I will just need to be patient until I can get it sussed out.