Sound not working after upgrade

Tried deleting the cache already. No effect.

BTW, i’m new to Manjaro/Arch-based distros but babysit Redhat and Debian machines for a living. Could offer some qualified strace output or other debugging if a guinea pig is required.

I tested pulseaudio -k and it worked, but every time I turn on the PC I have to run the command, I thought it was wrong for the manjaro people to update the packages without knowing if they were without problems


Using KDE, I had the same issues after the update. Was on kernel 56 (Previously 54) updated to kernel 57. MSI Tomahawk (non-max) with latest BIOS.

My GUI audio settings were scrambled after the update and I had no sound output, I use speakers and USB headphones.

‘systemctl --user restart pulseaudio’ allowed me to change settings and recognise speakers and headphones. Fails to remember settings.

I can configure my stereo speakers to work but USB headphones appear only to work in the right ear. That might be a HW issue, so I’m to test them. I had no issues with Kernel 54/56 and associated updates previously.

I did a little distrohopping too, before more or less landing on Manjaro (Linux Mint, Solus, Ubuntu, Kubuntu probably a couple others). I used Manjaro XFCE before deciding I wanted a bit more customization that KDE offers. Never any sound issues before now. I still have to use Windows some for MS Office anyway, so I’ll just stick with that until this gets fixed.

1 Like

so there is still no solution but to run pulseaudio -k every time you restart the system?

The solution for snd-hda-intel:

Open /etc/modprobe.d/alsa-base.conf and add the following line at the end:

options snd-hda-intel dmic_detect=0

pulseaudio -k && sudo alsa force-reload

I switched to EndeavourOS yesterday and the sound works great on kernel 5.4, 5.7, and 5.8 so this is a Manjaro issue. It doesn’t look like there is a fix so I’m sticking with Endeavour for now. It’s pretty much the same as Manjaro since it’s based on Arch but updates come regularly rather than lump updates. Manjaro is still a great distro but this update didn’t go well.

1 Like

that may be due to

KDE audio controls not saving user settings in home folder databases

suggest install pavucontrol-qt to change audio settings as this is more likely to sucessfully update user preferences in databases
may only need to use it one time to force database refresh as sometimes the usual GUI controls start working again


I was affected by the same issue. My motherboard is:

Base Board Information
        Manufacturer: Micro-Star International Co., Ltd.
        Product Name: Z390-A PRO (MS-7B98)

I can confirm the above workaround works after a reboot: just install pavucontrol-qt and no additional actions needed. However, there should be a proper patch for this in the next update imo.

Thanks, @nikgnomic!

1 Like

I’m using the script previosly mentioned and that works for now. Anyway is a “patch” measure, by whyle we wait a finally fix.

So I did pulseaudio -k and that set my audio correctly and was working at Analog Surround 5.1 output and the speakers worked. I then installed pavucontrol-qt and made sure it was set to use Analog Surround 5.1 output. I rebooted and initially I thought it worked as Analog Surround 5.1 output was selected but there was no sound.! Changing the selection off of 5.1 and back to 5.1 fixed it but I believe once I reboot It will be messed up again. So unfortunately this did not fix it for me.

pavucontrol-qt did not work for me after reboot. so I’ll be sticking with Endeavour on this machine going forward. There doesn’t appear to be a viable fix for this issue and it will be weeks before the next update comes which may or may not fix this issue.

1 Like

It only seems to be an issue on KDE, not Manjaro in general. I had been curious to try the Gnome version so I installed that today and have no issues with sound or anything else after updating. I started to install ArcoLinux or something else, but Manjaro just feels like home now so thankfully switching to another DE seems to be a viable option.

will give that a shot. Just updated but issue is still there. Entering pulseaudio -k after boot fixes the sound. So at least there is that.

I logged in under GNOME and sound works but getting use to GNOME coming from windows will be a challenge.

this may be due to use of pulseaudio -k to restart pulseaudio

Pulseaudio may appear to restart ok, but it does not reload all the pulseaudio modules
modules are loaded at boot-time by script /usr/bin/start-pulseaudio-x11
one of the modules module-device-manager is only loaded if a KDE session is detected

user can check pulseaudio to confirm modules are not all reloaded correctly with:

pactl list short modules

or pasystray GUI

to restart Pulseaudio without losing modules

systemctl --user restart pulseaudio.service
1 Like

Yeah Gnome is probably the biggest departure from Windows, at least in the DE world. If it isn’t working for you, one thing you might try is changing the layout from the Manjaro Hello menu, one or two are more traditional with the panel and app menu on the bottom of the screen. Otherwise your best bet is probably something like XFCE or Mate.

I use XFCE and this is also an issue for me :frowning:
Unfortunately, pulseaudio -k hasn’t helped me either.

I created my first script ever in Linux and added it in the Autostart to execute at startup. It works for me. I will remove the script after each major update to see if they fixed it. Someone else replied that this is probably a race condition and this kind of confirms for me anyways that it is. Anyways I’m going to stick with Manjaro KDE.
sleep 15s
systemctl --user restart pulseaudio.service

PS. Remember this issue and failure signature originated with people with MSI B450 motherboards. I can’t speak for other motherboards as the symptoms and fixes may vary.


Another Update today. Still doesn’t work. Script still does though.