Sound not working after upgrade

@nikgnomic I did a fresh install of Manjaro Plasma and the sounds was working on kernel 5.6. I switched to kernel 5.4 and the sound issue returned after a full update.

When I run alsa-info.sh --upload I get a command not found.

I already updated the BIOS when I first built PC earlier this year. Seems like a good idea to update based on the improvements regardless of it fixing this issue. With out making any changes and with my sound currently working I ran `alsa-info.sh --upload and got following:

dmesg: read kernel buffer failed: Operation not permitted
Uploading information to www.alsa-project.org ... Done!

Your ALSA information is located at http://alsa-project.org/db/?f=eb9047692e8c90436edb501d6f0611011dff7c4b
Please inform the person helping you.

BIOS update went well but didn’t fix this issue. It is a good idea to keep the BIOS updated for all the additional benefits.

I got the operation not permitted as well when running also-info.sh --upload even when running the command in root.

Here is my alsa information: http://alsa-project.org/db/?f=824fac2a8d1074906074d6df0289f7f6c560f6d4

I downgraded to kernel 4.19 and sound is working but I have to unplug my USB headset and then plug it back in to get it working every time I boot. 5.8., 5.4, and 5.7 still not working.

Yeah unfortunately my PC will not work with that kernal. I think it needs to be at least 5.4 due to my Video Card being a Radeon 5600XT which came out in Feb-March time frame. From my journal I did see message :
Aug 18 18:21:52 sammy-ms7c02 plasmashell[1243]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_2a_00.4.analog-surround-41.monitor"

1 Like

Upgrade to Kernel 5.8.0-2 fixed for me.

Yep, mine is MSI too. Specifically a B450 Tomahawk. I’ve never had any issues until the update, I assume that’s the case for you as well?

I should also mention that in my earlier post I said it works when I select the kernel from advanced options, but that’s only partially true. My speakers work, but it doesn’t recognize a headset at all (which doesn’t work for me because my wife and I are both working from home in the same room).

1 Like

I updated to 5.8.0-2 and it worked at first but after rebooting it was still having issue. I can’t fully remove 5.7 as it says there are dependencies:
removing linux57 breaks dependency ‘linux57’ required by linux-latest

1 Like

@Gatorman60 The same issue. After some reboot with that kernel, sound does not work again.

I went ahead and updated bios from v3.6 to v3.7. and boot up and the analog-surround 5.1 option was available so I selected it. Here is the journal output of the action. Doesn’t make a whole lot of sense to me but maybe it does to someone:

Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: qrc:/plasma/plasmoids/org.kde.plasma.volume/contents/ui/ListItemBase.qml:151: TypeError: Cannot read property 'ports' of undefined
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: kf.i18n: "0 instead of 1 arguments to message {Mute %1} supplied before conversion."
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_2a_00.4.analog-surround-41"
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_2a_00.4.analog-surround-41.monitor"
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: file:///usr/share/kpackage/kcms/kcm_pulseaudio/contents/ui/DeviceListItem.qml:33: TypeError: Cannot read property 'width' of null
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_2a_00.4.analog-surround-51"
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_2a_00.4.analog-surround-51.monitor"
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: org.kde.plasma.pulseaudio: No object for name "alsa_output.pci-0000_2a_00.4.analog-surround-51.monitor"
Aug 18 21:53:15 sammy-ms7c02 plasmashell[1256]: file:///usr/lib/qt/qml/QtQuick/Controls.2/org.kde.desktop/ComboBox.qml:96:9: QML Connections: Implicitly defined onFoo properties in Connections are deprecated. Use this syntax instead: function onFoo(<arguments>) { ... }
Aug 18 21:53:23 sammy-ms7c02 dbus-daemon[510]: [system] Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
Aug 18 21:53:23 sammy-ms7c02 pipewire[1603]: [E][000000043.008200][bluez5-dbus.c:1436 get_managed_objects_reply()] GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut
Aug 18 21:53:23 sammy-ms7c02 kded5[1208]: kf.bluezqt: PendingCall Error: "Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)"
Aug 18 21:53:23 sammy-ms7c02 pulseaudio[1321]: E: [pulseaudio] bluez5-util.c: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)
Aug 18 21:53:24 sammy-ms7c02 kwin_x11[1212]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12977, resource id: 52428807, major code: 15 (QueryTree), minor code: 0
Aug 18 21:53:24 sammy-ms7c02 kwin_x11[1212]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12982, resource id: 52428807, major code: 18 (ChangeProperty), minor code: 0
Aug 18 21:53:28 sammy-ms7c02 xdg-desktop-portal-kde[1500]: xdp-kde-background: GetAppState called: no parameters
Aug 18 21:53:34 sammy-ms7c02 plasmashell[1256]: trying to show an empty dialog
1 Like

Pulseaudio works on my system, but I have to reload it manually.

Same here.I suspect some race condition.

  • No sound devices after logging in (sddm/Plasma) in 9 out of 10 times.
  • Changed my session options in KDE to start with clean session instead of saved one. No change
  • Manually issuing ‘pulseaudio -k’ gets things to work.
  • Added a new testing user with default settings. The issue appears to happen less often (50% of the time)

As a workaround i added a sesssion startup script with ‘pulseaudio -k’ which makes things work 98% of the time, but even that fails in rare cases. I’m using preload (if that’s relevant)

1 Like

I do too, with an script added to “startup applications”:

#!/bin/sh
sleep 5
pulseaudio -k
pulseaudio --start

Does fix it for a few times, but after some reboot, curiously pulseaudio stop working and does not recognize any audio chipset. I don’t know what to think.

1 Like

Facing the same issue after the latest upgrade, with MSI B450 Tomahawk, as the others mentioned. Using i3 with KDE (and sddm).

Had to restart pulseaudio, go to pavucontrol --tab 5 to enable the ‘Starship/Matisse HD Audio Controller’ and then choose it as the output device for sound to work. The extra steps were likely needed because there’s an extra audio controller from my graphics card, which got selected as main when the mobo one was not found.

3 Likes

@j00jitsu Another B450 Tomahawk user with this issue, very interesting. I have not had any issues with this motherboard prior to the update.

I did fresh installs of Pop!_OS, Kubuntu, and Fedora and the sound works fine on those distros with the latest updates. Pop and Kubuntu are running kernel 5.4 and Fedora was 5.7/5.8 I believe so those kernels all work fine in other distros.

I’ll be testing EndeavourOS today to see if it works.

I believe Pipwire is still working through it’s initial stages of development. Not certain what that error means.

pulseaudio -k didn’t work for me.

not sure about this MSI motherboard, but i recall that B450 motherboards had issues
and i do not think a solution found on old forum

search on bugzilla found this open bug report
Bug 195303 - AMD HD-audio controller: Sound capture is crackled / distorted

it appears that problems with this audio codec have not been resolved yet

I downgraded to kernel 4.19 and sound is working

if audio is working ok, suggest getting ALSA data with alsa-info.sh which could then be compared data from a non-working ALSA

but the ALSA data posted for kernel v5.4 is not showing any problems that i can see

suggest check for any error messages

sudo dmesg | grep snd

and

pacmd dump

to check pulseaudio

pulseaudio -k may appear to restart pulseaudio ok, but it will break some pulseaudio functions

  • the systemd pulseaudio.service may fail
  • some of the pulseaudio modules will not get re-loaded correctly
  • GUI controls in KDE may not work (because pulseaudio does not have module-device-manger loaded)
  • network audio device may not work (because two X11 modules are not loaded)
  • audio devices may get muted or suspended

suggest use this command to check if pulseaudio is ok

systemctl --user --full --no-pager status pulseaudio.{socket,service} 

and this to restart pulseaudio

systemctl --user restart pulseaudio
2 Likes

pulseaudio -k
pulseaudio --start

That’s redundant and does more bad than good.
The -k option does restart automatically. I’d try without the second line.

And BTW i have a B450 MoBo, too, so this seems chipset related

1 Like

In the “old” forum (sadly, the posts seem to have been deleted/privated), one solution would be to delete pulseaudios cache. I might need a refresher on path, but I do believe it was ~/.config/pulse/** or ~/.pulse. It had caused trouble in the past upgrade.

I had the same problem now – then I realized my headset was just unplugged because I had tripped on the cord.

1 Like