[Stable Update] 2020-08-16 - Kernels, Plasma, KDE Framework, Systemd, Pamac, VirtualBox, Firefox

Fine update here on gnome DE.
Grub-vanilla reinstalled and updated with no problem.
Before reboot, did this command, just in case.
sudo cp /boot/efi/EFI/manjaro/grubx64.efi /boot/efi/EFI/boot/bootx64.efi
Everything’s fine

i don’t use wine but I guess we have to close wine before the update.

you can re-install wine ?

remove wine
do update all
re install wine

sudo pacman -Rsn wine
sudo pacman -Syyu
sudo pacman -S wine
1 Like

/etc/sudoers has changed and removed the *wheel group?

the whell line can be disabled (#)
we have in this file @includedir /etc/sudoers.d/ read this directory

My GUI audio settings were scrambled after the update and I had no sound output, I use speakers and USB headphones.

‘systemctl --user restart pulseaudio’ allowed me to change settings and recognise speakers and headphones. Fails to remember settings.

I can configure my stereo speakers to work but USB headphones appear only to work in the right ear. That might be a HW issue, so I’m to test them.

Using KDE, was on kernel 56 (Previously 54) updated to kernel 57. MSI Tomahawk (non-max) with latest BIOS. I had no issues with Kernel 54/56 and associated updates previously.

Ref: Sound not working after upgrade

VirtualBox is broken:

Failed to open a session for the virtual machine Win7.

Failed to load R0 module /usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciR0.r0: SUP_IOCTL_LDR_OPEN failed (VERR_INVALID_PARAMETER).

Failed to load ring-0 module ‘VBoxEhciR0.r0’ for device ‘usb-ehci’ (VERR_INVALID_PARAMETER).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

= stat /usr/lib/virtualbox/ExtensionPacks/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciR0.r0
** File: /usr/lib/virtualbox/ExtensionPacks**/Oracle_VM_VirtualBox_Extension_Pack/linux.amd64/VBoxEhciR0.r0
Size: 19984 Blocks: 40 IO Block: 4096 regular file
Device: 805h/2053d Inode: 1973688 Links: 1
Access: (0644/-rw-r–r--) Uid: ( 0/ root) Gid: ( 0/ root)
Access: 2020-08-19 16:06:36.645922119 +0200
Modify: 2020-08-19 16:06:36.645922119 +0200
Change: 2020-08-19 16:06:36.659255576 +0200
Birth: 2020-08-19 16:06:36.645922119 +0200

VirtualBox is broken:

I had the same problem. Down grade to 6.1.10, and make sure you activate the ignore package upgrade.

1 Like

Everything went smoothly. Thanks Manjaro team!

Was able to update the mirrors by country, and update successfully.
sudo pacman-mirrors --country United_States && sudo pacman -Syyu

1 Like

My virtualbox works just fine (I use it daily for production work). I’m running the updated 6.1.12-3.

I primarily for work use a windows 7 guest, but I quickly tested my linux guests and all of them work fine.

I’m using the 5.7.14 kernel, what kernel are you running? Not everything is ready on the 5.8 kernel.

1 Like

I use always use LTS kernels 5.4.57, and 419 and 414 for backup.

Works quite well! Except the XPS 17 9700 sound issue, I still haven’t been able to get the sound card recognized. Any help on this matter would be appreciated, since the only solution I found online no longer works on kernel 5.8. I also might have tampered with my sleep settings a little too much because it’s no longer hibernating properly, but well…

Hmmm, downgrading VirtualBox to 6.1.10 didn’t work for me. Neither did 6.1.8. :frowning:

Did you try to set your Win7 VM USB controller to 1.1 instead of 2.0/3.0 in Virtualbox as a workaround ?

I’ve had same error and solved it by downloading Oracle_VM_VirtualBox_Extension_Pack-6.1.13-139853.vbox-extpack and replacing older extension pack with

sudo VBoxManage extpack install --replace ~/Downloads/Oracle_VM_VirtualBox_Extension_Pack-6.1.13-139853.vbox-extpack

But warning: this ext pack is a test version.

@ersatz, @fhins, shameless plug :innocent:

2 Likes

Sound not working after update to Linux kernel 5.7.14+/5.8.0+

Laptop updated and switched to latest kernel without a hitch - forum won’t let me edit my original post - this is weird.

cant get into login page on startup, after fresh install with 5.8 kernel. tty is working. i supose something wrong with gdm and nvidia drivers. using gnome btw.

Did you downgrade all of these? 6.1.10-1
virtualbox-ext-vnc
virtualbox-guset-dkms
virtualbox-guest-iso
virtualbox-ext-vnc