No audio card detected (dummy output) for pc with audiodriver snd-hda-intel

If inxi -F shows audiodriver= snd-hda-intel then:

Open /etc/modprobe.d/alsa-base.conf and add the following line at the end:

options snd-hda-intel dmic_detect=0


pulseaudio -k && sudo alsa force-reload

Then restart computer and check sound

Thanks for the solution. I think I have the similar audio driver.

inxi -F | rg snd
Audio:     Device-1: Intel CM238 HD Audio driver: snd_hda_intel

I did this.

cat /etc/modprobe.d/alsa-base.conf | xclip -selection clipboard
options snd-hda-intel dmic_detect=0

(Note: I had to create the file.)

alsa force-reload
fish: Unknown command: alsa

pulseaudio -k was successful.

After, reboot, the problem still persists. I am on kernel 5.8.0-2. Am I missing something?

Thank you,

lspci -nnk | grep -A2 Audio

What output gives this command?

in some cases You can edit the file blacklist.conf in /etc/modprobe.d/ with the following content at the end of the file:

blacklist snd_soc_skl

(If that file doesn’t exist, you must create it)

lspci -nnk | grep -A2 Audio
00:1f.3 Audio device [0403]: Intel Corporation CM238 HD Audio Controller [8086:a171] (rev 31)
	Subsystem: ASUSTeK Computer Inc. Device [1043:1bb0]
	Kernel driver in use: snd_hda_intel

Try again with the blacklist.conf file from above and then

pulseaudio -k && sudo alsa force-reload

reboot after that.

alsa command not found.
Rest of the process I repeated with both the files.

tree /etc/modprobe.d/
├── alsa-base.conf
├── blacklist.conf
└── mhwd-gpu.conf

0 directories, 3 files
bat -p /etc/modprobe.d/*
options snd-hda-intel dmic_detect=0
blacklist snd_soc_skl

## Generated by mhwd - Manjaro Hardware Detection

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
options nvidia "NVreg_DynamicPowerManagement=0x02"

EDIT : I retried the process with both the files, I dont think it’s gonna work.
Thanks :slightly_smiling_face:

The modprobe option in OP was a good workaround for disabling the digital microphone array in Intel laptops
but it is no longer viable for kernels v5.7.x and above
user on old forum (with kernel v5.7.0-3 posted) this message from system

Bad audio quality from earphones - Hardware - Manjaro Linux Forum

!!ALSA/HDA dmesg

[ 2.126856] snd_hda_intel 0000:00:1f.3: dmic_detect option is deprecated, pass snd-intel-dspcfg.dsp_driver=1 option instead

suggest users check for a similar message

sudo dmesg | grep snd

and replace options snd-hda-intel dmic_detect=0 with options snd-intel-dspcfg.dsp_driver=1

and more links explaining this here:
Audio output from firefox mixed with microphone

suggestion to disable DMIC is more a workaround than a solution

A working solution at the moment for many Intel laptops is:

  • kernel v5.7.x or later
  • install sof-firmware
  • install pulseaudio-git to get Pulseaudio RC v13.99

Archwiki - Lenovo ThinkPad X1 Carbon (Gen 7) #Audio