Sound is completely broken

Hi, I am new to linux. In short, my sound does not work at all.

Devices are found, however they don’t seem to function at all.

pulseaudio-git is not found when I tried following other peoples advice installing it (there was a fix for no sound in another thread)

Strange bug? F1 key backlight is always on (the mute button), it will not turn off, even after rebooting it turns back on. Clicking it shows mute/unmute on screen, but does nothing.

inxi -Fxi

Host: joseph-20qd001tus Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A Desktop: KDE Plasma 5.19.5
Distro: Manjaro Linux
Machine: Type: Laptop System: LENOVO product: 20QD001TUS v: ThinkPad X1 Carbon 7th serial: <superuser/root required>
Mobo: LENOVO model: 20QD001TUS v: SDK0J40697 WIN serial: <superuser/root required> UEFI: LENOVO v: N2HET51W (1.34 )
date: 06/08/2020
Battery: ID-1: BAT0 charge: 45.2 Wh condition: 53.6/51.0 Wh (105%) model: SMP 5B10W13931 status: Discharging
CPU: Topology: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake rev: C L2 cache: 6144 KiB
flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808
Speed: 700 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 700 2: 700 3: 700 4: 700 5: 700 6: 700 7: 700 8: 700
Graphics: Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0
Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo bus ID: 1-8:2
Display: x11 server: X.Org 1.20.8 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.7 direct render: Yes
Audio: Device-1: Intel Cannon Point-LP High Definition Audio vendor: Lenovo driver: sof-audio-pci bus ID: 00:1f.3
Sound Server: ALSA v: k5.8.6-1-MANJARO
Network: Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 2000 bus ID: 00:14.3
IF: wlp0s20f3 state: up mac: f8:ac:65:dd:da:4c
IP v4: type: dynamic noprefixroute scope: global
IP v6: 2601:645:102:c6f0::91b3/128 type: dynamic noprefixroute scope: global
IP v6: 2601:645:102:c6f0:8277:d978:eea2:b29d/64 type: dynamic noprefixroute scope: global
IP v6: fe80::7eec:97f8:6977:1484/64 type: noprefixroute scope: link
Device-2: Intel Ethernet I219-V vendor: Lenovo driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6
IF: enp0s31f6 state: down mac: 00:2b:67:ab:3d:28
Drives: Local Storage: total: 238.47 GiB used: 18.55 GiB (7.8%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: PC SN730 SDBQNTY-256G-1001 size: 238.47 GiB
Partition: ID-1: / size: 233.43 GiB used: 18.55 GiB (7.9%) fs: ext4 dev: /dev/nvme0n1p2
Swap: Alert: No Swap data was found.
Sensors: System Temperatures: cpu: 44.0 C mobo: N/A
Fan Speeds (RPM): cpu: 0
Info: Processes: 220 Uptime: 1h 55m Memory: 7.46 GiB used: 2.41 GiB (32.4%) Init: systemd Compilers: gcc: N/A
Packages: 1214 Shell: Bash v: 5.0.18 inxi: 3.1.05

Please let me know what else I can provide! Much appreciated

you need to add sound-firmware

sudo pacman -S  sof-firmware alsa-ucm-conf

see this

Hi Stephane, thanks for the reply.

I tried and it said already installed. I reinstalled, rebooted, turned master volume on in alsamixer and still nothing.

Any other ideas, or would you need any other info about my set-up?

Alrighty, it is fixed. I will do my best to explain so anyone who is in my prior situation can benefit.

Following reddit user wbeater’s advice, I installed pulseaudio-git. I then tried to do makepkg but it said PKGBUILD did not exist. Too complicated for me to attempt fixing. I made a new directory called pulseaudio-git. Tried to build there, did not work.

I returned to add/remove software gui and noticed that you could build the package there. I tried, but it had a bunch of dependency issues. I said screw it and deleted everything it told me to, and installed everything it told me to, then following another posts advice I rebooted, ran pulseaudio --start, pulseaudio -k and again pulseaudio --start.

From there, the sound worked!!! If anyone has any questions, feel free to ask, it is likely that I did more but just can’t recall properly at this time.

Best of luck, and thanks wbeater for saving my ass :smiley:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.