Sound cutting many times after installing manjaro-pipewire, can't install manjaro-pulse back

So I first had issues when connecting a bluetooth controller and my bluetooth headphones together as the sound was very weird so I tried installing manjaro-pipewire to maybe solve the problem. Now, my sound is cutting regularly when watching youtoube videos and from anything that produces sound.

EDIT: I tried this guide [HowTo] Troubleshoot crackling in PipeWire and nothing seemed to work

Welcome to Manjaro forum @Dustoe

Metapackages manjaro-pipewire and manjaro-pulse are intended to allow users to switch between audio servers easily, but manjaro-pulse does not work as intended
Cant switch back from manjaro-pulse to manjaro-pipewire to manjaro-pulse

PulseAudio packages can be installed discretely without using the metapackage:

  1. pamac remove manjaro-pipewire
  2. pamac install pulseaudio

    Do not select any additional packages when requested
    This should install pulseaudio and pulseaudio-alsa

  3. pamac install pulseaudio-bluetooth

I tried this and it fails as now everything sound related loads endlessly online.

Anyway, I found something out. The cutting only happens with my bose quiet comfort 35 (which are I guess higher quality so there might be something there). What options could I try changing to fix this issue?

EDIT: It’s the same wether it’s bluetooth or wired.

EDIT 2: Just to be clear, my headphones work on my phone and worked on Windows 10

I tried everything listed here [HowTo] Troubleshoot crackling in PipeWire

It only does this with my Bose QC 35 wether it’s wired or bluetooth.

It kinda worked as far as I can remember with pluseaudio but I can’t seem to switch back and don’t really intend to as there was issue with bluetooth and sound while connecting more than one device.

I tried this and it fails

If any of the 3 commands suggested to reinstall PulseAudio packages failed please post any error messages

now everything sound related loads endlessly online

I suggest you delete PulseAudio user settings from home folder to clear any old settings

rm ~/.config/pulse/*

and reboot system to ensure PulseAudio creates new, clean user settings files

If audio GUI controls are still unable to load correctly, check systemd units for errors

systemctl -l --no-pager --user status pulseaudio.socket pulseaudio.service

Ok now I don’t know what fixed it but it might be that I switched back to the most recent kernel. I’ll try what you suggested if it stops work

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.