Cant switch back from manjaro-pulse to manjaro-pipewire to manjaro-pulse

Yesterday by troubleshooting a HDMI audio issue on a laptop I was reinstalling Manjaro on, I had an issue. I don’t want support for that, I just want to let you know so you may have a look at it.

So I installed KDE, I switched from Pulse Audio to Pipewire by installing meta package manjaro-pipewire, it replaced all Pulse things, I rebooted, it worked. However when I tried to switch back to Pulse Audio, by installing meta package manjaro-pulse, there was a dependency issue and refused to install, if I recall correctly it was because of pulseaudio-bluetooth. I didn’t mark the exact issue but now that I remember that I wanted to bring the issue here so maybe you can see what’s wrong in the meta packages.

As said I don’t need support, just wanted to mention it on the forum so you’re aware of it.

You’re right:

$ pamac install manjaro-pulse
Preparing...
Synchronisiere Paketdatenbanken...

Choose optional dependencies for manjaro-pulse:
 1:  paprefs: Configuration dialog
 2:  pasystray: system tray application
 3:  pavucontrol-qt: A Qt volume control tool
 4:  pulseaudio-ctl: Control volume from the shell or mapped to keyboard shortcuts
 5:  pulseaudio-equalizer: Graphical equalizer
 6:  pulseaudio-equalizer-ladspa: A 15-band equalizer
 7:  pulseaudio-jack: Jack support
 8:  pulseaudio-lirc: IR (lirc) support
 9:  pulseaudio-rtp: RTP and RAOP support
10:  sof-firmware

Enter a selection (default=none): 

Resolving dependencies...
Checking inter-conflicts...
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'pulseaudio-bluetooth' required by manjaro-pulse

I think the problem is that pipewire-pulse provides pulseaudio-bluetooth which should be removed and replaced by pulse’s package with the same name.

1 Like

Additionally, if you manually add pulseaudio-bluetooth to manjaro-pulse to packages to install, it seems to work and you switch back to Pulse Audio.

:thinking:

❯ pacman -Si manjaro-pulse | grep 'Depends On'
Depends On      : pulseaudio  pulseaudio-alsa  pulseaudio-bluetooth

Did you try? install manjaro-pipewire then go back to manjaro-pulse tell me the result.

This is what I get:

Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …
:: manjaro-pulse und manjaro-pipewire stehen miteinander in Konflikt. manjaro-pipewire entfernen? [j/N] j
:: manjaro-pulse und pipewire-pulse stehen miteinander in Konflikt. pipewire-pulse entfernen? [j/N] j
Fehler: Vorgang konnte nicht vorbereitet werden (Kann Abhängigkeiten nicht erfüllen)
:: Unerfüllbare Abhängigkeit »pulseaudio«, benötigt von manjaro-pulse
:: Unerfüllbare Abhängigkeit »pulseaudio-bluetooth«, benötigt von manjaro-pulse
:: Entfernen von pipewire-pulse verletzt Abhängigkeit »pulseaudio«, benötigt von plasma-pa
:: Entfernen von pipewire-pulse verletzt Abhängigkeit »pulseaudio«, benötigt von pulseaudio-ctl

If installing manjaro-pulse + pulseaudio-bluetooth works, Is it possible to work around the metapackage by installing pulseaudio and selecting pulseaudio-bluetooth from optional dependencies ?

I suspect that manjaro-pulse might be failing due to pulseaudio-alsa dependency
before pulseaudio-bluetooth dependency

If pulseaudio is installed it does not ask user to install recommended dependency pulseaudio-alsa, package is installed automatically

IMO pulseaudio-alsa is not needed as a dependency for metapackage manjaro-pulse

If it’s not, then one might have the wrong package installed. If one is using PulseAudio, one needs pulseaudio-alsa. If one is using PipeWire, one needs pulseaudio-pipewire.

Disclaimer: The manjaro-pulse and manjaro-pipwire meta packages are only provided as a convenience. Manual intervention is required. There’s no way around it, unfortunately. If they’re causing too much confusion and problems, they can be dropped.