Sometimes the KDE WiFi daemon pops up and ask me for the password

Hello Everyone,

At the beginning of December I got new parts for my pc. I used the chance and started a fresh install of manjaro KDE.

Now to the problem: Sometimes the KDE WiFi daemon pops up and ask me for the password for the current network despite I already typed it in and it worked for some time. After inputting it again it will work. Sometimes for a long period and sometimes for only 5 minutes then I get the question again.

When I close the window I don’t get a connection. If then I open the WiFi menu and click connect, it connects without asking for a password and it works for some time.

I didn’t had this issue before, maybe it is due to the change of the motherboard. I don’t think the new CPU and GPU are the problem. My W-LAN adapter stayed the same.

My internet works over satellite so the connection by itself is unstable and on days with bad weather even more. I think t happens most often under these circumstances. But why does it happen now and not in the 3 years before?

Does anyone know a fix for this?

1 Like

No fix - it’s just a ping check for internet when Arch systems boot up, and it disappeared as soon as I finished writing down the solution.

It doesn’t happen during or after startup. There my pc logs in with out any problems. But in the middle of a session the window pups up and I have to type in the password.

This is really annoying when I want to download something and it fails due to lost connection. Or when I’m working and suddenly the WiFi-daemon demands my attention and the text gets inserted there instead. I would say on average it happens ones every two hours, sometimes more, sometimes less.

I’ve already tried to to load a Timeshift profile from after the installation and updated only Firefox, because I thought the problem happened after some updates. I mean I was able to download some games without ever getting a popup. But no, the problem is still there.

I could install a different distribution but I would like to have this as my last resort.

How to provide good information

But mainly I think I just want inxi -Nazy

$ inxi -Nazy:

  Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter driver: ath9k 
  v: kernel bus ID: 05:00.0 chip ID: 168c:0032 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASRock driver: r8168 v: 8.048.03-NAPI modules: r8169 port: f000 
  bus ID: 06:00.0 chip ID: 10ec:8168 

First easy check would be kernels.
I suppose you have newish CPU/GPU stuff so you can probably only go up…

I already had kernel 5.9 installed. I tried the experimental 5.10 kernel, but the issue still occurs. I will try to go down a few kernels and post an update.

Sadly with the 5.4.80 kernel it doesn’t work either.