Some apps use wrong theme on title bar

For example here Manjaro setting and VLC have wrong light theme. They should all have same dark bar like in nautilus. I use Yaru-Orange theme. How can I fix this?

Qt apps have separate theming from normal gnome apps. Their theme is set in the application called kvantum.

I saw it, I set there Yaru theme but its still like on image above.

Manjaro Settings and VLC are Qt applications. You’ll either need to select a matching Kvantum theme (like MateriaYaru, perhaps) from Kvantum Manager or not use Kvantum at all.

If you can’t find a matching Kvantum theme you like, you can let QGnomePlatform automatically attempt to apply a matching theme. To do that comment this line in /etc/environment like this:


You’ll need to reboot for changes to take effect.

I made this edit in /etc/environment and rebooted and there is no change :frowning:

Please post the content of /etc/enviroment using Preformatted text </> or between three backticks `

Also, verify you have qgnomeplatform installed and not qt5ct.

# This file is parsed by pam_env module
# Syntax: simple "KEY=VAL" pairs on separate lines




# Force to use Xwayland backend

#Not tested: this should disable window decorations


I had installed qt5ct, removed it and rebooted and its still not respecting theme.
qgnomeplatform is installed.

What if you use Adwaita, Adwaita-maia or Matcha?

Adwaita and Matcha works correct

Which Yaru theme specifically are you using and where did you get it from?

I tried yaru theme from AUR and yaru-orange from there GitHub - Jannomag/Yaru-Colors: A fork of Ubuntu's Yaru theme - in different colors

yaru-orange worked correct in other distributions. I dont understed why Manjaro somehow use light variant of theme theme for some apps.

Again, those apps you’re referring to are Qt apps. GTK themes only work with GTK apps. QGnomePlatform attempts, but if it can’t match the theme it should default to Adwaita. Alternatively, you can find a matching Kvantum theme.

But it use actualy yaru theme but for unkown reason light variant instead of selected dark.

Since it’s only happening with that theme, I would contact the theme developer.

Yeah, theme works correct on all distros that I tested - Ubuntu, Pop OS, Arch Linux, EndeavourOS, openSUSE, Gecko Linux, Fedora, Debian, CentOS, etc and the ONLY ONE where theme is broken is Manjaro… Come on man… Its not theme fault but distro issue…

Is it though?

On those other distros did you actually test QT applications?

Also … whats the configuration difference?
For example the env vars:


Or the ‘use dark variant’ setting … which is a user desktop setting, but we will check the config file:

grep "dark" ~/.config/gtk-3.0/settings.ini

(check on one of your other distros where it ‘works better’ … but remember that only counts if true for QT applications such as VLC, qbittorrent, etc)

Yes, I’m testing VLC and I dont play with configuration, just theme change.


Gives no output on Ubuntu 20.04 and openSUSE Leap 15.2

grep "dark" ~/.config/gtk-3.0/settings.ini

Gives this on both distros “gtk-application-prefer-dark-theme=0”

Mine also did this, although I knew why and didn’t “blame” others, I just didn’t know what I was missing where.

I think it was eventually sorted with the following configuration:

  • System settings > Appearance > Global theme, in the right bottom, click on Get new... and install a dark theme. (I’m using the “Arc dark” theme)
  • System settings > Appearance > Plasma theme, in the right bottom click the Get new... button and download a theme. (I’m using the “Arc dark” theme). Also, For dark themes, I recommend installing the “Oxygen” theme. (Don’t enable it, just install it)
  • System settings > Appearance > Application style (I suspect this is where the big thing is), click on the Configure GTK... button in the bottom middle of the window.
    • In the middle of the window, select the theeme you wish to use. (This is where the Oxygen download from earlier comes into play. I use Ocygen dark (or something like that)

Don’t forget to save/apply after each step.

I hope this helps.
(P.S. Don’t be rude to the people that are only try6ing to help.)

With that then I would advise commenting out all of those environment variables in your manjaro /etc/environment to compare.

@Mirdarthos Sorry, but I think you provided instructions for a KDE desktop, whereas OP is on Gnome

@cscs, you are absolutely correct, they are KDE instructions.

From the original screenshots it quickly looked like KDE to me. And from what I read here, it also looked that way.

But I see now that I saw wrong, and I humbly apologize and ask forgiveness.