Some applications do not start for a very long time

Since yesterday some applications mainly firefox, Konsole, System Settings, Elisa and KSysGuard are not starting after booting up.
They just don’t open, trying to open them through WezTerm does not do anything. No output, nothing.
They do suddenly open up after 45-70 minutes.
The only change I have made to the system that I remember was trying to get samba to work.

I have no idea what this could be. I hope someone can help me.
Also Kinit only gives me this prompt when typing “Kinit” into WezTerm:
kinit: Client’s credentials have been revoked while getting initial credentials
“sudo Kinit” returns this:
kinit: Program lacks support for encryption type while getting initial credentials

It is actually around an hour. This time it was application start attempt:
20:43 and applications starting: 21:42

Edit 2:
For context I am trying to start the applications through ulauncher, latte and WezTerm

Edit 3:
Krunner also does not start.

If the applications open normally on their own, then I suspect it’s a Wezterm problem, which I have no idea. Why are you running it and how?

I am only running WezTerm because it is the only terminal application I have that starts (over nautilus). I use nautilus for preference reasons.

Nautilus in KDE Plasma?
strange, but ok - but may also cause issues

… perhaps re-think your choice of desktop environment :slightly_smiling_face:

There should be Konsole (konsole) ant then there is many terminal apps to choose from
just need to install them.
xterm and urxvt are examples …

I am not sure what my choice of applications has to do with my problem here. I know there are other terminal applications.

I have chosen my desktop enviorment because I generally like KDE’s look and feel. I also use gnome applications because I think they are easy to use and generally work great.

I am not sure how making a support thread leads to getting critized over my choice of Desktop Enviorment and applications. I just asked a question and instead of answers to my problem I am just getting asked about my choices of applications that have no clear connections to the problem to me.

I also don’t usually use WezTerm, I try to avoid it, but I have to at the moment because Konsole won’t even start.

No one is criticizing you. You mentioned you use WezTerm and Nautilus which are not normal applications used with KDE. Therefore, those attempting to help you were curious why you were using them.

FYI, KDE and GNOME have their own set of applications built with their own toolkit. As you may already be aware, GNOME uses Gtk while KDE uses Qt. Usually users do not like pulling in all the extra dependencies just for one application.

Either way, you have not provided enough information for anyone to help you. No one can reproduce your issue.

Please see:

Without additional system information, there is nothing to go on from here.

How do you start the applications that work? Could you try start the faulty ones the same way?

Thank you for the clear answer. I may be a little too defense, I have had not great experiences getting help in linux communities sadly. I may have been to quick to pick this up as general critique.

I am aware of the differences between GNOME (dependance on GTK2/3/4) and KDE (dependance on QT).

System Information:
DE: KDE Plasma 5.26.4
KDE Framework: 5.102.0
QT Version: 5.15.8
Kernel Version: 5.15.93-1-MANJARO (64-bit)
Graphocs Platform: X11
CPU: Intel i9-9900k
GPU: RTX 4080
GPU Drivers: video-nvidia & video-linux

The applications that work are some of my applications in autostart, namely Protonmail bridge, discord, jetbrains toolkit, mailspring (which are as far as I know electron or custom java frontend based).

I start applications either through ulauncher or latte dock. Some that start are:

  • Ungoogled Chromium
  • Nautilus
  • WezTerm
  • Add/Remove Program
  • Signal
  • Bitwarden
  • Spotify

What I have noticed is that as far as I know all of these application are either based on Electron or GTK if I am not mistaken. All applications that don’t start are based on QT (not sure about firefox but I think they have a QT Frontend right?).

I tried opening all mentioned non working applications per command in WezTerm, through ulauncher and by latte dock:

  • Firefox
  • Konsole
  • Elisa
  • System Settings
  • KSysGuard
  • Krunner

I have also tried restarting, which sadly has not fixed the issue. The applications are trying to start in the background though. Both times after nearly exactly one hour firefox, konsole, elisa, etc. opened multiple times (equvilantly to how often I tried to open them through latte dock/ulauncher).

Is there any output running any of the applications from the terminal? The most common here would be Firefox no matter what DE or WM on is using.

Sadly there is no output. When I tried “firefox”, “konsole” or “elisa” it did not give me any output. It also did not start anything. I waited ~5 minutes on all 3 before I stopped the it with CTRL+C.

I have just restarted and it seems to work now, I have tried a few things though and I am not 100% which of these fixed the problem.
There are a few solutions that I have tried:

I first tried removing some applications from my startup (I suspected something on there was causing some problems).

I then tried this command (from this thread: Konsole not working in Dolphin):

sudo pacman -Syu --asdeps kinit

I then tried to reinstalling some packages to see if that works with this command (not sure from which thread I have got that):

sudo pacman -Syu attica kactivities karchive kauth kbookmarks kclock kcodecs kcompletion kconfig kconfigwid
gets kcoreaddons kcrash kdbusaddons kdeclarative kglobalaccel kguiaddons ki18n kiconthemes kio kirigami2 kirig
ami-addons kitemviews kjobwidgets knotifications kpackage kservice ktextwidgets kwallet kwayland kwidgetsaddons kwindowsystem kxmlgui plasma-framework solid sonnet

And at last I tried to disable samba, suspecting that it may mess with my startup. I mainly suspect that something messed with my startup somehow:

sudo systemctl disable smb
sudo systemctl disable samba
sudo systemctl disable samba.service

I am not entirely sure which of these attempts currently seemed to fix the issue and if it is just more of a temporary bandate than a sufficent fix to the problem.
Applications now start when trying to open them through ulauncher and latte dock.

I have also noticed that the keyring or some kind of authentication with a KDE service now does not show up on login. Usually I log into KDE and I have to put in my password again on some popup for some KDE service, this popup now does not show up anymore.

The issue also could have been related to Kvantum. I did update Kvantum manager before doing the restart that fixed the issue.

Always reboot after a stable branch update.

I am. :wink: :point_up:

I reboot after every update directly. Oh I just remember there was an update I just did to Kvantum manager which may be the cause of the issue, seeing as only QT applications did not work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.