[SOLVED] Nvidia proprietary 390 and GLX

I’m sure this is related to the decision to remove older Nvidia drivers, but I just want to confirm and figure out what my options are. I am using the latest LTS kernel (5.4.85-1) on my system with the Nvidia 390xx drivers. I just updated today and my OpenGL hardware acceleration stopped working, it will only load the Mesa drivers instead of the Nvidia GLX module.

[     4.248] (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
[     4.248] (EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
[     4.248] (EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
[     4.248] (EE) NVIDIA(0):     you continue to encounter problems, Please try
[     4.248] (EE) NVIDIA(0):     reinstalling the NVIDIA driver.

I am actually running games on the system, granted they are all quite old. But still, running Unreal Tournament 2004 at 3 to 6 frames per second really sucks with Mesa. I was getting 100+ previously.

What are my options to get the GLX driver working properly again? Is this related to the kernel itself or Xorg?

I’m having the same issue. Does anyone know if downgrading the NVIDIA driver to an older version would be a temporary solution to get NVIDIA GLX working again under XOrg?

I am also in the same boat. Please help us out here!

I’ve solved as suggested in other forum post ( [SOLVED] GT520 + linux54 5.4.85-1 + linux54-nvidia-390xx 390.138-2 = absolutely terrible performance) By adding

Section "Files"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"

to /etc/X11/mhwd.d/nvidia.conf (the problem was loading the “wrong” libglx.so with llvmpipe as a renderer)


Thank you for finding this, worked like a charm!

I followed @philm’s instructions in his post (#86) at Dropping all legacy and older Nvidia drivers ?!? and that got NVIDIA GLX working again with XOrg for me with the 340xx driver series.

Thank you @philm!!!


cat /proc/driver/nvidia/gpus/0000:01:00.0/information
Model: GeForce GTX 560
IRQ: 136
GPU UUID: GPU-d4b3bf21-97b7-dbde-1ef5-21cf6b4445b6
Video BIOS:
Bus Type: PCIe
DMA Size: 40 bits
DMA Mask: 0xffffffffff
Bus Location: 0000:01:00.0

cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module 340.108 Wed Dec 11 11:06:58 PS
T 2019
GCC version: gcc version 10.2.0 (GCC)

grep ‘NVIDIA GLX’ /var/log/Xorg.0.log
[ 19.379] (II) NVIDIA GLX Module 340.108 Wed Dec 11 14:26:50 PST 2019

uname -a
Linux calypso 5.10.2-2-MANJARO #1 SMP PREEMPT Tue Dec 22 08:14:42 UTC 2020 x86_
64 GNU/Linux

Thank you a lot everybody! @ilbeppe solution worked perfectly!
Thought I would have to get a new GPU or PC right away.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.