[SOLVED] manjaro failed to start Remount Root and Kernel File system

I use Manjaro Cinnamon everything is OK. my system works fine, but I would like to know what it means?

Execute the command from the error message and post output.

● systemd-remount-fs.service - Remount Root and Kernel File Systems
   Loaded: loaded (/usr/lib/systemd/system/systemd-remount-fs.service; enabled-runtime; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2019-04-16 10:26:55 EEST; 26min ago
     Docs: man:systemd-remount-fs.service(8)
           https://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
  Process: 245 ExecStart=/usr/lib/systemd/systemd-remount-fs (code=exited, status=1/FAILURE)
 Main PID: 245 (code=exited, status=1/FAILURE)

Apr 16 10:26:55 office systemd-remount-fs[245]: mount: /: can't find UUID=a74453b1-72c4-48a8-a34e-e6d7751e70eb.
Apr 16 10:26:55 office systemd-remount-fs[245]: /usr/bin/mount for / exited with exit status 1.
Apr 16 10:26:55 office systemd[1]: systemd-remount-fs.service: Main process exited, code=exited, status=1/FAILURE
Apr 16 10:26:55 office systemd[1]: systemd-remount-fs.service: Failed with result 'exit-code'.
Apr 16 10:26:55 office systemd[1]: Failed to start Remount Root and Kernel File Systems.
Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

Please also post output of
lsblk -f

NAME   FSTYPE LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                        
└─sda1 ext4            e1a933fa-a813-4d71-a9fd-dc98e936c2af  263.4G    37% /
sdb                                                                        
├─sdb1 ext4            e4fcf224-9b8c-4866-a687-6fec3f814bb0  228.8G    61% /mnt/e4fcf224-9b8c-4866-a687-6fec3f814bb0
├─sdb2 ntfs   Recovery 4EA4FC24A4FC0FE7                                    
├─sdb3 vfat            90FD-648B                                           
├─sdb4                                                                     
└─sdb5 ntfs            34DAFF50DAFF0CBC

Please use code tags next time (it's the </> icon).
Do you have an entry for that UUID in your /etc/fstab?

fstab file:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
#
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=a74453b1-72c4-48a8-a34e-e6d7751e70eb /              ext4    defaults,noatime 0 1
/dev/disk/by-uuid/e4fcf224-9b8c-4866-a687-6fec3f814bb0 /mnt/e4fcf224-9b8c-4866-a687-6fec3f814bb0 auto nosuid,nodev,nofail,x-gvfs-show 0 0

Any thoughts?

The UUID for / in fstab doesn't correspond with the UUID from lsblk.
Honestly, no idea how that happened, especially because you say that your computer works.

thanks for your time.

You have to find out what you have done wrong and repair it. IMHO, it is a matter of time that your system will break with your current (posted) settings.
I assume it still works because of grub, but please provide more info and in no case you should run "grub-install" until the problem is solved.

inxi -Dpuo
grep -i cmdline /etc/default/grub
cat /proc/cmdline
grep ^HOOKS /etc/mkinitcpio.conf
findmnt -s

If it's a UEFI system/installation, also this

efibootmgr -v

And output of

sudo blkid

Output:

sudo blkid
/dev/sda1: UUID="e1a933fa-a813-4d71-a9fd-dc98e936c2af" TYPE="ext4" PARTUUID="aba55750-7400-465b-ae9b-070f23e346bc"
/dev/sdb1: UUID="e4fcf224-9b8c-4866-a687-6fec3f814bb0" TYPE="ext4" PARTUUID="3d18acb8-12fc-454a-8b81-eca9d31a66e8"
/dev/sdb2: LABEL="Recovery" UUID="4EA4FC24A4FC0FE7" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="65487012-ec9b-4c66-b2a3-1fb74fddfe94"
/dev/sdb3: UUID="90FD-648B" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="370a28e2-1239-4640-aab1-8d5b94fc24fa"
/dev/sdb5: UUID="34DAFF50DAFF0CBC" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="8bef30bc-d7ec-4ce7-8ecb-c64ded632202"
/dev/sdb4: PARTLABEL="Microsoft reserved partition" PARTUUID="e8495af4-bebd-47b9-82ae-86d386db67c3"

Change your fstab to the correct uuid. Reboot.
Let us know if error message is gone.
As petsam infers (which you did not provide output), check also your /etc/default/grub and see if uuid listed correspond with blkid (always use blkid, not other commands which gives uuid but may not be updated) and your /etc/mkinitcpio.conf (which petsam also infers) for resume (swap).

These are commands that if you run in a terminal they produce output with info to potentially help understand the issue. Post this output in a post.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark