[Solved - kind of] Anbox - Manjaro 5.4 VS Zen Kernel

Hello everyone,
I’m trying to install Anbox for quite a while with different methods, but none is working.

  1. I tried to compile Linux ZEN kernel v5.9.6-zen1 but for some reason, the Kernel freezes at log in. I see the log in desktop, but can’t type anything nor can I move my mouse

  2. I tried out an older kernel - the 5.4, but can’t find anbox-modules-dkms-git anywhere. The Arch Wiki says, it was removed from the repo and I can’t find any tar gz files.

2 might be simpler to resolve than 1, basically I don’t care which kernel out of the two I have as long as Anbox runs.

I tried the git-hub installation instruction on my 5.4. and it worked! But right now it seems like some apps cannot be installed, I get the error message

adb: failed to install pleco.apk: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]

Funny thing is, I installed anbox some months ago on another machine with Manjaro 5.4. and the exact same apk file could be installed.

Hello,

Take a look at some pointers here:



1 Like

Thanks!

I did know the problematic about ashmem and binder, but this was new to me:

Otherwise, I got rid of the error by just rebooting and trying again, its seems.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.