How to install anbox on manjaro?

hi there i have using manjaro for six months and have been in love with it . I was wondering is there any way to install anbox in manjaro

Have you tried the AUR package?

Also available as snap:

So, just enable either snap or aur in pamac and search for anbox.

i have tried the snap but it just states starting and then closes the anbox

What output do you get if you try running it in terminal? Is the snapd service active? You can check with systemctl status snapd. If snap simply doesn’t work, you can try aur.

AUR’s Anbox is not working with kernels 5.7 or above, 5.6 down is working without a problem, check if Snap has this same problem.

this is my output

snap service is active

with kernels >=5.7 binder and ashmem are in the kernel, but must be activated in config before building. However, it looks like it was not activated in the manjaro config from my testing as I cant seem to start binder. So it may require a kernel build, or rolling back to 5.6 and installing the anbox dkms.

I have yet to recompile the kernel to test it, but the Arch Wiki explains it: Anbox - ArchWiki

@Strit I dont know if you can confirm or deny the kernel config thing, but it would be good to know.

They are not present in the ARM mainline kernel at least.

Thanks! That helps to know on the pine64 side of things, @Chrysostomus can you give any info on the x86 side? Do you know if the configs are set by default?

The related config parameters are not in the kernel configs. I tried adding them according to the Anbox ArchWiki entry to the 5.8 kernel config… but it seems to be incomplete (or out-of-date) as during build it additionally prompted me for things like ION Memory Manager, ION System Heap and binder test related options.

However, after building the modules do not seem to be really working… Anbox complains about either ashmem or binder were not active, and I couldn’t find anything related to them so I can’t really tell whether the modules were really built or not.

Unfortunately I cannot go down to 5.6 in this case (currently only the rt variant is still in the repo), as my video card (Radeon 5700 XT) is not quite stable until 5.7 kernel.

I think anbox support would be a good addition to Manjaro. Let’s see what it would take.

2 Likes

Hi. There were some topics about anbox on the previous forum. Maybe some of them can help.
https://archived.forum.manjaro.org/search?q=anbox%20order%3Alatest

3 Likes

when anbox support for 58 kernel?

as far as I know it needs to be enabled in the kernel, I personally haven’t tried it yet, but wait eagerly for it to be enabled as stated on arch wiki.

It would be really nice to have out of box support for anbox, being able to install it through pacman, (im not particularly fond of snap) but using the AUR is fine because you can choose what image to use

Unless the latest Manjaro kernel config correctly enables building ashmem and binder (as well as other Android-related stuffs), Anbox won’t work there.

Unfortunately 5.6 kernel is now EOL and only the rt version is still available. I currently have a different system that is currently forced to stay on the 5.6-rt kernel as I intend to test Anbox on it…

The main concern, however, is that without out-of-box support in the official kernel and requiring one to manually build the kernels with the added options, would make updating system harder since it’s no longer just a simple pacman -Syu anymore as official kernel updates (that do not include your changes) would break things again unless you always remember to manually rebuild it with your configs/patches included.

true, but of you are fine with compiling your own kernel and are just using it for testing purposes, compile the kernel using a custom name thing so it doesnt get overwritten by updates, and then try and use kexec to swap to new kernel, though i haven’t used kexec for a long time it MAY work??? im not to sure, but you would defo have to start anbox manually instead of just enabling it in systemd

I would love to see it integrated natively into the manjaro kernel though

Just tried to compile manjaro with the config changes outlined by arch wiki and for somereason they just get ignored and im not sure why I’m afraid

EDIT: it worked once i manually enabled it with nconfig

@schinfo agreed to test enabling anbox support in our official kernel. I’ll see what we can do about adding anbox to the repos.