[SOLVED] KDE Plasma in black screen when using Nvidia drivers

Hello everybody,

I know that there are many posts about this issue (and I know that there are many because I looked in many of them) but I cannot solve my problem with existing posts. The problem is, I don't want to use Nouveau drivers and I want to use KDE Plasma with Nvidia proprietary drivers.

I have i7 7700HQ (UHD Graphics 630) and GTX 1050Ti on my laptop.

I managed to install GNOME on Arch Linux using Nvidia drivers but I really dislike GNOME. For the last 2 days I've been trying to install KDE Plasma on Arch Linux (I will get to the Manjaro point, okay). It works with Nouveau drivers, or Intel Integrated Graphics (with SDDM). However, when I force it to use Nvidia drivers, it gets stuck in a black screen. I had access to TTY. I used many solutions, using "acpi_osi=! acpi_osi="Windows 2009" when boot, or blacklisting i915 and intel_agp, or installing Bumblebee, and many other solutions that I don't remember.

Then, I gave up and decided to install Manjaro KDE. However, again, on live boot it can use Nouveau drivers but it cannot use Nvidia drivers. When I select "non-free" before live boot, it boots with Integrated Graphics.

So, I decided to post this here. Can I use Manjaro live boot in order to post logs here, since the problem seems to be exist in there? And if I can, could you please help me and tell me which logs I should post to enable you to help me? Thank you in regards.

I feel (and i almost never use that word in a technical related topic) that you are trying to solve the drivers problem on live environment. Make the install as you can, then on installed system chose how to use the iGPU + dGPU or just one. Here are the options:


Chose only one, don't mix. As always i will recommend Optimus Switch. Is straight forward, advantageous and has clear instructions for each DM.

maybe you will still require custom kernel boot parameters, like:

and in some circumstances, the haveged service needs to be enabled.
systemclt enable haveged --now
it will ask for your password and the next reboot should get you directly to the desktop interface.

2 Likes

@tungstensteelwrench
install using the free drivers, get manjaro updated, and do what @bogdancovaciu suggested. it will work.

2 Likes

Thank you very much for your replies. Manjaro is freezing so much on my system, now I can't even open terminal and run commands, including TTY. When I solve this problem, I will apply your suggestions and reply.

Hello again. KDE Plasma really disappointed me; however, I managed to use Nvidia drivers with Xfce on Manjaro 18.1.0 with your solution. @bogdancovaciu thank you very much for your reply, and @dglt thank you for Optimus Switch.

2 Likes

Forum kindly sponsored by Bytemark