[Solved]GDM does Not Start after Update

I installed Manjaro on a new Laptop. Everything worked as expected. After I did an update and tried to reboot i am left with a blank screen. However if I go to tty2 and then to tty1 the boot process continues normally and i get into the system.

So far i have tried:

  • using LightDM, this created the same issue.
  • SDDM worked, but I had graphical glitches
  • not performing the Update, this left me with an acpi_video0 error

I’ve had the same issue for the last month or so. I have yet to find a fix.

See here for some steps that (didn’t work for me) might work for you.

Thank you. I will try it. :slight_smile:

No none of the recommended changes worked. But still think you.

Check in /etc/X11 for the existence of the xorg.conf file.

I experienced this problem with Nanjaro/Gnome, using Wayland with an Nvidia GPU and the proprietary driver. Spelunking around revealed there was no xorg.conf file in /etc/X11.

My fix was to log out of the Wayland session, log back in with an X.org session (click on the little gear in the lower right corner on the password screen to open options), select Gnome on X.org and then enter my user password where indicated.

The session came up normally using X.Org as the display manager.

Once there, I opened the Nvidia setting application (does not work in Wayland), clicked on the “X Server Display Configuration” selection, clicked on the “save to X configuration file” option. Didn’t make any changes to configuration.

Closed the Nvidia application, logged out of the X.org session and at this time selected the “Gnome” option from the password entry screen. The Wayland session opened normally and I haven’t experienced the blank login /GDM failed to start on boot issue since.

The file ist present and I am also using an AMD Processor with integrated graphics.
Still thank you.

Since I dont rely in using Manjaro. I switched to Fedora and everything works fine there. Still I dont know the cause of the issue. Thanks for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.