Unable to reach the login screen unless I swtich through ttys a few times

About 9/10 times, when I reboot or cold boot, I am left on a black screen with a blinking cursor. I used to just hold the power button to force shut down my laptop and boot it again, and usually on the third try I was able to log in.

Recently, I realized instead of force shutting down I can just cycle a few ttys (for instance tty4-tty6-tty2-tty1) to be able to get the login screen to show up and allow me to login.

While not a deal-breaker it is certainly annoying. Anything I’m doing wrong?

It’s a fresh Architect installation, using Gnome, nvidia-hybrid-440.100, kernel 5.8.0-2.


Can you share the:
inxi -Fxza --no-host
mhwd -li

if i’m not mistaken should be video-hybrid-intel-nvidia-440xx-prime but we have to make sure is not any bumblebee there. Also some laptop models need some custom kernel boot parameters, so maybe this will help

Thank you @bogdancovaciu for getting back to me.

Here is the requested information:

System: Kernel: 5.8.0-2-MANJARO x86_64 bits: 64 compiler: N/A parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=2bcd1344-6222-4bb4-84a1-c3e46883dc32 rw quiet udev.log_priority=3 Desktop: GNOME 3.36.4 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 Distro: Manjaro Linux Machine: Type: Laptop System: ASUSTeK product: FX503VD v: 1.0 serial: <filter> Mobo: ASUSTeK model: FX503VD v: 1.0 serial: <filter> UEFI: American Megatrends v: FX503VD.308 date: 04/29/2019 Battery: ID-1: BAT1 charge: 52.4 Wh condition: 52.4/64.4 Wh (81%) volts: 5.2/15.2 model: ASUS A32-K55 type: Li-ion serial: N/A status: Full CPU: Topology: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: D6 L2 cache: 6144 KiB flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20004 Speed: 800 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled Type: mds mitigation: Clear CPU buffers; SMT disabled Type: meltdown mitigation: PTI Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling Type: srbds mitigation: Microcode Type: tsx_async_abort status: Not affected Graphics: Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:591b Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK driver: nvidia v: 440.100 alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1c8d Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-7:4 chip ID: 13d3:5666 serial: <filter> Display: x11 server: X.org 1.20.8 compositor: gnome-shell driver: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa resolution: <xdpyinfo missing> OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 20.1.5 direct render: Yes Audio: Device-1: Intel CM238 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 chip ID: 8086:a171 Sound Server: ALSA v: k5.8.0-2-MANJARO Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8168 IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: d000 bus ID: 04:00.0 chip ID: 8086:24fd IF: wlp4s0 state: down mac: <filter> Drives: Local Storage: total: 1.14 TiB used: 165.54 GiB (14.1%) SMART Message: Required tool smartctl not installed. Check --recommends ID-1: /dev/sda vendor: A-Data model: SU800NS38 size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 8BS scheme: GPT ID-2: /dev/sdb vendor: Seagate model: ST1000LX015-1U7172 size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT Partition: ID-1: / raw size: 237.97 GiB size: 233.24 GiB (98.01%) used: 22.44 GiB (9.6%) fs: ext4 dev: /dev/sda2 Swap: Kernel: swappiness: 3 (default 60) cache pressure: 50 (default 100) ID-1: swap-1 type: file size: 10.00 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile Sensors: System Temperatures: cpu: 45.0 C mobo: N/A Fan Speeds (RPM): cpu: 0 Info: Processes: 216 Uptime: 1m Memory: 15.52 GiB used: 1.16 GiB (7.5%) Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1128 lib: 396 Shell: Bash v: 5.0.18 running in: gnome-terminal inxi: 3.1.05


`> Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

video-hybrid-intel-nvidia-440xx-prime 2019.10.25 false PCI

Warning: No installed USB configs!`

@bogdancovaciu I read through your post about choosing an ACPI argument but I’m still unsure which one is right for me.

My Laptop was running FreeDOS when I bought it, not Windows, not any Linux distro.

Not sure if ACPI kernel boot parameters would be required for your laptop model, but AFAIK the acpi_osi=! acpi_osi='Windows 2012' works in most cases. A second guess would be acpi_osi='Windows 2018'

Is hard to tell, so probably a bit of tinkering and experimenting/testing is required from your part.
What i want to make sure is that you have installed only the video-hybrid-intel-nvidia-440xx-prime driver, and no other. Not sure when the video-hybrid-intel-nvidia-450xx-prime will arrive to stable branch, but that might be best choice and hassle free option. (based on rumors, not tested by myself, so don’t quote me on that) :slight_smile:
mhwd -li
will display what drivers you have installed. Remove any other driver if is installed except the mentioned one. Then, i would add this kernel boot parameter nouveau.modeset=0

Once this is done, you should have a functional laptop and be able to make use of the prime-offload capability, aka run prime-run glxinfo as example, so prime-run application would launch that application using the dGPU (Nvidia).

To have even more options and control over this, the optimus-manager would be a good choice. I had no time to bring the old tutorial here from the archived forum, so i apologize to send you over there to check it out. Let me know how it goes.

Installed PCI configs:video-hybrid-intel-nvidia-440xx-prime            2019.10.25               false            PCI

Warning: No installed USB configs!

As far as I can tell I only have the video-hybrid-intel-nvidia-440xx-prime driver. and prime-run glxinfo works just fun, as do other apps and games.

My only issues (besides the NVENC deal, already reported) is how my laptop boots, or rather doesn’t.

Great, we render out the possibility of a faulty driver install, so now we move our focus on GDM and/or check if there is another DM installed?
What is from TTY the status of GDM?
systemctl status gdm

Once you log in with startx (i suppose) or is that the login screen only gets accesible once you cicle trough multiple TTYs, what is the session type, X11 or Wayland?
To find out run this command from terminal:

Now, if the login screen comes to “life” after you cicle trough TTY, then installing and enabling haveged might be helpful.
sudo pacman -Syu haveged
systemctl enable haveged --now
then reboot the system.

Sorry for the crappy picture, I don’t know how to copy from tty.

Regarding echo $XDG_SESSION_TYPE it’s X11

I’ve done

sudo pacman -Syu haveged
systemctl enable haveged --now

but that didn’t seem to do anything, I still need to cycle through ttys a few times before going back to tty and being able to log in.

Thank you very much for your ongoing assistance.

Possibly unrelated, but I got this error Possibly missing firmware for module: xhci_pci when I ran sudo mkinitcpio -P && sudo update-grub

This is preventing the login functionality:

gkr-pam: unable to locate daemon control file

That can happen because of a couple of reasons, so we can try to fix without entering in a lot of details, just run from terminal:
dbus-launch gsettings reset org.gnome.clocks world-clocks
in case time settings is an issue.

More extreme (you will lose all custom settings but have them in that backup file):
mv ~/.config/dconf/radu ~/.config/dconf/radu.bak

More direct and with no backup, run this:
dconf reset -f /

Reinstalling some packages might also help:
sudo pacman -Syu gdm gnome-shell gnome-keyring libgnome-keyring

dbus-launch gsettings reset org.gnome.clocks world-clocks


No such schema “org.gnome.clocks”

I tried dconf reset -f /

I tried sudo pacman -Syu gdm gnome-shell gnome-keyring libgnome-keyring

to no avail. Issue remains

You mean after reboot?

Yes, @bogdancovaciu after reboot I am greeted with a black screen and a blinking cursor. This time, not even switching ttys allowed me to log in. I had to force shutdown by long-pressing the power button, boot again to the same black screen and blinking cursor, cycle through a few ttys and only then was I able to get to the login screen.

There is something else going on there, please see this and follow accordingly and see the linked topics to it too:

Have you tried a different Kernel?

I’ve tried 5.6, 5.7 and 5.8. they all do the same.

Very strange indeed, could you check your logs after a successful boot if there is any indication of what causes it?
Run bmenu if it’s already installed, press D in the main menu and check options 5,6,7

Yeah… well… I wouldn’t know how to read those logs. All that programmer talk means nothing to me. I have just started using Linux this spring, after having been on Windows exclussively for the last 20 years.

We can try to take a look on the logs if you post them here :slightly_smiling_face:. Let’s start with:

journalctl -p 3 -x

sudo dmesg -T --level=err,warn

And these only after a succesful reboot?