[Solved] Failed Boot after recent update -emergency shell

After the recent update, my current installation of Manjaro KDE fails to boot properly,
When trying to boot only the following is displayed:

Warning: /lib/modules/5.10.2-2-MANJARO/modules.devname not found - Ignoring
mount: /new_root: unknown filesystem type 'ext4'.
You are now being dropped into an emergency shell.
sh: can't access tty; job control turned off
[rootfs ]# _

the computer is entirely unresponsive at this point… not sure what to do or what exactly went wrong

See This thread: Manjaro does not boot after update - emergency shell

sudo manjaro-chroot -a
pacman -S linux510

Allowed the my system to boot, thank you

This helped me to recover my Manjaro GNOME laptop - thank you!

My disk is encrypted so I had some additional steps. Here is what worked for me after booting from live usb (sudo pw is ‘manjaro’ btw):

sudo cryptsetup luksOpen /dev/nvme0n1p2 encrypted_device
sudo mount /dev/mapper/encrypted_device /mnt
sudo manjaro-chroot /mnt
pacman -S linux510