[SOLVED] Computer doesn't shut down

I just recently installed Manjaro on my PC and I’m very new to this.
When I shut it down by selecting “Shut Down” from the “log out” menu, the computer just doesn’t shut down, but I noticed these things happening:

  • The motherboard’s logo (the same one that shows up when I turn the computer on) stayed on the screen for a long time.
  • I turned the monitor off and didn’t see everything that happened, but when I came back after ~20 minutes and turned the monitor on, there was a terminal screen with a bunch of messages on it.

I know that I need to share certain log files to help find out what the problem is. What commands do I need to run to share these files?

Could you give more info? Like your motherboard manufacturer (the one with the logo) Did it happen before? Did you try manually shutting down the pc? Can you run any commands on the terminal that showed up?

My answers will depend on these answers. °_°

Hi @steveRoll, and welcome!

If you can run commands, in other words, if it’s not frozen, also pate/provide us with the output of the uptime command.

$ uptime
14:42:54 up  5:46,  3 users,  load average: 0.17, 0.20, 0.25

This should, at least in theory, tell us whether the shutdown ever occurred or not. I know it doesn’t look like it did, but we all know that looks can be deceiving.

My motherboard is a Gigabyte B365M DS3H.
Last time I shut it down, the shutdown just took a very long time. But this time, there simply was no shutdown at all.
The only way to shut the pc down after that was to press the small reset button on the pc itself, it did not respond to anything else.
Pressing any keys didn’t do anything either, so I couldn’t type any commands in there.

I would post an image of what the terminal looks like… but unfortunately, the forum doesn’t allow me to upload images or links. So I don’t know how to share it :confused:

Who said you cant upload images? There is a trick to do it

Use the preformatted text widget on the top. Then paste the link of the link. That should do it.

Like this:- https://google.com

You can upload both text as well as screenshots to https://0x0.st/

Hope this helps

Ah ok, I got it. Here’s the image: https://imgur.com/a/eJjkhzL
Those last 3 lines repeated a bunch of times.

Please forgive the quality, I hope it is readable.

Does that happen everytime u try to shut down?
Does the keyboard work on the terminal? Try ctrl+c. That helped me kill processes on boot.

I tried pressing Ctrl+C - it just typed ^C in the terminal, but other than that didn’t really do anything. The same messages kept appearing.

For some reason your X session is not ending as it should. I notice from your screenshot you appear to be running kernel 5.9, which I believe is end of life - it might be worth seeing whether there is a driver issue fixed with a later or LTS kernel. Also, you write that you have a Gigabyte motherboard, which reminded me of this similar sounding issue I read about: Killing Xorg fails on reboot/shutdown. It turned out for the poster there that a different BIOS version fixed the issue (wifi route cause apparently). What graphics card and driver are you using? What display manager?

I am using Xfce. I have a GTX 1660ti and I’m using proprietary drivers.
How is 5.9 kernel already end of life? I installed Manjaro quite recently.
In any case, I will try updating the BIOS and see if that helps.

Manjaro is not in control of the Linux kernel itself. Switch to an LTS version for longest support, (5.4 or 5.10, which is set to be the next LTS version).

In case you were wondering, a BIOS update won’t change that. However, Manjaro is awesome and makes it very easy to up- and downgrade kernels.

You can either do it from the GUI from the “Kernels” window in system settings somewhere (don’t know where as I don’t use Xfce.) Or you can do it from the command line with mhwd-kernel

$ sudo mhwd-kernel -i linux54

to install kernel version 5.4m or

$ sudo mhwd-kernel -i linux510

to install kernel version 5.10. Followed by

$ sudo mhwd-kernel -r linux59

to remove the current version, 5.9.

I just tried installing both 5.10 and 5.4 - neither have fixed the issue.

how did u do it? did u not first remove 5.9 then install something else?

$ sudo mhwd-kernel -r linux59
$ sudo mhwd-kernel -i linux510

Using the GUI, but yeah, that’s what I did. First I tried 5.10, then did the same with 5.4. Both of them didn’t fix the problem.

Did gigabyte update BIOS for your motherboard? Updating BIOS often solves problems like this

Fair warning: I have never done, or even tried to do this. So I have absolutely no idea what to expect or not to expect and can not take responsibility for anything if it goes wrong!

Try installing wayland and see is that works.

$ pacman -Syu plasma-wayland-session

The, hold your breath, cross your thumbs, and


This should, theoretically, give you an option at the next login, somewheree on the screeen, to select wether you’d like to use X or Wayland. Choose wayland and see if the problem persists. If not, you can choose whether to remove X and keep Wayland or remove X, remove all X configurations and install X again.

If it does, I have no further idea.

PLEASE DONT DO THAT!! wayland may (or may not!) solve the problem this time but that could bring a billion problems on the future. Having several WM’s also brings problems. I wouldn’t recommend using wayland even on an as flexible os as manjaro. Try something else. I once installed wayland on arch and i still regret that.

But maybe try the last few lines @Mirdarthos sayed.

remove all X configurations and install X again.

How can I do that?