[SOLVED] Bluetooth acting weird while connecting Sony WH-1000XM3

So first of all, here is my inxi -Fazy output:

  Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=4700295b-0f6c-46ad-82ec-bee656250e5f rw quiet 
  resume=UUID=66c33a9c-460a-466e-8672-e83fff93c450 udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Dell product: XPS 13 9370 v: N/A serial: <filter> 
  Chassis: type: 10 serial: <filter> 
  Mobo: Dell model: 0F6P3V v: A00 serial: <filter> UEFI: Dell v: 1.13.1 
  date: 07/08/2020 
Battery:
  ID-1: BAT0 charge: 43.0 Wh condition: 47.9/52.0 Wh (92%) volts: 8.4/7.6 
  model: SMP DELL G8VCF6C type: Li-poly serial: <filter> status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 32012 
  Speed: 900 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 895 2: 854 3: 897 
  4: 819 5: 832 6: 844 7: 827 8: 839 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel 
  bus ID: 00:02.0 chip ID: 8086:5917 
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo 
  bus ID: 1-5:2 chip ID: 0bda:58f4 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 168 size: 290x170mm (11.4x6.7") 
  diag: 336mm (13.2") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.8.16-2-MANJARO 
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  vendor: Bigfoot Networks Killer 1435 Wireless-AC driver: ath10k_pci 
  v: kernel port: f040 bus ID: 02:00.0 chip ID: 168c:003e 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 62.55 GiB (13.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB 
  size: 476.94 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: AADA4105 scheme: GPT 
Partition:
  ID-1: / raw size: 459.76 GiB size: 451.54 GiB (98.21%) 
  used: 62.53 GiB (13.8%) fs: ext4 dev: /dev/nvme0n1p2 
Swap:
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.88 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 37.0 C mobo: 30.0 C sodimm: 30.0 C 
  Fan Speeds (RPM): cpu: 0 
Info:
  Processes: 217 Uptime: 12m Memory: 15.34 GiB used: 1.92 GiB (12.5%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1132 lib: 350 
  Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05 

I am running a Dell XPS 13 9370, however, Blueooth is acting weird when I am trying to connect my Sony WH-1000XM3 wireless headset.
When opening the Bluetooth icon and select ‘Set Up New Device’ (I am using ‘Blueman’) it pairs succesfully, however, it does not auto-connect but immediatley disconnects.
When I manually connect the headset kind of freaks out, it/she keeps telling me that she is connected, and it loops very fast.
I have tried sudo systemctl start/restart/enable bluetooth to no avail. I have tried switching kernels, also did not help.

Here is the output of sudo dmesg | grep Bluetooth :

[    3.329867] Bluetooth: Core ver 2.22
[    3.329887] Bluetooth: HCI device and connection manager initialized
[    3.329891] Bluetooth: HCI socket layer initialized
[    3.329893] Bluetooth: L2CAP socket layer initialized
[    3.329897] Bluetooth: SCO socket layer initialized
[    3.451682] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    3.451684] Bluetooth: BNEP filters: protocol multicast
[    3.451689] Bluetooth: BNEP socket layer initialized
[   10.641376] Bluetooth: RFCOMM TTY layer initialized
[   10.641383] Bluetooth: RFCOMM socket layer initialized
[   10.641391] Bluetooth: RFCOMM ver 1.11

And here is the output of journalctl | grep Bluetooth (October 21) :

okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: Core ver 2.22
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: HCI device and connection manager initialized
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: HCI socket layer initialized
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: L2CAP socket layer initialized
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: SCO socket layer initialized
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: hci0: using rampatch file: qca/rampatch_usb_00000302.bin
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: hci0: QCA: patch rome 0x302 build 0x3e8, firmware rome 0x302 build 0x111
okt 21 01:50:52 dell-xps-13-9370 systemd[1]: Starting Bluetooth service...
okt 21 01:50:52 dell-xps-13-9370 bluetoothd[769]: Bluetooth daemon 5.55
okt 21 01:50:52 dell-xps-13-9370 systemd[1]: Started Bluetooth service.
okt 21 01:50:52 dell-xps-13-9370 systemd[1]: Reached target Bluetooth.
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: hci0: using NVM file: qca/nvm_usb_00000302.bin
okt 21 01:50:52 dell-xps-13-9370 bluetoothd[769]: Bluetooth management interface 1.18 initialized
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: BNEP filters: protocol multicast
okt 21 01:50:52 dell-xps-13-9370 kernel: Bluetooth: BNEP socket layer initialized
okt 21 01:50:59 dell-xps-13-9370 kernel: Bluetooth: RFCOMM TTY layer initialized
okt 21 01:50:59 dell-xps-13-9370 kernel: Bluetooth: RFCOMM socket layer initialized
okt 21 01:50:59 dell-xps-13-9370 kernel: Bluetooth: RFCOMM ver 1.11
okt 21 01:50:59 dell-xps-13-9370 systemd[1]: Starting Bluetooth management mechanism...
okt 21 01:50:59 dell-xps-13-9370 systemd[1]: Started Bluetooth management mechanism.
okt 21 01:50:59 dell-xps-13-9370 systemd[1045]: Starting Bluetooth OBEX service...
okt 21 01:50:59 dell-xps-13-9370 systemd[1045]: Started Bluetooth OBEX service.
okt 21 01:55:20 dell-xps-13-9370 systemd[1]: Stopped target Bluetooth.
okt 21 01:55:20 dell-xps-13-9370 systemd[1]: Stopping Bluetooth service...
okt 21 01:55:20 dell-xps-13-9370 systemd[1045]: Stopping Bluetooth OBEX service...
okt 21 01:55:20 dell-xps-13-9370 systemd[1045]: Stopped Bluetooth OBEX service.
okt 21 01:55:20 dell-xps-13-9370 systemd[1]: Stopped Bluetooth service.
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: Core ver 2.22
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: HCI device and connection manager initialized
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: HCI socket layer initialized
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: L2CAP socket layer initialized
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: SCO socket layer initialized
okt 21 01:55:48 dell-xps-13-9370 systemd[1]: Starting Bluetooth service...
okt 21 01:55:48 dell-xps-13-9370 bluetoothd[880]: Bluetooth daemon 5.55
okt 21 01:55:48 dell-xps-13-9370 systemd[1]: Started Bluetooth service.
okt 21 01:55:48 dell-xps-13-9370 systemd[1]: Reached target Bluetooth.
okt 21 01:55:48 dell-xps-13-9370 bluetoothd[880]: Bluetooth management interface 1.18 initialized
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: BNEP filters: protocol multicast
okt 21 01:55:48 dell-xps-13-9370 kernel: Bluetooth: BNEP socket layer initialized
okt 21 01:56:03 dell-xps-13-9370 kernel: Bluetooth: RFCOMM TTY layer initialized
okt 21 01:56:03 dell-xps-13-9370 kernel: Bluetooth: RFCOMM socket layer initialized
okt 21 01:56:03 dell-xps-13-9370 kernel: Bluetooth: RFCOMM ver 1.11
okt 21 01:56:04 dell-xps-13-9370 systemd[1]: Starting Bluetooth management mechanism...
okt 21 01:56:04 dell-xps-13-9370 systemd[1]: Started Bluetooth management mechanism.
okt 21 01:56:04 dell-xps-13-9370 systemd[966]: Starting Bluetooth OBEX service...
okt 21 01:56:04 dell-xps-13-9370 systemd[966]: Started Bluetooth OBEX service.
okt 21 01:59:32 dell-xps-13-9370 systemd[966]: Reached target Bluetooth.
okt 21 02:01:00 dell-xps-13-9370 systemd[1]: Stopped target Bluetooth.
okt 21 02:01:00 dell-xps-13-9370 systemd[1]: Stopping Bluetooth service...
okt 21 02:01:00 dell-xps-13-9370 systemd[966]: Stopped target Bluetooth.
okt 21 02:01:00 dell-xps-13-9370 systemd[966]: Stopping Bluetooth OBEX service...
okt 21 02:01:00 dell-xps-13-9370 systemd[966]: Stopped Bluetooth OBEX service.
okt 21 02:01:00 dell-xps-13-9370 systemd[1]: Stopped Bluetooth service.
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: Core ver 2.22
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: HCI device and connection manager initialized
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: HCI socket layer initialized
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: L2CAP socket layer initialized
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: SCO socket layer initialized
okt 21 02:01:28 dell-xps-13-9370 systemd[1]: Starting Bluetooth service...
okt 21 02:01:28 dell-xps-13-9370 bluetoothd[682]: Bluetooth daemon 5.55
okt 21 02:01:28 dell-xps-13-9370 systemd[1]: Started Bluetooth service.
okt 21 02:01:28 dell-xps-13-9370 systemd[1]: Reached target Bluetooth.
okt 21 02:01:28 dell-xps-13-9370 bluetoothd[682]: Bluetooth management interface 1.18 initialized
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: BNEP filters: protocol multicast
okt 21 02:01:28 dell-xps-13-9370 kernel: Bluetooth: BNEP socket layer initialized
okt 21 02:01:34 dell-xps-13-9370 kernel: Bluetooth: RFCOMM TTY layer initialized
okt 21 02:01:34 dell-xps-13-9370 kernel: Bluetooth: RFCOMM socket layer initialized
okt 21 02:01:34 dell-xps-13-9370 kernel: Bluetooth: RFCOMM ver 1.11
okt 21 02:01:35 dell-xps-13-9370 systemd[1]: Starting Bluetooth management mechanism...
okt 21 02:01:35 dell-xps-13-9370 systemd[1]: Started Bluetooth management mechanism.
okt 21 02:01:35 dell-xps-13-9370 systemd[958]: Starting Bluetooth OBEX service...
okt 21 02:01:35 dell-xps-13-9370 systemd[958]: Started Bluetooth OBEX service.
okt 21 02:01:55 dell-xps-13-9370 systemd[958]: Reached target Bluetooth.
okt 21 02:15:29 dell-xps-13-9370 systemd[1]: Stopped target Bluetooth.
okt 21 02:15:29 dell-xps-13-9370 systemd[1]: Stopping Bluetooth service...
okt 21 02:15:29 dell-xps-13-9370 systemd[958]: Stopped target Bluetooth.
okt 21 02:15:29 dell-xps-13-9370 systemd[958]: Stopping Bluetooth OBEX service...
okt 21 02:15:29 dell-xps-13-9370 systemd[958]: Stopped Bluetooth OBEX service.
okt 21 02:15:29 dell-xps-13-9370 systemd[1]: Stopped Bluetooth service.
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: Core ver 2.22
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: HCI device and connection manager initialized
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: HCI socket layer initialized
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: L2CAP socket layer initialized
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: SCO socket layer initialized
okt 21 02:15:52 dell-xps-13-9370 systemd[1]: Starting Bluetooth service...
okt 21 02:15:52 dell-xps-13-9370 bluetoothd[869]: Bluetooth daemon 5.55
okt 21 02:15:52 dell-xps-13-9370 systemd[1]: Started Bluetooth service.
okt 21 02:15:52 dell-xps-13-9370 systemd[1]: Reached target Bluetooth.
okt 21 02:15:52 dell-xps-13-9370 bluetoothd[869]: Bluetooth management interface 1.18 initialized
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: BNEP filters: protocol multicast
okt 21 02:15:52 dell-xps-13-9370 kernel: Bluetooth: BNEP socket layer initialized
okt 21 02:16:00 dell-xps-13-9370 kernel: Bluetooth: RFCOMM TTY layer initialized
okt 21 02:16:00 dell-xps-13-9370 kernel: Bluetooth: RFCOMM socket layer initialized
okt 21 02:16:00 dell-xps-13-9370 kernel: Bluetooth: RFCOMM ver 1.11
okt 21 02:16:01 dell-xps-13-9370 systemd[1]: Starting Bluetooth management mechanism...
okt 21 02:16:01 dell-xps-13-9370 systemd[1]: Started Bluetooth management mechanism.
okt 21 02:16:01 dell-xps-13-9370 systemd[953]: Starting Bluetooth OBEX service...
okt 21 02:16:01 dell-xps-13-9370 systemd[953]: Started Bluetooth OBEX service.
okt 21 02:16:13 dell-xps-13-9370 systemd[953]: Reached target Bluetooth.
okt 21 02:29:17 dell-xps-13-9370 systemd[1]: Stopped target Bluetooth.
okt 21 02:29:17 dell-xps-13-9370 systemd[1]: Stopping Bluetooth service...
okt 21 02:29:17 dell-xps-13-9370 systemd[953]: Stopped target Bluetooth.
okt 21 02:29:17 dell-xps-13-9370 systemd[953]: Stopping Bluetooth OBEX service...
okt 21 02:29:17 dell-xps-13-9370 systemd[953]: Stopped Bluetooth OBEX service.
okt 21 02:29:17 dell-xps-13-9370 systemd[1]: Stopped Bluetooth service.
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: Core ver 2.22
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: HCI device and connection manager initialized
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: HCI socket layer initialized
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: L2CAP socket layer initialized
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: SCO socket layer initialized
okt 21 02:29:44 dell-xps-13-9370 systemd[1]: Starting Bluetooth service...
okt 21 02:29:44 dell-xps-13-9370 bluetoothd[753]: Bluetooth daemon 5.55
okt 21 02:29:44 dell-xps-13-9370 systemd[1]: Started Bluetooth service.
okt 21 02:29:44 dell-xps-13-9370 systemd[1]: Reached target Bluetooth.
okt 21 02:29:44 dell-xps-13-9370 bluetoothd[753]: Bluetooth management interface 1.17 initialized
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: BNEP (Ethernet Emulation) ver 1.3
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: BNEP filters: protocol multicast
okt 21 02:29:44 dell-xps-13-9370 kernel: Bluetooth: BNEP socket layer initialized
okt 21 02:29:51 dell-xps-13-9370 kernel: Bluetooth: RFCOMM TTY layer initialized
okt 21 02:29:51 dell-xps-13-9370 kernel: Bluetooth: RFCOMM socket layer initialized
okt 21 02:29:51 dell-xps-13-9370 kernel: Bluetooth: RFCOMM ver 1.11
okt 21 02:29:52 dell-xps-13-9370 systemd[1]: Starting Bluetooth management mechanism...
okt 21 02:29:52 dell-xps-13-9370 systemd[1]: Started Bluetooth management mechanism.
okt 21 02:29:52 dell-xps-13-9370 systemd[1036]: Starting Bluetooth OBEX service...
okt 21 02:29:52 dell-xps-13-9370 systemd[1036]: Started Bluetooth OBEX service.
okt 21 02:29:53 dell-xps-13-9370 systemd[1036]: Reached target Bluetooth.
okt 21 02:29:53 dell-xps-13-9370 systemd[959]: Reached target Bluetooth.
okt 21 02:30:00 dell-xps-13-9370 systemd[959]: Stopped target Bluetooth.

I couldn’t find anything about the Bluetooth being faulty on the Dell XPS 13 9370 on the wiki: Dell XPS 13 (9370) - ArchWiki

I have also tried to reinstall Blueman and rebooting, also did not work unfortunately, some help is very much appreciated :smile:

More information will be added when asked for!

Also, my Logitech MX ERGO connects and works just fine, although it slightly makes hicups when moving it after a couple of seconds.

I have also tried fwupd (fwupd - ArchWiki) but it tell me after fwupdmgr get-updates that everything is up-to-date:

• KXG50ZNV512G NVMe TOSHIBA 512GB has no available firmware updates
• System Firmware has the latest available firmware version
• Touchpad has no available firmware updates
• UEFI dbx has no available firmware updates

Some help is very much appreciated! More info will be provided decently when asked for :smile: !

I’m unfamiliar with your Hardware, but i would suggest to post info about your WiFi adapter also, because some if not all WiFi adapters are actually a combined WiFi-Bluetooth adapter, which require separate drivers (with or without firmware) to activate…
The problem could be with those drivers instead of the Bluethooth sub-system…

I see yes, well it is an Intel based machine, so chances are it indeed uses combined WiFi/Bluetooth as this is how they also sell these adapters on the market.

Could you kindly provide a command so I can add this information to my thread/post please? It would be very much appreciated :smile:

Well you could ofcourse use this tool to generate the PCI/USB info…

Or perhaps only lspci -nn; lsusb .

Well here is the output of lspci -nn; lsusb :

00:00.0 Host bridge [0600]: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [8086:5914] (rev 08)
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07)
00:04.0 Signal processing controller [1180]: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem [8086:1903] (rev 08)
00:14.0 USB controller [0c03]: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller [8086:9d2f] (rev 21)
00:14.2 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Thermal subsystem [8086:9d31] (rev 21)
00:15.0 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #0 [8086:9d60] (rev 21)
00:15.1 Signal processing controller [1180]: Intel Corporation Sunrise Point-LP Serial IO I2C Controller #1 [8086:9d61] (rev 21)
00:16.0 Communication controller [0780]: Intel Corporation Sunrise Point-LP CSME HECI #1 [8086:9d3a] (rev 21)
00:1c.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 [8086:9d10] (rev f1)
00:1c.2 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #3 [8086:9d12] (rev f1)
00:1c.4 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #5 [8086:9d14] (rev f1)
00:1d.0 PCI bridge [0604]: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 [8086:9d18] (rev f1)
00:1f.0 ISA bridge [0601]: Intel Corporation Sunrise Point LPC Controller/eSPI Controller [8086:9d4e] (rev 21)
00:1f.2 Memory controller [0580]: Intel Corporation Sunrise Point-LP PMC [8086:9d21] (rev 21)
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
00:1f.4 SMBus [0c05]: Intel Corporation Sunrise Point-LP SMBus [8086:9d23] (rev 21)
01:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS525A PCI Express Card Reader [10ec:525a] (rev 01)
02:00.0 Network controller [0280]: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter [168c:003e] (rev 32)
6e:00.0 Non-Volatile memory controller [0108]: Toshiba Corporation Device [1179:0116]
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0489:e0a2 Foxconn / Hon Hai 
Bus 001 Device 002: ID 0bda:58f4 Realtek Semiconductor Corp. Integrated_Webcam_HD
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

EDIT #1

So according to Qualcomm its own website it is… well… not an Intel adapter. And it is a dual-chip, so WiFi/Bluetooth in one.

EDIT #2:

Okay, so I seem to have… "fixed’’ it for now, because I have a Sony WH-1000XM3, so I wanted to have the full experience so I replaced pulseaudio-bluetooth with pulseaudio-modules-bt (Github link) to get LDAC support on my headset.
However, I have now switched back to pulseaudio-blutooth and it connects just fine without looping and connecting.
So I guess (?) it is safe to say pulseaudio-modules-bt “breaks” my Bluetooth connection on my Dell XPS 13 laptop. I don’t have these problems on my other systems that have run Manjaro with this package. Maybe the error is bound to specifically the Qualcomm Atheros QCA6174A that I have in my laptop.

I will make this thread [SOLVED] but feel free to add any comments please! :smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.