So every time my laptop gets tilted, it disconnects my wifi and bluetooth

So i will say that i am still relatively new to using linux, but every distro i have downloaded to this laptop has had this issue.

All that’s happening is any time the accelerometer tries to trigger the screen rotation even with rotation and touch screen off. It disables any “unneccesary” devices and drivers which just so happens to my bluetooth, wifi, and also any keyboards or mouses external or internal.

So I basically have had to use my laptop as a Desktop computer on a flat surface as to not risk disconnecting everything, cutting off downloads etc… just because i decided to pick up my laptop and put it somewhere else, and at this point its just gotten kind of irritating and redundant so i finally came for help.

Hi there. What does a search for turning off the accelerometer on your specific notebook come up with? It could be a hardware issue. I hope you find a solution soon. R :slight_smile:

Well over the past few months i have searched up everything i could regarding the issue.

From what i know it has to do with the fact that whatever device is in control of disconnecting my mousepad and integrated keyboard when the keyboard rotates just disconnects all the devices connected to the computer that aren’t essential to function.

Ever thought it could be just(…) some sort of internal earthing issue? Look around the battery parhaps, it could be a connectivity problem. In any case fingers crossed :crossed_fingers:

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.

[HowTo] Provide System Information

  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

Try uninstalling your Pinball Wizard

    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=2a06fd87-998e-43b5-9656-b035a6d21ca4 rw quiet splash
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Convertible System: HP product: HP ENVY x360 Convertible 15m-ed0xxx
    v: Type1ProductConfigId serial: <filter> Chassis: type: 31 serial: <filter>
  Mobo: HP model: 875B v: 09.40 serial: <filter> UEFI: Insyde v: F.21
    date: 12/28/2020
  ID-1: BAT1 charge: 44.5 Wh (100.0%) condition: 44.5/51.0 Wh (87.1%)
    volts: 12.6 min: 11.6 model: COMPAL PABAS0241231 type: Li-ion
    serial: <filter> status: full
  Device-1: hid-0018:04F3:2B0E.0001-battery model: ELAN2514:00 04F3:2B0E
    serial: N/A charge: N/A status: N/A
  RAM: total: 11.48 GiB used: 3.93 GiB (34.3%)
  Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB
    note: est.
  Device-1: Bottom - Slot 1 (left) type: DDR4 detail: synchronous size: 8 GiB
    speed: 3200 MT/s volts: curr: 1.2 width (bits): data: 64 total: 64
    manufacturer: Micron part-no: 8ATF1G64HZ-3G2J1 serial: <filter>
  Device-2: Bottom - Slot 2 (right) type: DDR4 detail: synchronous
    size: 4 GiB speed: 3200 MT/s volts: curr: 1.2 width (bits): data: 64
    total: 64 manufacturer: Micron part-no: 4ATF51264HZ-3G2J1 serial: <filter>
  Info: model: Intel Core i7-1065G7 socket: U3E1 bits: 64 type: MT MCP
    arch: Ice Lake gen: core 10 level: v4 note: check built: 2019-21
    process: Intel 10nm family: 6 model-id: 0x7E (126) stepping: 5
    microcode: 0xB6
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 1136 high: 1200 min/max: 400/3900 base/boost: 1200/8300
    scaling: driver: intel_pstate governor: powersave volts: 0.7 V
    ext-clock: 100 MHz cores: 1: 1124 2: 1168 3: 1133 4: 1095 5: 1113 6: 1120
    7: 1138 8: 1200 bogomips: 23968
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f avx512ifma
    avx512vbmi avx512vl bmi1 bmi2 bts clflush clflushopt cmov constant_tsc
    cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms
    est f16c flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid rdrand rdseed
    rdtscp rep_good sdbg sep sha_ni smap smep split_lock_detect ss ssbd sse
    sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust
    tsc_deadline_timer tsc_known_freq umip vaes vme vmx vnmi vpclmulqdq vpid
    x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G7 vendor: Hewlett-Packard driver: i915
    v: kernel arch: Gen-11 process: Intel 10nm built: 2019-21 ports:
    active: HDMI-A-1,eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
  Device-2: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
    bus-ID: 3-5:3 chip-ID: 04f2:b6b6 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.7 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: iris gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1184x380mm (46.61x14.96")
    s-diag: 1243mm (48.96")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: left model: M43Q6-J04
    serial: <filter> built: 2020 res: 2560x1440 hz: 60 dpi: 59 gamma: 1.2
    size: 1096x616mm (43.15x24.25") diag: 1630mm (64.2") ratio: 16:9 modes:
    max: 3840x2160 min: 720x400
  Monitor-2: eDP-1 pos: primary,right model: BOE Display 0x08a8 built: 2019
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: Mesa Intel Iris Plus Graphics
    (ICL GT2) direct-render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Hewlett-Packard
    driver: sof-audio-pci-intel-icl
    alternate: snd_hda_intel,snd_sof_pci_intel_icl bus-ID: 00:1f.3
    chip-ID: 8086:34c8 class-ID: 0401
  Sound API: ALSA v: k5.15.93-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.65 running: yes
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX201 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-10:5
    chip-ID: 8087:0026 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
    v: 3.0 port: 3060 bus-ID: 00:17.0 chip-ID: 8086:282a rev: N/A class-ID: 0104
  Local Storage: total: 504.19 GiB used: 31.7 GiB (6.3%)
  ID-1: /dev/nvme0n1 maj-min: 259:1 vendor: Intel model: HBRPEKNX0202AH
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: HPS2 temp: 28.9 C scheme: GPT
  SMART: yes health: PASSED on: 294d 10h cycles: 466
    read-units: 5,139,551 [2.63 TB] written-units: 12,630,933 [6.46 TB]
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Intel model: HBRPEKNX0202AHO
    size: 27.25 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s
    lanes: 2 type: SSD serial: <filter> rev: HPS3 temp: 30.9 C
  SMART: yes health: PASSED on: 310d 16h cycles: 467
    read-units: 7,100,496 [3.63 TB] written-units: 8,106,301 [4.15 TB]
  Message: No optical or floppy data found.
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 31.7 GiB (6.8%)
    fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p2 maj-min: 259:3 label: N/A
    uuid: 2a06fd87-998e-43b5-9656-b035a6d21ca4
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 312 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
    maj-min: 259:2 label: N/A uuid: 5389-5E95
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: MosArt 2.4G INPUT DEVICE type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 100mA
    chip-ID: 062a:4180 class-ID: 0301
  Device-2: 3-5:3 info: Chicony HP Wide Vision HD Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 04f2:b6b6 class-ID: 0e02 serial: <filter>
  Device-3: 3-6:4 info: Elan Micro ELAN:ARM-M4 type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 04f3:0c4c class-ID: 0000
  Device-4: 3-10:5 info: Intel AX201 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0026
    class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 53.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 244 Uptime: 10h 35m wakeups: 5 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: 1181 pm: pacman pkgs: 1163 libs: 323 tools: pamac pm: flatpak
  pkgs: 18 Shell: Zsh (sudo) v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.25```

Alright here you go hope this helps.

Nah ive tested it, it is perfectly in sync with the rotation of the screen. Linux Mint is the only linux distro that i didn’t have this problem with and this is OS number like 6. Yet like i said i worked on linux mint and it worked on windows also.

What happens when i tilt the laptop to the side it tries to go into upright orientation and only enable the touch screen.

Disabling screen rotation doesn’t do the trick, and i cant seem to find a dedicated device in this computer that acts as an accelerometer. I was more less wondering if there was a way i could from the operating system level just stop it from accepting any accelerometer outputs.

1 Like