Snap apps stop working after latest manjaro upgrade

Yesterday 21st of Nov I see a bunch of manjaro updates. After running them the snap apps stopped to work.

If I try to run them on the terminal, I have following error:

cannot open /proc/self/cgroup: Permission denied

I am running Manjaro + gnome + kernel 5.14.18-1

snap --version
snap     2.53.2-2-dirty
snapd    2.53.2-2-dirty
series   16
manjaro  -
kernel   5.14.18-1-MANJARO

I have tried reinstalling brave and snap, but without any success.

any clue what can be happening?

Just install brave-bin from AUR or brave-browser from Manjaro-repos.


1 Like

Long story short. I have installed kernel 5.15.2-2 and magically snap apps started working properly.

Thanks for your suggestion. I will review carefully this article because it looks interesting and maybe it is time to move to another system but I do not consider this a valid solution for my problem unless manjaro is dropping support.

I just use snap because it just works ( until today :slight_smile: ) Let me explain the reason why I started using snap apps. I have always used the apps from the official repositories and I have always though that snap apps were a waste of disk space and maybe performance, but long time ago Freecad stopped working after another manjaro update because of a certain dependency that broke something … looking for the solution I found somebody that talked about using the snap version, so I tried … and I was very surprised.

Maybe snap is not the best option from a performance or disk usage point of view but I didn´t see any difference from the official repository version. After this experience I decided to install brave from snap and I never had any complain from a performance point of view … so it simply works fine as I expect.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.