Smb:// windows 10

manjaro gnome minimal :

files > other locations > enter server address

smb:// followed by ip address of my other computer(windows 10) on my lan network

pops up a window which has my username & asks for a password

i enter the password for my username the pop-up window

flashes back on again still asking for a password, again & again & again.

can some one help me fix this please?

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.

  3. Did you enter your Windows user name and password???


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which CPU/GPU or Kernel, … you have without typing it every time

1 Like

maybe - just maybe - this is easy
(cave: I have not much experience with samba …)
What username is already filled in?
The one on your Linux system or the one on your Windows system?
Which password did you use?
Did you even set one to access shares on Windows?

But maybe you already thought about that …

1 Like

@Fabby @Nachlese

pardon me for the delay in replying & thank you very much to you both for replying.

no i used my manjaro username & password.

will update my profile at the earliest.

i used this manjaro-gnome-21.0.2-minimal-210419-linux510.iso to install.

manjaro username & manjaro password.

i have no passwords on the windows computer.

Something isn’t right.
I mean in the way you approach this.
You want to access a share.
This share has no password on it.
Not sure about the user name - whether it’s the same as in Linux.

Why would you enter your Linux credentials (usename/password) to access a share which is not on Linux but on Windows and which doesn’t have a password set
and expect it to succeed?

it seems illogical

… but this question/advise comes from someone (me) who doesn’t have any Windows shares to try and play with …

I have the same issue. My sis doesn’t have password on her Win10 system (no idea how she set it that way, it’s not auto loging, it’s actual no password) and because of that samba on Linux won’t work, because there is no credintials and samba won’t accept that… :frowning:

If someone knows the way out of this, please, let us know.

1 Like
  1. i have a shared folder on windows 10 with full access to read & write with no password.

  2. files > other locations > smb://ipaddress pops up an authentication required window with
    a username box where my linux username is already there, domain = workgroup & an empty box for password.

  3. when i enter my linux, in this case, the password for my manjaro username the pop-window disappears & re-appears.

  4. when i do the exact same procedure with ubuntu i am given access to my shared folder on windows.

That difference in behavior between Ubuntu and Manjaro would indicate to me
to me!
that there is a difference in what software is installed and how it is configured.

I can’t be of real help here - since I cannot test how and why either one system behaves like it does
because I have no Windows share to test with.

Someone else might know more, have experience with this.


  • UID: guest
  • PWD: nothing! (As in: don’t type anything and hit enter)

If that doesn’t work, enter:

  • UID: \\m.n.o.p\WinUserName
  • PWD: WinUserPWD

Where, obviously m.n.o.p is the LAN IP address of the Windows machine, WinUserName is any username on said Windows machine and WinUserPWD is the password of WinUserName.


cc @michaldybczak


By IP address of Windows machine, you mean internal IP of the home network, like or similar?

1 Like

When you are requested for credentials in the server connection dialog - this is the credentials on the server not you Linux credentials.

If the server has no password then you should supply no password.

If the Samba engine will not connect due to the lack of server credentials then it is a server problem not a client problem.

That means you have to edit the share on the Windows machine. This can never be a client issue.


Yes, editing edited post to make it clearer it’s the LAN IP address but without the HTTP:// just the ip address preceded with two backslashes.


no luck.

on debian & ubuntu i enter my linux username & password & it works.

on fedora it works just like on debian & ubuntu but after an upgrade even fedora has the same problem.

could this have to do with the samba version on the distros?

  1. Set a password on the Windows computer for at least one user and use that one.

  2. If that doesn’t solve the issue, what’s the output of:

    grep --ignore-case protocol --recursive /etc/samba/
    smbclient --list=m.n.o.p --no-pass


One thing that worked for me was to edit group policies in windows. It looks complicated but, in fact, was quite easy.

On the Windows computer:

  • Win +R

  • type gpedit.msc and press Enter

  • Go to Machine settings→Administrative templates→Network→Lanman workstation

    There should be an option called something like “enable insecure guests login” which is disabled by default. You must enable this policy.
    After doing that, remember to change the network options to share without using passwords

  • Win+R

  • Type Controland press Enter

  • Click Network and sharing center

  • Change Advanced sharing center

  • Expand All networks

  • Disable password protected sharing (or something similar)

    With those options I’ve been able to share files between Manjaro and Windows 10 and vice versa.

To open the share in:

  • Windows: \\m.n.o.p where m.n.o.p is the IP address of the share
  • Manjaro:
    • Choose the network icon on folder explorer
    • Type smb://m.n.o.p

I hope this helps someone!

1 Like