Smart Window Placement missing

I have usually in the past relied on smart window placement so all my apps and windows more or less remember their size and position, however this setting is now missing in the windows behavior - advanced settings panel.

I must now do this manually for each window and app I have because if I set a global remember placement and size, plasma messes up as it can’t determine the difference between certain windows, for example it can’t determine a difference between Dolphin and its settings pop out windows OR skype and a conversation window.

Sometimes these windows will have the same class name and window name but be different. The smart window placement option for the most part worked, but it has been silently killed off in plasma5.

Is there a better option then manually doing it for each window & app?

Welcome to the forum! :wink:

The upcoming Plasma 5.20.x now remembers window positions and sizes. :wink:

1 Like

To do that today:

  • right-click the window title
  • Click More Actions
  • Click Configure Special Application Settings (if you want to do this per application)
  • Click Add Properties like the diagonal arrow below
  • Set the settings you want to set and how / what you want them to be as per the horizontal arrows below
  • Click OK
  • Done!

:+1:

2 Likes

Yeah I know about this. But its for each app you must do this. Smart option did it for everything automatically.

I might have figured it out anyway by having title and class name as exact and just leaving blank. Maybe that will work.

No it doesn’t remember them.

If I enable the system setting Allow apps to remember the positions of their own windows, if they support it then all KDE / system windows still open small, but at the top-left corner of my left-most monitor. With it disabled they at least open on the primary monitor (middle of 3 monitors) but never remember the size or position. I’ve tried using both Special Window Settings and Special Application Settings with specific sizes initially, forced, remember, with and without the recommended Ignore requested geometry option.

It just doesn’t work. I did record my screen to show how the dolphin file manager behaves, but this forum won’t let me upload video files or drop a link to the video uploaded on any 3rd party service. It won’t even let me upload a screenshot of the System Information window, so you’ll have to put up with this text version:

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.13.13-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × 11th Gen Intel® Core™ i5-11600K @ 3.90GHz
Memory: 31.2 GiB of RAM
Graphics Processor: NVIDIA GeForce RTX 3060/PCIe/SSE2

Position isn’t too important, as long as they open on the primary monitor, but why they got to be so small?! I just installed manjaro-kde-21.1.2-210904-linux513 after work today specifically because I thought this window size / position thing was just one of several GNOME issues I was butting heads with in Zorin OS 16 Core, but apparently not.