Slow internet with Ethernet cable

Hello! So, I installed Manjaro after using Ubuntu for a while. It works great so far, all but the internet.
It takes a long time to start loading a page, like if I had a lot of ping, it can take like 5 seconds to start loading a page. I have checked my internet and is okay. It’s also not a cable or something because in Ubuntu or Windows in the same PC it works correctly so it has to be something here.

This is my result after running inxi -Fxxxz

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1
  Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: X470 AORUS ULTRA GAMING v: N/A
  serial: <filter>
  Mobo: Gigabyte model: X470 AORUS ULTRA GAMING-CF v: x.x serial: <filter>
  UEFI-[Legacy]: American Megatrends v: F5 date: 01/08/2019
  Info: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP arch: Zen+
  rev: 2 cache: L2: 4 MiB
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 102434
  Speed: 2679 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz):
  1: 2679 2: 2686 3: 1370 4: 1378 5: 1378 6: 1378 7: 1376 8: 1370 9: 2806
  10: 2769 11: 1459 12: 1313 13: 1368 14: 1326 15: 1376 16: 1372
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: PNY driver: nvidia
  v: 470.63.01 bus-ID: 09:00.0 chip-ID: 10de:1e89 class-ID: 0300
  Display: x11 server: 1.20.13 compositor: gnome-shell driver:
  loaded: nvidia resolution: <missing: xdpyinfo>
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
  v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
  Device-1: NVIDIA TU104 HD Audio vendor: PNY driver: snd_hda_intel
  v: kernel bus-ID: 09:00.1 chip-ID: 10de:10f8 class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel
  v: kernel bus-ID: 0b:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media KIMU PRO type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2 chip-ID: 0d8c:9703
  class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb
  v: kernel port: f000 bus-ID: 06:00.0 chip-ID: 8086:1539 class-ID: 0200
  IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Local Storage: total: 1.69 TiB used: 168.11 GiB (9.7%)
  ID-1: /dev/sda vendor: Samsung model: SSD 840 EVO 120GB size: 111.79 GiB
  speed: 6.0 Gb/s type: SSD serial: <filter> rev: BB6Q scheme: GPT
  ID-2: /dev/sdb vendor: Kingston model: SA400S37240G size: 223.57 GiB
  speed: 6.0 Gb/s type: SSD serial: <filter> rev: 0100 scheme: MBR
  ID-3: /dev/sdc vendor: Seagate model: ST1000DM003-1ER162 size: 931.51 GiB
  speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: CC45 scheme: MBR
  ID-4: /dev/sdd vendor: Kingston model: SA400S37480G size: 447.13 GiB
  speed: 6.0 Gb/s type: SSD serial: <filter> rev: B1C2 scheme: GPT
  ID-5: /dev/sde type: USB vendor: Kingston model: DataTraveler 2.0
  size: 14.42 GiB type: N/A serial: <filter> rev: PMAP scheme: MBR
  ID-1: / size: 214.77 GiB used: 12.45 GiB (5.8%) fs: btrfs dev: /dev/sdb1
  ID-2: /home size: 214.77 GiB used: 12.45 GiB (5.8%) fs: btrfs
  dev: /dev/sdb1
  ID-3: /var/log size: 214.77 GiB used: 12.45 GiB (5.8%) fs: btrfs
  dev: /dev/sdb1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/sdb2
  System Temperatures: cpu: 49.1 C mobo: N/A gpu: nvidia temp: 32 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 29%
  Processes: 403 Uptime: 14m wakeups: 0 Memory: 15.58 GiB
  used: 2.76 GiB (17.7%) Init: systemd v: 249 Compilers: gcc: 11.1.0
  Packages: pacman: 1002 Shell: Zsh v: 5.8 running-in: gnome-terminal
  inxi: 3.3.08

Hi @Alexowyrle, and welcome!

I’m afraid this might not be it, but I have to check, for thoroughness’ sake. Have you tried with a different kernel?

Sorry but I’m very new at this so I don’t know. I installed the LTS version and the minimal. It happens in both.
It the kernel version another thing? Where can I change it?

You can install and remove kernels in Manjaro Settings.If you want the latest kernel 5.14 just install it and reboot then you can go back into the settings and remove 5.13 .Just make sure it’s showing that 5.14 is running.

Changed the kernel to 5.14.10-1 . The problem its still there

Try version 5.10.

If it doesn’t help, I’m all out of ideas.

Changed it and it doesn’t work either :cry:

Can you make a speed test of your internet connection ?

Sure. The results are
Ping: 17ms
Download speed: 91.53Mbps
Upload speed: 93.2Mbps

But, to load this page took a long long time. In my phone it was instant

Have you tried a different browser.For some reason Chrome seems to lag opening pages and Firefox seems faster I haven’t a clue why.

Yeah, tried both, and both are slow.
Its like it takes a long time before it connect with the page and once it does it loads it correctly, but I dont know why it takes so long to connect to it.

The connection is fine.

Open browser from terminal and see if you have relevant errors appearing.

No errors, just the same as if I opened it from the shortcut

What about the terminal? Look in the terminal when it doesn’t seem to work :man_facepalming:

There are no error or nothing in the console. Its clear

Slow internet with Ethernet cable

Do the webpages load quickly with wifi?

I don’t know, I’m using a desktop and I it doesn’t have WiFi to test it

cpupower frequency-info
Run this command and see if the CPU governor is set to powersave.

Here its the output:

analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 1.55 GHz - 3.20 GHz
  available frequency steps:  3.20 GHz, 2.80 GHz, 1.55 GHz
  available cpufreq governors: conservative ondemand userspace powersave performance schedutil
  current policy: frequency should be within 1.55 GHz and 3.20 GHz.
                  The governor "schedutil" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 2.37 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: no

Run sudo cpupower frequency-set -g ondemand and the load a webpage. That’s all I got.
If it doesn’t help, you can set it back to schedutil by running sudo cpupower frequency-set -g schedutil.