Shutdown takes too long

Hey there,

I’m currently experiencing unusually long shutdown times (around 1 to 2 minutes). I had this issue before but now it happens nearly everytime I reboot or shutdown. I looked through similar topics, but could not find anything usefull.

inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.4.101-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=63b20c95-fc92-475f-b8b6-18fa6880d5c8 rw quiet apparmor=1 
  security=apparmor resume=UUID=0f38a9a3-f0fe-4fd8-b31e-c74bcc449f14 
  Desktop: KDE Plasma 5.21.2 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Desktop Mobo: MSI model: Z87-G43 (MS-7816) v: 1.0 serial: <filter> 
  BIOS: American Megatrends v: 1.6 date: 11/27/2013 
  RAM: total: 15.59 GiB used: 7.01 GiB (45.0%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i7-4771 bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 
  L2 cache: 8 MiB bogomips: 56016 
  Speed: 3761 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3761 2: 3876 
  3: 3814 4: 3804 5: 3779 6: 3839 7: 3775 8: 3813 
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2 bts 
  clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm 
  dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht 
  ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
  movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb 
  pebs pge pln pni popcnt pse pse36 pti pts rdrand rdtscp rep_good sdbg sep 
  smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 
  tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic xsave 
  xsaveopt xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI 
  driver: nvidia v: 460.56 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c03 class ID: 0300 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3600x1080 s-dpi: 81 s-size: 1129x343mm (44.4x13.5") 
  s-diag: 1180mm (46.5") 
  Monitor-1: DVI-D-0 res: 1920x1080 dpi: 82 size: 598x336mm (23.5x13.2") 
  diag: 686mm (27") 
  Monitor-2: HDMI-0 res: 1680x1050 hz: 60 dpi: 90 size: 474x296mm (18.7x11.7") 
  diag: 559mm (22") 
  OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 460.56 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio 
  vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  chip ID: 8086:8c20 class ID: 0403 
  Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f1 
  class ID: 0403 
  Device-3: C-Media CMI8788 [Oxygen HD Audio] vendor: ASUSTeK CMI8786 
  driver: snd_oxygen v: kernel bus ID: 07:04.0 chip ID: 13f6:8788 
  class ID: 0401 
  Sound Server: ALSA v: k5.4.101-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Message: No Bluetooth data was found. 
  Message: No RAID data was found. 
  Local Storage: total: 1.69 TiB used: 86.19 GiB (5.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SV300S37A120G 
  size: 111.79 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: BBF0 scheme: MBR 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST1000DM003-1CH162 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC47 scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: SDSSDA240G 
  size: 223.57 GiB block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 80RL scheme: MBR 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Crucial model: CT500MX500SSD1 
  size: 465.76 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 023 scheme: MBR 
  Message: No Optical or Floppy data was found. 
  ID-1: / raw size: 78.12 GiB size: 76.4 GiB (97.79%) used: 28.75 GiB (37.6%) 
  fs: ext4 dev: /dev/sdc2 maj-min: 8:34 label: N/A 
  uuid: 63b20c95-fc92-475f-b8b6-18fa6880d5c8 
  ID-2: /home raw size: 97.66 GiB size: 95.62 GiB (97.92%) 
  used: 57.45 GiB (60.1%) fs: ext4 dev: /dev/sdc1 maj-min: 8:33 label: N/A 
  uuid: 911149de-2563-4198-89df-8d3832fd2b05 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 18.55 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda1 maj-min: 8:1 label: N/A 
  uuid: 0f38a9a3-f0fe-4fd8-b31e-c74bcc449f14 
  ID-1: /dev/sda2 maj-min: 8:2 size: 92.74 GiB fs: ntfs label: N/A 
  uuid: 7C8EDE2A8EDDDCA8 
  ID-2: /dev/sda3 maj-min: 8:3 size: 505 MiB fs: ntfs label: N/A 
  uuid: 24AC3163AC3130A2 
  ID-3: /dev/sdb1 maj-min: 8:17 size: 448.99 GiB fs: ntfs label: Hauptplatte 
  uuid: 01D3C542C44B29D0 
  ID-4: /dev/sdb2 maj-min: 8:18 size: 198.8 GiB fs: ext4 label: N/A 
  uuid: e4819263-1437-47cb-8afa-8e9230eb7a8d 
  ID-5: /dev/sdc3 maj-min: 8:35 size: 50 MiB fs: ntfs label: System Reserved 
  uuid: 326CCD7E6CCD3D7B 
  ID-6: /dev/sdd1 maj-min: 8:49 size: 454.09 GiB fs: ntfs label: N/A 
  uuid: 0E8A16C30E8A16C3 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:8008 class ID: 0900 
  Hub-3: 2-0:1 info: Full speed (or root) Hub ports: 14 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Device-1: 2-4:2 info: Holtek USB Keyboard type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 3 rev: 2.0 speed: 12 Mb/s 
  chip ID: 04d9:a0cd class ID: 0300 
  Device-2: 2-6:3 info: SINOWEALTH Wired Gaming Mouse type: Mouse,Keyboard 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  chip ID: 258a:1007 class ID: 0301 
  Hub-4: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0 
  speed: 480 Mb/s chip ID: 1d6b:0002 class ID: 0900 
  Hub-5: 3-1:2 info: Intel Integrated Rate Matching Hub ports: 8 rev: 2.0 
  speed: 480 Mb/s chip ID: 8087:8000 class ID: 0900 
  Hub-6: 4-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip ID: 1d6b:0003 class ID: 0900 
  System Temperatures: cpu: 44.5 C mobo: 36.0 C gpu: nvidia temp: 60 C 
  Fan Speeds (RPM): cpu: 697 fan-1: 0 fan-3: 0 fan-4: 850 fan-5: 782 
  gpu: nvidia fan: 0% 
  Power: 12v: N/A 5v: N/A 3.3v: 3.30 vbat: 3.33 
  Processes: 286 Uptime: 48m wakeups: 0 Init: systemd v: 247 Compilers: 
  gcc: 10.2.0 clang: N/A Packages: 1462 pacman: 1453 lib: 409 flatpak: 4 
  snap: 5 Shell: Bash v: 5.1.0 running in: terminator inxi: 3.3.01 

journalctl -b -1

Also when pressing CTRL + ALT + DEL following message appears:

[ 1003.726254] systemd_shutdown[1]: Waiting for process: kwin_x11, dbus-daemon, gpg-agent, scdaemon, systemd, dbus-daemon

Hope you guys can help me.
Thanks in advance.

Hi @CallMeMisterOwl, and welcome!

While I certainly don’t have this problem (So please don’t take my word as the be-all and end-all of this), the lines with message watchdog: watchdog0: watchdog did not stop! seemed suspicious. So, I just googled around a bit and it seems watchdog can cause problems in this regard.

The Arch wiki states that if you have a desktop or laptop, you can disable the watchdog. Apparently it also improves performance and battery life.

So maybe, just maybe, you should give it a ask/disable/uninstall and see if it helps?

Thank you for your answer @Mirdarthos.

I’ll try that and report back with the results.

I saw a similar post, but I’m afraid this will only fix the symptom and not the problem itself. But in case I don’t find a better solution, I’ll have to resort to this.
Still thanks for your answer.

So I successfully disabled the watchdog (wdctl returns No default device is available) and the there is no more watchdog0: watchdog did not stop!.

Unfortunately the problem still persists.

I’ll have to settle for @flux 's solution, until I find the root of the problem.

Problem is at line 2883. There is then the standard 90 secs until session is killed at 2885.

I suggest you look on KDE bugs for akonadi crashes.

I think you’re right, when the akonadi crash doesn’t occur, the system shuts down without delay.
I tried this and it somehow worked, no more akonadi crashes.
In case this happens again I know where to look.
Thanks a lot :blush:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.