Sharing problem

Thank you megavolt for trying.
I have trouble finding what I want so I want to keep the snap source of packages.
I don’t believe that samba can’t work with apparmor being installed.

I will keep looking on the internet and maybe there is someone else on in this forum who knows more about samba than I do (which is not much).

If I cant fix this I’ll look for another rolling release distro.

Have a look at these, if you haven’t seen them already:

Thank you for the suggestions.
My browser (nemo) has Sharing Options in the context menu that I use to try to share.
The Setup and Troubleshooting link is mostly beyond me at this stage.

The error I am getting contains "cannot convert name Everyone to SID.
What does that mean? what is SID?

Edit: I have provided my password to samba with sudo smbpasswd -a user.
Where ‘user’ is my username.

I am surprised that others are not complaining about this issue.
I found a page from Manjaro about exactly this error as follows:

My installation came with Kernel 6.1.7.-1 - it behaves like above.
I downloaded Kernel 5.15.89-1 LTS - at also behaves like this.

SID → Security Identifiers
It is a Windows term. “Everyone” on Linux gets translated to “S-1-1-0”

Thank you for the link, but didn’t help.
If “Everyone” on Linux gets translated to “S-1-1-0”, they why do I get the error
“cannot convert name Everyone to SID”?
I think that this is a Majaro problem as I had no such problem, on the same machine, the same partition settings, on Linux Mint. I installed Linux Mint a week before Majaro but then discovered that there are rolling release distros.

Maybe my work around this problem will have to be going back to Linux Mint or trying another distro. Linux Mint also had much more and better GUI settings.
My reason for installing a linux distro was that my HDD crashed and after replacing the HDD, had to install something - I could have just restored Win 7 from my backup but decided to try win 10. It took about 1 hour and worked fine. Unfortunately, it is too slow on this machine to use, so decided to try a linux distro. I looked at a number of them and decided on Linux Mint. Took a week to get it to look like what I am used to and work properly. Then discovered that there are such things as rolling release distros and that’s when I decided to try Majaro. I’ve been trying to get this installation to work properly for about a week. You can see why windows users are so reluctant to even try Linux. I have actually restored my win 7 and now dual booting with Manjaro.
Sorry for the long story but it probably doesn’t belong in this thread.


Yeah I totally understand that, but ArchLinux and all ArchLinux based Systems like Manjaro share the same common goal: Simplicity, but not beginner friendliness. While you can fix problems with ease, also samba and apparmor, you need knowledge, even if it is simple. It needs more maintenance compared to Linux Mint and especially debian-based systems, because it always updates your system to the next new version while Debian often do only security updates and not feature updates.

Manjaro itself is made to be easily installed and also to configure, compare to bare ArchLinux, but it is by all mean not beginner friendly like debian based systems: Ubuntu, Linux Mint, PopOS.

Let me explain it in short:

Apparmor is a module that uses kernel techniques to sandbox samba. Apparmor rules locks samba into a jail, where it is only allowed to do what the rule says. Therefore, if it doesn’t allow samba to convert it, then it will result in an error here.

However… did you install manjaro-settings-samba ?

I can only say, that samba work perfectly well on my system, without snap and without apparmor. I don’t need both when I run this in my local network.

1 Like

Yes I did install manjaro-settings-samba but couldn’t work out how to launch it.

Tried to remove apparmor but refused due to dependency from snapd.
So tried to remove snapd and also refused due to dependency.

frank@Dell1 ~]$ pamac remove apparmor
Checking dependencies…
Error: Failed to prepare transaction:
could not satisfy dependencies:

  • removing apparmor breaks dependency ‘apparmor’ required by snapd
    [frank@Dell1 ~]$ pamac remove snapd
    Checking dependencies…
    Error: Failed to prepare transaction:
    could not satisfy dependencies:
  • removing snapd breaks dependency ‘snapd’ required by libpamac-snap-plugin
    [frank@Dell1 ~]$
pamac remove --cascade apparmor

Thank you. That did the trick. Now removed.
I rebooted, tried the share again in the context menu and guess what, it worked.
Now it shows that it is sharing.

Unfortunately that’s as far as it goes.
In the file manager, and Networks, the computer is visible now but selecting that required the password and then an error:
Unable to mount location.
Failed to retrieve share list from server: Invalid argument.

On the other computers there is no sign of this computer.

enable avahi-daemon

sudo systemctl enable --now avahi-daemon

For your information - there is several topics in the Tutorials section on samba - both setup and troubleshooting.

1 Like

It seems that you are not using gnome/nautilus, but take a look here:

Add this option under the [global] section:

    client ipc signing = auto
 then restart samba (systemctl restart smb.service) or reboot

linux-aarhus, I tried your suggestion to enable avhi-daemon.
It didn’t work. However, looking into your links I found another link about sharing NTFS on Majaro:

I tried to complete the instructions but I received ‘Failed’ in terminal.
But when I tried to access the partition on my windows machine, there it was.
It looks like it is now working as I expected in the first place.
Thank you everyone for helping.
I can now go to the next problem - I’ll start another post.
Thank you again.

You fail to mention the complete message - so I am guessing …

A mount unit may fail if target is already mounted in /etc/fstab - this is expected behavior - if a unit and fstab target the same mountpoint.

There should be no issues mounting the same device on different mountpoints.

Also bear in mind that mount units must be named after their mountpoint path.

From the PoC the mountpoint /srv/samba/ntfs’s unit name is srv-samba-nfts.mount.

Changing the mountpoint inside the unit will also throw a failure when starting/enabling the unit.

This is an entirely different subject and likely why your attempts fail.

User shares is an optional advanced setup and requires options to be set in smb.conf and further it requires a folder /var/lib/samba/usershares

Read more Samba - ArchWiki

Hello linux-aarhus.
Thank you for your explanations.
Please note that my experience with linux is extremely limited. I installed Linux Mint Xfce for a few days with minimal problems. Then discovered Rolling Release distros and installed Manjaro. So my main experience is during this tread in the forum.
So when you say “You fail to mention the complete message”, I had no idea that the fstab entry has anything to do with the share configuration.
I apologize for the term “My browser (nemo)”, it’s not My browser but My file manager (nemo).
The only things I know about linux is what I am learning now and the amount of my knowledge feels quite minimal. I come from Windows 7 with a Classic theme and classic menu for 25 years.

It doesn’t. But it becomes relevant because the failure you mention was in relation to your reading and possibly testing the PoC on NTFS formatted devices where changes you made may have interfered.

Then you have to unlearn everything - you cannot mogrify your Windows knowledge to LInux.

Nobody mentioned that ‘new’ samba uses a different protocol than Windows 7. If you are attempting to network with a W7 computer, /etc/samba/smb.conf needs to be modified to use the ‘old’ protocol. Add to Global Settings:

client min protocol = NT1
server min protocol = NT1

I didn’t need to add the NT1 into smb.conf.

linux-aarhus, I read through your link about becoming a Manjaro power user.
An interesting article, but it has a link to another article about “Linux is not Windows”
This is a long article but very worthwhile to read. There is something I don’t agree with and they left out something important.

  1. It states that the developers don’t care about attracting windows user to Linux.
    If this is true, why spend so much effort in creating so many window managers and themes to resemble windows. The one thing they haven’t done is copy the Windows Classic Menu (Drag and Drop on single column).
  2. I agree with the comparison they make about the windows user (using a car) and the Linux user (using a motor bike). They are not the same, they are different. The car user will say that the car is better, but the motor bike user will say that the motor bike is better. I understand that. The problem with this comparison is that very often the comparison is not a car versus a motor bike, but a car versus a motor bike without the brakes working and broken mirrors.
    Installing a Windows system it is unlikely that the network doesn’t work or the synaptics mouse pad driver doesn’t work, etc. This is common on Linux. It is great to fiddle with the system, but it is not great to have to troubleshoot a system not understood just to make usable in the first place.
    I agree that linux is getting better. It’s had 25-30 years.
    I’ve looked at about 16 distributions now. The first I actually installed was Linux Mint. It did work but it’s not a rolling release distribution. After deciding I want a rolling release distribution I chose Manjaro - this didn’t work. After a week of persistence, I have it working. Not many Windows users would attempt such an exercise, even if they were capable. Most I know would not be capable of getting Manjaro to work.

I don’t think you will ever get samba working with W7 unless you add those parameters to smb.conf
I have several W7 installs (virtual machines) and samba requires the NT1 parameter (smb1) for sharing, because that is the only samba that W7 knows. And, to share W7 and W10, the W10 registry must be edited to use that parameter or networking will not work between W10 and W7, either. I’ve been through this myself.