Several problems with Plasma 6 on Wayland (and X11...)

Hello! In my experience Plasma 6 is rather immature, and is causing several problems, especially on wayland. I use a laptop with an AMD integrated card, and fractional scaling. Here is a list of some problems I am experiencing

In wayland, when I maximize a video, after some seconds the whole screen goes black. This also happens in spectacle, if I try to take the screenshot of a rectangular region
In wayland, the font is still not as crisp as in X11, even in Qt programs. Additionally, when I drag a window to a different position, for a while the font appears even more blurry after releasing the window
In wayland, in many GTK applications, such as Pinta or Inkscape, the font looks “segmented”
In wayland, in Firefox web pages, scaling factor is not applied and text looks tiny
In wayland, mouse pointer is oversized
RAM usage has increased dramatically, in a new Plasma session about 2GB are in use
(In wayland?) Apparently there is a memory leak. After some usage time, even if I logout from my Plasma session I am still using about 4GB of RAM (excluding caches of course). I cannot find a culprit among processes
In wayland and X11, especially in wayland, icons on system tray and, to a lesser extent, task manager and start menu are blurred and disproportionate
In wayland and X11, if I select the “Breeze Classic” color theme, there is a nasty tiny white border around the black title bar
In X11, the title bar looks too tiny (apparently it does not scale according to the scaling factor)

  • Self-solved by changing scaling factor in the Display Configuration settings in an X11 session. Maybe going back and forth between X11 and Wayland had messed up the X11 display configuration.

In X11, Plasma does not remember the relative position of monitors in a multimonitor setting

In X11, I’m experiencing several crashes of Plasmashell

  • It doesn’t seem to happen anymore

3 posts were split to a new topic: Transparency stuck on KDE desktop

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.