Setting meta for a launcher in Plasma

For years, I used latt-dock and had dashboard as my main launcher. I assigned meta key for it and it worked well. Then, some development happen and meta was disabled from being a main and only key, instead it become a helper key, meaning it only is valid with combos, like meta+d and so on.

However, despite that change, my old configs were still working well and meta was my main key for launching dashboard. Unfortunately, I lately wanted to try out cutefish DE, installed it and then removed it after I was done with it. Since cutefish is using kwin and some of the plasma elements, it interfered with it somehow and reset some configs somewhere (not sure which one), but now META KEY IS NOT WORKING ANYMORE.

I tried changing kglobalshortcutsrc file. I assume that lines:

_k_friendly_name=Latte Dock
activate entry 1=none,Meta+1,Activate Entry 1

could be the ones I’m looking for. The system won’t let me assign meta anymore, so I tried altering this to meta only. I save it, relog and… the line is brought back. So no matter if I change it to:

activate entry 1=none,Meta,Activate Entry 1

it goes back to default Meta+1.

I assume, there is some global config in the /etc (probably) that is used to fix it or maybe some other mechanism repairing the broken entries in config? Plus, I’m not sure if that is the line or config I’m looking for.

Has someone an experience with it and know how to bring my shortcut back? When I old config, it didn’t change anything, so it may be some other config and finding out how to make that line permanently meta may not be a solution here.

I found this topic:

But when I applied meta+f1, launcher works exactly with meta+f1, not with meta alone. So this isn’t a solution. I open launcher so often, that it makes sense to have it with easily one hit key. Any shortcut with F+ is not convenient at all and unsuitable for common actions.

Hi @michaldybczak,

Try seeing it to Alt+F1. My launcher’s is like that and Meta opens my launcher just fine.

Hope it helps!

1 Like

No, it still does work as a standalone key — I am using it with the dashboard myself — but it will only work if you have an application launcher icon on your panel, and I believe you also have to have a secondary shortcut associated with it, such as Alt+F1.

However, I do not know whether this covers the panel replacements offered by Latte.

I tried with the default panel, the same issue. Setting launcher with meta+f1 launches it only with meta+f1.

I noticed that in my kglobalshortcutsrc it created a new line:

activate widget 42=Meta+F1,none,Włącz element interfejsu: Tablica programów

As before, deleting +F1 is not saved and after relog, that line looks exactly as above. The same happens if you have a default panel.

My guess is, something else must be preventing it. Maybe cutefish added some own config that is now actively overwriting the intended behavior?

Dis you try with Alt+F1 and not just Meta+F1?

The same result with alt+f1. It works only with it, not with meta.

I deleted cutefishos folder from configs, didn’t change anythng. I also noted in kwinrc a line:

Meta=org.kde.lattedock, /Latte, org.kde.LatteDock, activateLauncherMenu

So it does look as if latte was somehow involved in it, but still, this line looks like that now and it looked the same in the past (on my backup) and the meta alone doesn’t work.

Well, maybe Cutefish did mess it up, yes. I honestly don’t know.

see it there’s something useful for you here:



The issue did happen exactly after the cutefish install. Anyway, I found the solution:

I brought back my kwinrc and kwinrcrulesrc from my backup, relogedd and now meta launches my dasboard as before. No idea what is the difference, because looking inside config, I didn’t notice anything. I guess I need to use meld to find out the differences.

In the new kwinrc (the one that was problematic, now renamed to kwinrc.bak), the line:

Meta=org.kde.lattedock, /Latte, org.kde.LatteDock, activateLauncherMenu

has spaces, while in old one there are no spaces after comas and it loooks like that:


Should have been your first step. That is, after all, what backups are for.


Yeah, but it’s not clear which confg must be changed. I first tried with kglobalshortcutsrc and it didn’t make any difference.

I had issues with this before.

The actual standard launcher shortcut is Alt+F1

I tested other launchers, adding them and setting them to be something like Meta+Z - but the Alt+F1 is what launches from the Meta key.

If you don’t want to clutter up the desktop, then put launchers on a auto-hidden latte or something; the only two things I see most of the time are my tray, and my event calendar.

But yes, if you can’t fix the Alt+F1 launching from Meta (as I say, there were issues in the past - but it’s cleared up now) then I’d suggest go with Meta_z because that’s also pretty easy to hit.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.