Sea of Thieves not Working on Manjaro

I try to play Sea of Thieves with Proton-5.9-GE-6-ST and after logging in to Microsoft account if I wait the splash screen it gives Cyanbeard error*, if I don’t wait but skip it, I can get to the main menu but after a while it gives the same error. But if I try fast to open a crew (basically starting the game) it gives Coarsebeard error**.

I tried fresh install Pop_Os and it worked after installing wine to it, I also tried fresh Manjaro install but it gave the same errors. So I think there is something in Manjaro that causes this.

To reproduce what I do:
1 -Download Sea of Thieves
2- Download Proton-5.9-GE-6-ST
3- Extract it to ~/.local/share/Steam/compatibilitytools.d/ (create the last folder if not exists)
4- Restart Steam
5- Go into the game properties and force it to use Proton-5.9-GE-6-ST
6- Start game

I can give any logs but I don’t know which ones are needed now. Any response, information are appreciated.

Cyanbeard error*: Your connection to Xbox Live has been lost. Please check your connection and try again.
Coarsebeard error**: Sea of Thieves failed to setup a crew session. Please try again.

Any reason you’re not using the official Proton in Steam? Does it work with default Proton?

ProtonDB seem OK https://www.protondb.com/app/1172620

// EDIT: also if you want to clean the Wine/Proton prefix, it is located at ~/.local/share/Steam/steamapps/compatdata/{APP ID OF THE GAME}, so simply delete the corresponding folder (here should be 1172620 for Sea of Thieves) if you want to reset the prefix, it is sometimes necessary when switching proton version especially with custom builds downloaded from internet. Worth trying. Note that it will delete all the config files / save files locally but it may recreate them as most games use Steam Cloud. If you want to play it safe, rename the folder instead of deleting it.

1 Like

As you can see in the protondb site everyone uses custom proton because stock ones don’t work with this game (custom one has a fix for the game). And I also used this custom version of proton with my 2 fresh OS installs, forgot to mention there.

Deleted the game folder in compatdata and the bug still remains.

I see people using custom builds but I see people using official Proton too.
Proton issue tracker also confirms that the game works with official Proton Sea Of Thieves (1172620) · Issue #3931 · ValveSoftware/Proton · GitHub and lists current issues.

Maybe verify your game files in Steam, clean the prefix, use the official Proton, and try to launch the game multiple times. Also from what you say it seems to work because if your get in game error message when trying to create a lobby/game, then Proton works. So the issue may not be Proton but maybe you have some network/firewall setup we don’t know.

// EDIT: some googling led me to posts like this one Sea Of Thieves (1172620) · Issue #3931 · ValveSoftware/Proton · GitHub if you want to try random fixes from internet.

// EDIT2: no issue regarding your network? Connection quality/stability?

1 Like

I tried everything you said including the fixes in github page and read all comments in there and asked at the end before I came here.

But as I said it works in pop os, also tried Windows; they all work. Only time I cannot play is when I use Manjaro, which I also tested a fresh install. I am sure the issue being about Manjaro.

(I use testing branch in my everyday use setup but the fresh install was in stable and all up-to-date.)

I don’t know maybe try to compare your working and non working systems then maybe there is a big difference somewhere (driver version, desktop environment, things like that)?

I tried an older kernel with my fresh install Manjaro and it also does not work. I don’t know how can I compare Manjaro and Pop_Os. The only think I can try is DE but I do not think this is the issue but I will give it a try.

You should be able to fix this by linking your steam account with the m$ account outside of SoT. It didn’t work for me initially but this worked. I got it working under Eggroll’s proton as well as standard proton, however, I did have to tweak it following the instructions on protondb. It still works for me. Hope this helps.

I looked and there are only 3 ways to link steam and ms
(I cannot post links or photos for some reason)

  • Link an account using Xbox Game Bar
  • Link an account using the Xbox app
  • Link an account from a game purchased on Steam

Because I do not have windows installed right now I tried linking from the in-game option on the main menu after logging in but it did not work. Can you point out which instructions specifically, like the username of the person who wrote the instructions on protondb. Thanks.

P.S: I also tried GNOME after my last reply but it didn’t work either

Try linking through a VM if you can, I had already installed windows in order to get SoT working. Which has lead to a lot of problems moving back to Manjaro for some reason. Once it’s linked, you no longer have to use it on windows, though I would recommend against installing windows itself.


I did this for proton 5.0

Not sure if this is what you’re after but it’s the process I went through to get it working.

Tried winhttp.dll again but it did not work, tried win7 with protontricks but it didn’t work either. I cannot find a way to use that patch file, there are no files named after the ones it tries to modify.

Edit: also tried linking in windows (VM did not work and installed dual boot) it also did nothing

And also my main question was not “Why this game does not work in Linux?”, my question was “Why this game does not work in Manjaro?”. Because I can play it on another distro. I want to submit some logs to developers or who can help me to understand what is wrong in the distro. Or at least point me something to look and fix for myself. I do not think in-game or proton related solutions will fix anything at this point. Thanks for the previous replies.

Can you launch it with lutris instead of natively through steam (you can use steam in lutris). Lutris will show you the log (press terminal icon) while the game is loading and will show where it fails. You might see something there

It works on Manjaro according to all the reports on ProtonDB. It doesn’t work on your side, difference.

I doubt you actively follow Proton development, so I’m comming back here to let you know there is a new Proton version available in Steam, so I suggest you to clean everything, select the new Proton 5.13 globally in Steam, and try again. That may solve issues you had on your side with the game and Proton.