Screen won't turn off

Hello, friends.

Previously, I had an nVidia graphics card and had no problems. However, after updating the graphics card and drivers for the AMD card, my screen does not turn off after the specified time in the power manager.

For example, before, I had it set to turn off after 3 minutes. Now, I set any time and it turns off, then turns on (only on x11). That is, it should turn off and not turn on without mouse or keyboard movement, but it turns on immediately after the screen displays a message that there is no video signal.

I would prefer not to completely reinstall the system to test how it behaves on a clean installation of the system and AMD drivers. Therefore, perhaps you can suggest something. I have tried different kernels (5.15, 6.1, 6.2, 6.3), but there is no effect.

Also, since I installed the AMD card, I hoped that open source drivers would give smoother performance for the entire system. However, when working on Wayland, the screen also does not turn off at all. It only turns off on x11, but immediately turns on.

At the same time, my peripheral devices are working properly and I have not changed them. That is, the same mouse and keyboard were used with the nVidia card. I have no other devices that could be waking up the screen.


Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.4
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 6.3.0-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™2 Quad CPU Q9550 @ 2.83GHz
Memory: 5,8 GiB of RAM
Graphics Processor: AMD Radeon RX 470 Graphics
Product Name: MS-7360
System Version: 1.0

Friends, do you have any ideas?
I updated my computer hardware. I reinstalled the operating system, but the problem is still relevant.
On X11, the monitor turns off, but then immediately turns on.
On Wayland it doesn’t turn off at all

This might be your problem.
You can try linux60-rt , this works on my ryzen 7 6850u notebook, while linux61 ,linux62 and linux63-rc5 will not suspend (x11 here).
The first sugestion in this thread, appending
to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub is also partially working on my machine, so I can wait for a fix (hopefully) in the next update.

And if you have not seen yet,

1 Like

On 6.0 my system won’t start at all.
But thanks for the advice.

Does this command work?

xset dpms force off

If so, somebody reported it was an issue with his webcam:

Unfortunately, apart from the keyboard and mouse, I have no other third-party devices connected (except for monitors, of course).

xset dpms force off                                                                            ✔ 
server does not have extension for dpms option
xset:  unknown option force

Friends, is there any point in trying to install other drivers (modesetting, vesa)?

If I understood you correctly, then among other things, you advised adding such a setting to the bootloader configuration. I tried. It didn’t fix the screen behavior. It still turns off and on again, immediately.

GRUB_CMDLINE_LINUX_DEFAULT="quiet cryptdevice=UUID=0000-00-00000:luks-0000-0000 root=/dev/mapper/luks-0000-000-0000 splash resume=UUID=000-000-000 udev.log_priority=3 !!! amd_iommu=off !!!"

As you can read in the arch forum link, various users with various amd systems have various workarounds. This is no advice, this is “try and error”. As long as this is not fixed, we have to get around that somehow. My best option on my notebook is linux60-rt.

For programmers, this is called a “crutch” )

For some reason, when I use Wayland, those programs that were open are not remembered when I exit and enter a session or restart the PC. For example kate, dolphin. Do you also?
Although at x11 they open at login.

I have 2 monitors installed. First is Philips 246e.
Second - Samsung 223BW.
If I turn off the first one (Philips), and set the monitor to turn off after 1 minute (when only Samsung is working), then it works. Samsung turns off and turns on only when I move the mouse or press keys on the keyboard.
But, if I turn off Philips or use it together with Samsung, then the Philips monitor turns off, writes that there is no input signal and turns on again…
Perhaps there is some solution.