Screen Tearing while Gaming with Optimus


My Problem is that while gaming i get terrible screen tearing. I Have a Laptop with an Intel HD and a GTX 1050 on Manjaro KDE. I installed the proprietary driver via the manjaro install menu in the settings. Works fine, but when i play CS GO (surf maps especially) and i get like 150-200 fps the screen tearing is really bad. Im also limited in the nvidia menu because it is optimus and not “purely” nvidia, so the fixes i googled wont work for me, see picture for settings (cant upload so heres the link. just add a . before com) imgurcom/a/8fugrUH

well, i now kinda got it working, but not like i want to.

I tried everything i could find on the internet.
installed optimus manager and tried with only nvidia card activated but i still got tearing.
adding the DRM kernel mode setting (nvidia-drm.modeset=1) to grub as it is written in the archwiki did also not help. not with hybrid mode or pure nvidia mode.

then i tried LinuxMint and there it works with the nvidia mode and the added kernel mode setting to the grub config. ii get no tearing with those settings while gaming. I really would like to continue to use manjaro, but the screen tearing is just a nogo.

If anyone knows how to fix that issue on manjaro(KDE) pls post it here :slight_smile:

Can you check if PRIME synchronization is enabled? Run xrandr --verbose, and then check if the integrated display has “PRIME Synchronization: 1”.

I’m currently on Linux Mint, here i can see in the nvidia settings when I’m on the only-nvidia mode, that the prime sync is on. It was off prior to me adding the nvidia-drm.modeset=1 to the grub config. In hybrid mode it is always off.

Don’t really wanna reinstall Manjaro until i see a potential fix (have it backed up via timeshift so wont take long) but I remember on Manjaro(KDE) that it was always off and I could not get it to on. No matter what i tried.

solution here:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.