Screen Tearing while gaming on Kde Plasma

I’m posting this here in the Kde Plasma section, because the problem seems to be KDE specific. Here is a link to my old post in the Graphics & Display category: Screen Tearing while Gaming with Optimus (short summary, Laptop with intel and nvidia graphic, optimus -> hybrid driver 455 installed, get screen tearing while gaming on games with high framerate)

I now have Manjaro Kde and Manjaro XFCE installed side by side and on XFCE i get no screen tearing while playing Games with high frames, like CS:GO. On Kde I still get really bad screen tearing. The setup on both of those installs was exactly the same.

I have a slight suspicion that it has something to do with the compositor. When I’m on Kde and press the key comination alt+shift+f12 to reset the compositor, the screen tearing gets better for a second before getting worse again.
I then tried to change the settings in the compositor section in the settings and un- and rechecking the box for allowing programs to deactivate compositor, but nothing seems to help :(.

I would really like to have it working on Manjaro Kde, XFCE just is not my thing to put it mildly ;).

What is your Rendering backend en tearing prevention setting in the Compositor?

You could try

Rendering Backend to OpenGL 3.1
Tearing Prevention to Automatic

Above worked for me, this does not mean it also works for you

Don’t know about the hybrid systems much, but on a normal KDE Nvidia system I do that and it is perfect, on a non Gsync monitor.

Not sure how you could configure your system as I think the main video card is NOT the Nvidia one. I’m sure knowledgeable people will chime in to get you going.

This does sadly not work, because of the hybrid driver. You can’t change anything in the nvidia settings. But thank you for the suggestion :slight_smile:

Yeah that’s what I was wondering, I know people start the Nvidia Settings with prime-run or something like that, but yeah it is probably not the good way, just wanted to bring that up as it could help think about a way to achieve similar configuration.

Maybe have a look at the wiki there are info about screen tearing.

https://wiki.manjaro.org/index.php/Using_Compton_for_a_tear-free_experience_in_Xfce

Maybe not relevant as your’re using the hybrid driver.

Hence the reason I suggested changing the settings in the Compositor tab from KDE settings.

Did you already tried that ?

I would like to try that, but it seems that i would have to deactivate the compositor that is currently running. Its only documented for XFCE in that Wiki as far as I can tell. If you know how I can do it on Kde I will try it.

in about 15 minutes or so. Making Chicken Wings right now :smiley:

Great I will give you my address so you can send some over :stuck_out_tongue_closed_eyes:

My bad, I though you were on XFCE not KDE I remembered wrong the initial post.

//EDIT: tried to look there? Search results for 'kde tearing hybrid' - Manjaro Linux Forum

Looking at the OP it has nothing to do with his common settings else it would also occur in XFCE. This at least for as far I know (which is not very much).

So it seems KDE-Plasma specific.
Only thing you can try than is fiddle with its settings,

…For now I am just waiting for the chicken wings with hot sauce…

For me the issue lies in the compositor/desktop settings and/or the video config (but that I’m not familiar with, I don’t personally use hybrid graphics).

cant really play and test with the settings right now, because the cs.go network seems to be down. Will try it later. And for the Wings. They are all gone :smiley: but heres the link to the hot sauce i can recommend: https://www.amazon.de/gp/product/B07FTKRB84/ref=ppx_yo_dt_b_asin_title_o04_s00?ie=UTF8&psc=1

I think the settings in the picture here are what is working for me. I get no Screen tearing now with the box unchecked that lets programs block the compositor. I hope that this does not have bad side effects. Well time will tell :slight_smile:. I thought I had already tried those settings, but maybe not. Guess I’m getting older ;).
Thanks everyone for helping

The bad effects I noticed is when this box in enabled, as some programs (for Instance Mad Max game Linux version) can disable the compositor to ‘gain performance’ but when it is disabled your desktop is broken when you ALT+TAB out of the game (like the Panel and icons, the clock, nothing refreshes it stays in an old random state, blocked). It’s been two years almost that I run with this setting disabled (see my post linked above, where I detail my KDE settings in image).

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.