Screen tearing when moving mouse at max resolution

I’ve recently installed Manjaro KDE on a brand new pc, but when I try to set the desktop resolution to the max value (3840:2400 16:10) I get some awful screen tearing whenever I move the mouse (staying still doesn’t trigger this). Interestingly, it doesn’t seem to get picked up by the built in screencap, so I can’t get a screenshot to show the effect. I can try with an external tool if that’s needed for more info. How can I fix this?

System information:

  Kernel: 5.15.32-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=c0382431-3b04-4e3b-82d0-8eec3d9f6e2c rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma v: 5.24.4 tk: Qt v: 5.15.3 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 17 9720 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0W7GHH v: A00 serial: <superuser required> UEFI: Dell
    v: 1.4.0 date: 03/08/2022
  ID-1: BAT0 charge: 93.2 Wh (100.0%) condition: 93.2/95.1 Wh (98.0%)
    volts: 13.2 min: 11.4 model: SMP DELL 01RR3YM type: Li-poly serial: <filter>
    status: full
  RAM: total: 31.04 GiB used: 3.47 GiB (11.2%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i9-12900HK bits: 64 type: MST AMCP
    arch: Alder Lake family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x419
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 1295 high: 2787 min/max: 400/6300:6400:3800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 612 2: 603 3: 400 4: 768
    5: 485 6: 519 7: 456 8: 626 9: 560 10: 594 11: 985 12: 1437 13: 2567
    14: 2756 15: 1351 16: 2698 17: 1489 18: 2364 19: 1846 20: 2787
    bogomips: 116780
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2 bts
    cat_l2 cdp_l2 clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault
    cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c
    flexpriority flush_l1d fma fpu fsgsbase fsrm fxsr gfni ht hwp
    hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdt_a rdtscp rep_good sdbg sep serialize sha_ni smap
    smep smx split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq
    umip vaes vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec
    xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel ports: active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, DP-5, HDMI-A-1
    bus-ID: 0000:00:02.0 chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] vendor: Dell
    driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm
    bus-ID: 0000:01:00.0 chip-ID: 10de:2520 class-ID: 0300
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 0c45:6a15 class-ID: 0e02
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
    s-diag: 798mm (31.43")
  Monitor-1: eDP-1 model: Sharp 0x1517 built: 2021 res: 2560x1600 hz: 60
    dpi: 178 gamma: 1.2 size: 366x229mm (14.41x9.02") diag: 432mm (17")
    ratio: 16:10 modes: 3840x2400
  OpenGL: renderer: Mesa Intel Graphics (ADL GT2) v: 4.6 Mesa 21.3.8
    direct render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 0000:00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel
    bus-ID: 0000:01:00.1 chip-ID: 10de:228e class-ID: 0403
  Sound Server-1: ALSA v: k5.15.32-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.49 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:6
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 1.86 TiB used: 19.24 GiB (1.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC801 NVMe 2TB
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 51002141 temp: 41.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 976.56 GiB size: 960.16 GiB (98.32%)
    used: 19.14 GiB (2.0%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
    label: N/A uuid: c0382431-3b04-4e3b-82d0-8eec3d9f6e2c
  ID-2: /boot/efi raw-size: 200 MiB size: 196 MiB (98.00%)
    used: 99.5 MiB (50.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: ESP uuid: 2ADE-507B
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 128 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 910.43 GiB fs: bitlocker
    label: N/A uuid: N/A
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 1.01 GiB fs: ntfs
    label: WINRETOOLS uuid: 0C5A195C5A1943BC
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 17.97 GiB fs: ntfs label: Image
    uuid: 761C19C11C197CF5
  ID-5: /dev/nvme0n1p6 maj-min: 259:6 size: 1.43 GiB fs: ntfs
    label: DELLSUPPORT uuid: A026A74726A71D72
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-3:2 info: VIA Labs USB2.0 Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    chip-ID: 2109:2211 class-ID: 0900
  Device-1: 1-3.2:5 info: Dell DA20 Adapter type: Billboard driver: N/A
    interfaces: 1 rev: 2.1 speed: 12 Mb/s power: 2mA chip-ID: 413c:b080
    class-ID: 1100 serial: <filter>
  Device-2: 1-6:3 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6a15 class-ID: 0e02
  Device-3: 1-9:4 info: Shenzhen Goodix USB2.0 MISC type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 27c6:63ac class-ID: ef00 serial: <filter>
  Device-4: 1-10:6 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 3-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-5: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-6: 5-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-7: 6-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-8: 6-2:2 info: VIA Labs USB3.0 Hub ports: 1 rev: 3.1 speed: 5 Gb/s
    chip-ID: 2109:0211 class-ID: 0900
  System Temperatures: cpu: 49.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 504 Uptime: 4m wakeups: 283 Init: systemd v: 250 tool: systemctl
  Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: 1268 pacman: 1257 lib: 333
  flatpak: 0 snap: 11 Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.15

post also output from: mhwd -l && mhwd -li

Hello @merlo :wink:

file: /etc/X11/xorg.conf.d/20-intel.conf

Section "Device"
  Identifier "Intel Graphics"
  Driver "intel"
  Option "TearFree" "true"
  Option "TripleBuffer" "true"
> 0000:01:00.0 (0300:10de:2520) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
          video-nvidia            2021.12.18               false            PCI
    video-nvidia-470xx            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:00:02.0 (0300:8086:46a6) Display controller Intel Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI
video-hybrid-intel-nvidia-470xx-prime            2021.12.18               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
video-hybrid-intel-nvidia-prime            2021.12.18               false            PCI

Warning: No installed USB configs!

I tried the solution proposed by @megavolt, but after editing the config file and rebooting manjaro wouldn’t boot at all, staying stuck on something like

/dev/nvme0n1p7: recovering journal
/dev/nvme0n1p7 clean, 476519/3662848 files, 7840227/14650980 blocks

I was somehow able to boot from the CLI and edit the file back to empty, and the system booted again.

Something else I should probably mention, but I’m not sure if it’s related. Ever since installing Manjaro on this machine, whenever I try to shut it down, the system always hangs on three “systemd-udevd” processes that won’t end and I have to shut it off by hand. I meant to open a separate forum post but I’ll mention it here since I don’t know if it can help. I know the process manages devices, so could it be related to the no USB configs message?

One last thing, the “recovering journal” and disk messages I mentioned earlier always show up on boot, but the system usually goes through them, it just got stuck on them after editing that config file.

Any ideas? Please let me know if there’s anything else I can do to help

Since you didn’t provide a any logs (example: current log /var/log/Xorg.0.log), I can only assume, that without modesetting Alder Lake GPUs don’t work.

This is method to catch all logs:

export logs=(/var/log/Xorg.*.log $HOME/.local/share/xorg/Xorg.*.log)
for x in ${logs[@]}; do echo -e "\n---$x---\n$(cat $x)"; done

On Gnome you need this:

journalctl --boot 0 --user --grep "\([A-Z][A-Z]\)" --no-pager  
journalctl --boot -1 --user --grep "\([A-Z][A-Z]\)" --no-pager  
journalctl --boot -2 --user --grep "\([A-Z][A-Z]\)" --no-pager  

However… you can look at these man pages:

man modesetting
man intel
Section "Device"
  Identifier "Intel Graphics"
  Driver "intel" # or modesetting
  BusID "PCI:00:02:00"
  Option "OptionName" "true" # or false

And also:

modinfo i915 | egrep "^parm" 

For example add this to the kernel parameter to disable power saving methods:

i915.enable_fbc=0 i915.enable_dc=0 i915.enable_psr=0 

Since I have no logs, I can only guide you with some basic things. :wink:

Hi, thanks for the reply
I don’t really know what I’m looking for in logs and I’d rather not touch anything myself since this is a brand new machine and I don’t honestly trust myself enough to know what I’m doing and touch stuff I don’t know.
Here’s a pastebin of the logs you asked for, if there’s anything else in particular I should look for please let me know
Thanks for the help!

Nothing special there. Seems to work as it should on xorg. Could be a driver/module specific problem of i915 (intel driver).

Yeah your system is pretty new and support for this GPU starts with kernel 5.14: Intel Alder Lake-P Integrated Graphics Controller

Since the driver is integrated into the kernel and you have a hybrid gpu (means intel have to be run in modesetting), my best advice is that there could be improvements on newer kernels.

Try a newer stable kernel:

# linux516 or linux517 or linux518
sudo mhwd-kernel --install linux517

Reboot and choose the kernel at the boot menu at startup. (type ESC)

However… keep in mind that stable kernels live only about 3 months. Therefore you need to upgrade as soon as possible when a major kernel goes EOL (End-Of-Life). Minor Upgrades like should just work like on LTS Kernels.

For example linux516 is already marked as EOL:

If that doesn’t work, then you have to test some driver parameters as mentioned:

1 Like

I have the same laptop, and the same issues as OP, just FYI, so at least can confirm it’s not user error.

OK, can confirm that kernel 5.17 does indeed resolve the screen tearing issue, but not the hanging when trying to restart.

Kernel 5.18 seems to have fixed both for me, even if the blocks/files message still appears on boot, but the system does pull through quickly.

I tested rebooting a few times now and only the first time gave me a different strange error, which I’m not entirely sure where to find the logs for. Otherwise, everything seems to be going relatively smoothly. Thanks for the help!

Welp, I have to edit that immediately, the shutdown issue did not indeed go away, after rebooting another time it came back and it seems to stay. I feel like we should open another topic, since this isn’t relevant to the resolution issue? @robotictacos let me know if you can figure something out ^^

Will do. Honestly I haven’t spent a ton of time looking into that so far, because it only affects me when I restart, but yeah, it’s definitely annoying, and I’m certain there’s a fix.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.