Screen rotation not working after gnome 40 update

Hi guys!
After the recent Gnome 40 update I’m unable to rotate the screen o my tablet pc.
When my bluetooth keyboard is connected screen rotation is disabled and on-screen keyboard doesn’t show up (as expected) but when I detach my keyboard, even if screen rotation becmes available, flipping the screen does nothing.
I read on this reddit post that it’s a known issue and the solution for now is to replace mutter and gnome-shell with mutter-git and gnome-shell-git and rebuild mutter with a specific line added to the build files.
Problem is, even if gnome-shell-git is available in add/remove software, the build fails cause the program “can’t find gnome-shell-git” and I can’t replace mutter with mutter-git without uninstalling gnome-shell (dependencies problem).
I don’t know what to do, any help will be appreciated.

Some system information:

                  Kernel: 5.13.1-3-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
                  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
                  root=UUID=eb15fe92-9dd1-4916-a165-44b7d9c53292 rw quiet splash apparmor=1 
                  security=apparmor resume=UUID=37a38fc5-21ee-47cf-bdf5-1fba174025ed 
                  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.0 
                  Distro: Manjaro Linux base: Arch Linux 
                  Type: Laptop System: Acer product: Aspire P3-171 v: V2.04 serial: <filter> 
                  Mobo: Acer model: Sage2 v: Type2 - A01 Board Version serial: <filter> 
                  UEFI: Insyde v: 2.04 date: 06/24/2013 
                  ID-1: BAT1 charge: 23.4 Wh (69.0%) condition: 33.9/40.1 Wh (84.4%) 
                  volts: 7.8 min: 7.6 model: SANYO AP13A3L type: Li-ion serial: <filter> 
                  status: Discharging 
                  Info: Dual Core model: Intel Core i3-3229Y bits: 64 type: MT MCP 
                  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
                  cache: L2: 3 MiB 
                  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11176 
                  Speed: 1397 MHz min/max: 800/1400 MHz Core speeds (MHz): 1: 1397 2: 1397 
                  3: 1397 4: 1397 
                  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
                  Type: l1tf 
                  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
                  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
                  Type: meltdown mitigation: PTI 
                  Type: spec_store_bypass 
                  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
                  Type: spectre_v1 
                  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
                  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
                  IBRS_FW, STIBP: conditional, RSB filling 
                  Type: srbds status: Not affected 
                  Type: tsx_async_abort status: Not affected 
                  Device-1: Intel 3rd Gen Core processor Graphics 
                  vendor: Acer Incorporated ALI driver: i915 v: kernel bus-ID: 00:02.0 
                  chip-ID: 8086:0166 class-ID: 0300 
                  Device-2: Sunplus Innovation 5M Cam type: USB driver: uvcvideo 
                  bus-ID: 1-1.1:3 chip-ID: 1bcf:2c46 class-ID: 0e02 
                  Device-3: Alcor Micro HD WebCam type: USB driver: uvcvideo bus-ID: 3-1:2 
                  chip-ID: 058f:b201 class-ID: 0e02 serial: <filter> 
                  Display: wayland server: 1.20.11 compositor: gnome-shell driver: 
                  loaded: intel unloaded: modesetting alternate: fbdev,vesa display-ID: 0 
                  resolution: <missing: xdpyinfo> 
                  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
                  v: 4.2 Mesa 21.1.4 compat-v: 3.0 direct render: Yes 
                  Device-1: Intel 7 Series/C216 Family High Definition Audio 
                  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
                  bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403 
                  Sound Server-1: ALSA v: k5.13.1-3-MANJARO running: yes 
                  Sound Server-2: JACK v: 0.125.0 running: no 
                  Sound Server-3: PulseAudio v: 14.2 running: yes 
                  Sound Server-4: PipeWire v: 0.3.31 running: no 
                  Device-1: Qualcomm Atheros AR9462 Wireless Network Adapter vendor: Lite-On 
                  driver: ath9k v: kernel port: 2040 bus-ID: 01:00.0 chip-ID: 168c:0034 
                  class-ID: 0280 
                  IF: wlp1s0 state: up mac: <filter> 
                  Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-1.3:5 
                  chip-ID: 04ca:3008 class-ID: e001 
                  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
                  Local Storage: total: 55.9 GiB used: 28.48 GiB (50.9%) 
                  SMART Message: Required tool smartctl not installed. Check --recommends 
                  ID-1: /dev/sda maj-min: 8:0 vendor: Intel model: SSDMCEAC060B3A 
                  size: 55.9 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
                  rotation: SSD serial: <filter> rev: LLLi scheme: GPT 
                  ID-1: / raw-size: 51.75 GiB size: 50.64 GiB (97.84%) used: 27.89 GiB (55.1%) 
                  fs: ext4 dev: /dev/sda2 maj-min: 8:2 
                  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
                  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
                  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
                  ID-1: swap-1 type: partition size: 3.85 GiB used: 598.2 MiB (15.2%) 
                  priority: -2 dev: /dev/sda3 maj-min: 8:3 
                  System Temperatures: cpu: 53.0 C mobo: N/A 
                  Fan Speeds (RPM): N/A 
                  Processes: 212 Uptime: 28m wakeups: 99 Memory: 1.75 GiB 
                  used: 1.59 GiB (91.0%) Init: systemd v: 248 tool: systemctl Compilers: 
                  gcc: 11.1.0 Packages: pacman: 1456 lib: 432 flatpak: 0 Shell: Zsh v: 5.8 
                  running-in: gnome-terminal inxi: 3.3.05

And a partial output of monitor-sensor with keyboard and mouse disconnected:

        Waiting for iio-sensor-proxy to appear
    +++ iio-sensor-proxy appeared
    === Has accelerometer (orientation: undefined)
    === Has ambient light sensor (value: 58,000000, unit: lux)
    === No proximity sensor
        Light changed: 46,000000 (lux)
        Light changed: 33,000000 (lux)
        Light changed: 59,000000 (lux)
        Light changed: 53,000000 (lux)
        Light changed: 30,000000 (lux)
        Light changed: 21,000000 (lux)
        Light changed: 25,000000 (lux)
        Light changed: 11,000000 (lux)
        Light changed: 26,000000 (lux)
        Light changed: 38,000000 (lux)
        Light changed: 52,000000 (lux)

As you can see, both accelerometer and light sensors got detected, but If i try to rotate the tablet the accelerometer doesn’t output any data, so I assume it’s not working.

It all worked fine in gnome 3.38, so I assume this is a gnome 40 problem.

Edit: Don’t know why but the site doesn’t let me format the output o inxi -Fazy and monitor-sensor correctly… I tried with the “preformatted-text” option but nothing changes
Edit 2: thank you @Wollie, it never happened before :joy:

I’m with you on this issue.

I performed a fresh install, and noticed iio-sensor-proxy wasn’t installed by default.

After a couple tries, I could install mutter-git and gnome-shell-git. I had to uninstall all extensions and manjaro-gdm packets that depended on the ones I wanted to replace.

You’ll reboot into a tty, so you’ll need to install gdm-git to get back to graphical mode.

Sadly, this didn’t seem to solve the problem with autorotation for me.

I’ve given up and switched to Solus Gnome, which seems to be working fine out of the box, even after the latest updates.

1 Like

Hi @OctopusOnFire, thanks for the info!
How’s solus gnome on system resources consumption?
As you can see from the inxi -Fazy the tablet that I use is pretty old and not very powerful…
I mainly use it for light web browsing and reading documents on the go but I would still prefer a decent experience XD

I’m testing it. My 2-in-1 is also quite limited in resources (Intel Atom and 2GB RAM)

I’ve been playing around with Solus since I wrote the comment and the experience is a little underwhelming. It runs on X11 instead of Wayland. It’s not a resource hog, but I’m experiencing some issues that kinda break the touchscreen experience.

The most notable is the on-screen keyboard. If there’s any window behind it, it won’t register the keypress, but whaterver it is in the window, which is a big no-no. Other than that, the system feels sluggish, there’s window tear when scrolling, and the lack of apps in the software manager (and no AUR) kind of breaks the deal for me.

Apparently, you can’t beat Manjaro when it comes to performance and user experience :man_shrugging:t2:

The problem is that anything other than Gnome has proven dreadful for tablet-like devices. I’ll keep looking for an alternative, let me know how it goes for you.

One more thing. Solus behaves really, really weird with the Gnome DE. Like, you’ll change some settings and nothing will happen. Basic things like theming or showing the battery %
It seems a bit half-baked, tbh. Probably they just focus on Budgie.

Anyway, I’ve been distro-hopping for a while and it surely seems this problem is because of Gnome 40. Fedora doesn’t work as well.

So far, the best alternative I’ve found is Pop OS (it uses Gnome 3.38 for its custom Cosmos DE). Autorotation and on-screen keyboard work properly. There’s enough software in their repos and flatpak for light browsing and reading comics, epub, pdf, etc. It’s based on Ubuntu so Brave and other stuff can be also easily installed.

The performance is okay. It’s not the lightest distro out there, but if it works in my Intel Atom, it will work in your i3. Cheers!

Sorry for bringing up this post again, but hasn’t anyone found any workaround for this issue? The solution posted in Reddit is impossible to implement for me because dependencies keep coming up, and uninstalling them prevents me from following the instructions. What am I doing wrong? Is screen rotation forever screwed up for Gnome 40 users from now on?

Hi, sorry for the late reply but I was on vacation!

I still haven’t found a solution and didn’t have any time to trying other distros on my tablet :frowning:
I’m hoping the issue will solve itself with the next updates even though it really bothers me: I used to use that tablet for reading e-books and, you know, it’s way more comfortable in its vertical orientation XD

I have faith though, 'till 4 months ago I couldn’t update the kernel to 5.10 on the very same tablet because it would break wifi and bluetooth but someone solved the issue along the development line and I think it’ll be the same for rotation on gnome 40!

From what I read it seems that it was a conscious decision in order to solve other issues, so I wouldn’t expect a solution anytime soon.

But if you want to save time, just go with Pop OS. I’ve tried every distro under the sun that uses a custom version of Gnome pre-4.0, and that’s the best one managing resources, by a long shot. You can even uninstall the Pop Shop for extra performance without missing much.

I’d rather use Manjaro, but it is what it is. I don’t need the AUR in my tablet, anyway :grinning_face_with_smiling_eyes:


Same problem here. Is there still no solution or is a new problem on my side.

Thanks for the work and the help.

Unfortunately I don’t think the problem has been solved yet… every update I hope and pray but nothing :joy:

Same problem here, i’m a user of surface go 2 and use it to read or write with pen ! Hope will be resolve at next update :slight_smile:

Is there something we can do to help solving the problem?

I installed iio-sensor-proxy-git 3.3.r4.b688114 and gnome extension
GitHub - kosmospredanie/gnome-shell-extension-screen-autorotate: Enable screen rotation regardless of touch mode,
and screen rotation finally works on Lenovo ThinkPad S1 Yoga 12.

1 Like

Thanks a lot! This works for me, too (but had to reboot before).
I used version 2 form the gnome extension (don’t know the difference to version 1).

I am not sure if I understand you correctly. Did you use iio-sensor-proxy-git oder iio-sensor-proxy? For me it only works with the git version.
My device is a surface go 2, the keyboard is therefore detachable keyboard.

My apologies, I was totally wrong :rofl:
I did try iio-sensors-proxy git when the problem first appeared but it didn’t solve the issue so I thought it wouldn’t work this time either…
I reinstalled it now and it’s working fine finally!

I’m gonna remove the previous post 'cause it doesn’t contain useful informations anyway

Now that Gnome41 has been implemented, can anyone confirm if the auto-rotation problem has been fixed?


I can confirm autorotation is been working fine for a couple of months now, I’m using gnome-waylad and kernel 5.13!

1 Like

mine isnt working, do you know where Ishould looking for to track the probem
my tablet rotation working well with ubuntu and pop os

Since I use iio-sensor-proxy-git instead of iio-sensor-proxy auto-rotation works fine for me.