Screen crashes and freezes completely if laptop is not plugged into charging

I am new to manjaro. it was working fine untill I updated, after the restart, my screen kept crashing everytime. so I added a tear free option. it got stable but not while unplugged. so now I have to keep my laptop plugged in all the time. If I remove the charger, in five seconds it tears like snow screen and freezes.

  Kernel: 5.10.53-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=77a88e0c-ee2b-46ab-800b-e180009618f8 rw apparmor=1 
  security=apparmor resume=UUID=b0967772-1a60-45ab-b4ae-3873411514a4 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: LENOVO product: 80XH v: Lenovo ideapad 320-15ISK 
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 320-15ISK 
  serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: NO DPK serial: <filter> UEFI: LENOVO 
  v: 4WCN40WW date: 04/13/2018 
  ID-1: BAT0 charge: 22.2 Wh (96.9%) condition: 22.9/30.0 Wh (76.4%) 
  volts: 8.4 min: 7.5 model: SMP L16M2PB1 type: Li-poly serial: <filter> 
  status: Unknown 
  RAM: total: 3.63 GiB used: 1.47 GiB (40.5%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP 
  arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: EA cache: 
  L2: 3 MiB bogomips: 16006 
  Speed: 500 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 500 2: 501 3: 478 
  4: 500 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts erms est f16c flush_l1d fma 
  fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs 
  intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor 
  movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm 
  pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp 
  rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp 
  syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave 
  xsavec xsaveopt xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel HD Graphics 520 vendor: Lenovo driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:1921 class-ID: 0300 
  Device-2: Chicony EasyCamera type: USB driver: uvcvideo bus-ID: 1-8:3 
  chip-ID: 04f2:b5d8 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: 
  loaded: intel display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 21.1.5 
  direct render: Yes 
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3 
  chip-ID: 8086:9d70 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.53-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.32 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 4000 bus-ID: 01:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: 3000 bus-ID: 02:00.0 
  chip-ID: 10ec:8821 class-ID: 0280 
  IF: wlp2s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
  Device-1: Realtek RTL8821A Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-7:2 chip-ID: 0bda:0821 class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Message: No logical block device data found. 
  Message: No RAID data found. 
  Local Storage: total: 931.51 GiB used: 20.85 GiB (2.2%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD10SPZX-24Z10T0 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: HDD rpm: 5400 serial: <filter> rev: 1A01 scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 9.97 GiB (10.2%) 
  fs: ext4 dev: /dev/sda3 maj-min: 8:3 label: N/A 
  uuid: 77a88e0c-ee2b-46ab-800b-e180009618f8 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL 
  uuid: BA59-C448 
  ID-3: /home raw-size: 100 GiB size: 97.87 GiB (97.87%) 
  used: 10.88 GiB (11.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A 
  uuid: 095a6c16-5eab-4be3-acc9-0d4ced39a669 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda6 maj-min: 8:6 label: N/A 
  uuid: b0967772-1a60-45ab-b4ae-3873411514a4 
  ID-1: /dev/sda4 maj-min: 8:4 size: 150 GiB fs: ext4 label: N/A 
  uuid: 1cd2d372-465e-455c-b8a6-f05bcf77110d 
  ID-2: /dev/sda5 maj-min: 8:5 size: 570 GiB fs: ext4 label: N/A 
  uuid: 28d61185-8f54-4a3d-abb4-36bdbbb4c80b 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 12 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-7:2 info: Realtek RTL8821A Bluetooth type: Bluetooth 
  driver: btusb interfaces: 2 rev: 2.1 speed: 12 Mb/s power: 500mA 
  chip-ID: 0bda:0821 class-ID: e001 serial: <filter> 
  Device-2: 1-8:3 info: Chicony EasyCamera type: Video driver: uvcvideo 
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b5d8 
  class-ID: 0e02 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 6 rev: 3.0 speed: 5 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 36.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 177 Uptime: 5m wakeups: 9551 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: N/A Packages: pacman: 1191 lib: 326 flatpak: 0 Shell: Bash 
  v: 5.1.8 running-in: konsole inxi: 3.3.06```

That sounds like a hardware problem to me. Your battery is probably dying, and the display subsystem is one of the biggest consumers of electricity. Obviously your battery cannot provide the juice anymore to power your GPU.


1 Like

@Aragorn NO, Battery is in great condition. windows work perfectly fine. before the update, manjaro was also working fine. Also screen tears and freezes,

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and press the three dots below your original post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you want to notify me that you did provide this information, please :heart: this message and I’ll come back and have another look.
P.P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

1 Like

Hello, I have edited the post and added the information from the konsole. Also here is a photo of my screen when it is unplugged.

Battery is fine @Aragorn (76%, 8.4v delivered when 7.5 is minimum) so @pradyuman it must have to do with energy savings: did you add any third-party tools to increase battery savings?

If yes: tweak those settings to exclude your graphics subsystem!

If not, use the standard tools to remove energy savings:


grep "TLP_ENABLE" /etc/tlp.conf

If you get:


Execute the following to turn off battery savings altogether:

sudo sed 's/TLP_ENABLE=1/TLP_ENABLE=0/' /etc/tlp.conf

reboot and try again.

If that solves your problem and you don’t want to tweak individual settings you’re done!

If you still want battery savings, edit /etc/tlp.conf with your favourite editor and tweak your settings manually.

For more information:

man tlp


1 Like

I did execute both the commands and rebooted, but still it’s the same. It loads up-to login screen then glitches for few times and freezes as in earlier photo.
note: this problem starts only after I update. fresh installation of KDE worked perfectly fine.


  2. Switch to Ctrl+Alt+F2

  3. log in there

  4. execute:

    journalctl --system --boot=0 --priority=3 | tail --lines=50 > /tmp/myjournal.txt
  5. Copy /tmp/myjournal.txt to a USB sick

  6. post it here in-between 3 ```


I tried tty2 login but it shows invalid login. does this need a different login? while installing I had only one username and two passwords and I remember them both. now it says your account is locked and you have only 6 min to unlock it. I panicked, forced shutdown and restarted it again and login normally. what happened ? Have I done something irreversible ? please walk me through.

I have tried the following to make sure that I am using the correct credentials.

[sudo] password for pradyuman: 
New password: 
Retype new password: 
passwd: password updated successfully
[pradyuman@pradyuman-PC ~]$ sudo passwd Pradyumann
passwd: user 'Pradyumann' does not exist
[pradyuman@pradyuman-PC ~]$ sudo passwd Pradyuman
passwd: user 'Pradyuman' does not exist```

Looking at your technical knowledge and the state your system is in, it’s going to be easier for you to read this:


  • Boot a new Manjaro .iso from USB
  • backup your data
  • reinstall
  • be more conservative as to what you do with the new install until you learn more

Nope, I’ve been in the same situation as you: I messed too much with themes and abandoned software and installed from source and … and then couldn’t figure out what I did any more.


reinstall? have I messed up in tty2 login? right now system is working as before. that is in constant charge. even if I reinstall, cumulative update will still mess it up. what’s in the update that my system isn’t cooperating? Also, I am stuck with the current system because my boot-able USB’s are fried dead. have to buy a new one.

Huh??? So none of the weird screen tearing any more? Everything back to normal???


NO, the problem still is the same. I have to keep it plugged into charging all the time. if I remove the charger, it will start flickering and in few second it will freeze as in the photo I shared earlier.

Could you boot a Manjaro ISO and see if it happens there too?

manjaro ISO as in from the USB right? that worked perfectly fine, with or without charging. fresh installation also worked great. it is the first update that messes up my screen.

I want to try this option, but I don’t know exactly how,
screen flickering

panel self refresh (PSR), a power saving feature used by Intel iGPUs is known to cause flickering in some instances FS#49628 FS#50605. A temporary solution is to disable this feature using the kernel parameter i915.enable_psr=0

If I would be you, I would:

And then:

  • If it works: restore data backup
  • If it doesn’t, report back

I have reinstalled manjaro, even the fresh installation (without updating) cannot sustain being unplugged. I have been at it for a month now and still no solution.

By now, I have to agree with @Aragorn that you have a hardware problem: have your machine serviced by a qualified service person…


1 Like

AAhh mannn, I recently switched from windows like just a month ago cause I got a ransomeware attack on it. so I switched to manjaro. anyway I am installing kubuntu now, I’ll update how that goes. thank you for all the help and time.

This is an update about the screen problem I was facing in manjaro. I have been using kubuntu for about 2 weeks now, there has been no problem in using the laptop while plugged or unplugged. however I have seen similar problem while shutting down. it happens at random. I have experienced it 3 times now. otherwise it works great.

Hope this feedback be of help. thank you.