Screen Capture Flickering and Not Recording Opened Windows

I hope somebody can help me. Im on Manjaro Gnome and unable to do screen capture properly, recorded video is flickering and only the desktop, mouse and screen capture app is recorded. Newly opened windows does not appear. Tried OBS Studio, vocoscreenNG and simplescreenrecorder with same result.

Sorry cant post link here, if there a work around please let me know.

Thanks in advance.

1 Like


You should be able to provide this kind of information, so we know what we deal with

oh im so sorry. will do this. thanks

so here is my setup, its an old acer laptop my kid is using for online schooling now. yes im training my kid to use linux :slight_smile:

~ >>> inxi -Fazy                                                               
  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=cc40fd53-7686-4a3c-a908-8beb3fcaa690 rw quiet udev.log_priority=3 
  Desktop: GNOME 3.36.6 tk: GTK 3.24.23 info: plank wm: gnome-shell 
  dm: GDM 3.36.3 Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire R3-131T v: V1.17 serial: <filter> 
  Mobo: Acer model: Aspire R3-131T v: V1.17 serial: <filter> UEFI: Insyde 
  v: 1.17 date: 11/30/2016 
  ID-1: BAT0 charge: 11.2 Wh condition: 11.2/51.1 Wh (22%) volts: 17.3/15.4 
  model: SANYO AC14B3K type: Li-ion serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331 
  serial: <filter> charge: 5% (should be ignored) rechargeable: yes 
  status: Discharging 
  Topology: Quad Core model: Intel Pentium N3700 bits: 64 type: MCP 
  arch: Airmont family: 6 model-id: 4C (76) stepping: 3 microcode: 368 
  L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 12805 
  Speed: 480 MHz min/max: 480/2400 MHz Core speeds (MHz): 1: 1859 2: 1570 
  3: 480 4: 480 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:22b1 
  Device-2: Sunplus Innovation HD WebCam type: USB driver: uvcvideo 
  bus ID: 1-3:3 chip ID: 1bcf:2c81 
  Display: x11 server: 1.20.8 compositor: gnome-shell driver: intel 
  unloaded: modesetting alternate: fbdev,vesa resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 405 (BSW) v: 4.6 Mesa 20.1.7 
  compat-v: 3.0 direct render: Yes 
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 chip ID: 8086:2284 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 1000 
  bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Intel Wireless 3165 driver: iwlwifi v: kernel port: 1000 
  bus ID: 02:00.0 chip ID: 8086:3165 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 465.76 GiB used: 15.37 GiB (3.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: SDM1 scheme: GPT 
  ID-1: / raw size: 92.63 GiB size: 90.68 GiB (97.89%) used: 15.16 GiB (16.7%) 
  fs: ext4 dev: /dev/sda6 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 3.00 GiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 54.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 240 Uptime: 5m Memory: 3.68 GiB used: 1.01 GiB (27.3%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1131 lib: 367 
  Shell: Zsh v: 5.8 running in: gnome-terminal inxi: 3.1.05 

and here is a drive link to an actual screen capture using obs studio:

Im new on manjaro my english not very good , sorry for that
I think i know what you mean , i have same problem and follow this steps to solve

Disable Xorg graphic configurations in /etc/X11/xorg.conf.d/
by rename with .bak in last
like “90-mhwd.conf” to “90-mhwd.conf.bak”
let every think else without rename like “keybord.conf” “touchpad.cong”
don’t worry if you didn’t see any graphic config just don’t do any thing

disable Xorg graphic configurations in /etc/X11/
like above if you see anything graphic just rename it with .bak “mhwd.conf” “intel.conf nvidia.conf” etc

at last go to sitting->display and monitor->compositor
and change the Rendering backend to xRender

just sure the “enable compositor on startup”


that worked for me in kde but i think work anothrs , i hope work for you