Screen brightness control Dell Optiplex 7780

Hi all. I have a Dell Optiplex 7780 (an AIO computer) with integrated Intel graphics card. So far, I am unable to change its brightness, it is always stuck at 100%.

I tried the solution here as well as the ddcci and i2c-dev kernel modules (+ several utilities to interact with them: ddcutil, backlit_control, brightnessctl, light) as partially explained in

I am using Manjaro GNOME with Wayland and Kernel 5.4. I have tried with X11 and with Kernels 5.8, 5.9 and 5.10 and still the same issue.

Do you have any idea? I know that similar AIO computers need some sort of OSD (On-Screen Display) software, but I tried to find something for my particular one, and found nothing.

This is my output for the relevant info (in my opinion) of the inxi -Faz command:

System:    Kernel: 5.4.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=db5cc74f-3469-4916-ab75-4023b69efe8b rw quiet splash 
           apparmor=1 security=apparmor resume=UUID=38f1480a-218d-419f-8e78-2e2c7500369e udev.log_priority=3 
           Desktop: GNOME 3.38.3 tk: GTK 3.24.24 wm: gnome-shell dm: GDM Distro: Manjaro Linux 
Machine:   Type: Desktop System: Dell product: OptiPlex 7780 AIO v: N/A serial: <filter> Chassis: type: 13 serial: <filter> 
           Mobo: Dell model: 04G47W v: A00 serial: <filter> UEFI: Dell v: 1.3.0 date: 10/06/2020 
Graphics:  Device-1: Intel vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:9bc5 
           Device-2: Sunplus Innovation Integrated_Webcam_FHD type: USB driver: uvcvideo bus ID: 1-10:3 chip ID: 1bcf:2b9b 
           Display: wayland server: 1.20.10 compositor: gnome-shell driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display ID: 0 resolution: <missing: xdpyinfo> 
           OpenGL: renderer: Mesa Intel UHD Graphics 630 (CML GT2) v: 4.6 Mesa 20.3.2 direct render: Yes 

Of course I will provide the output of any command at your request. Thanks a lot. Appreciated,

Update: With the ddcci module loaded, ddcutil detect returns No displays found, but with the i2c-dev module loaded via
sudo modprobe i2c-dev,
the command ddcutil detect returns

Invalid display
   I2C bus:             /dev/i2c-1
   EDID synopsis:
      Mfg id:           DEL
      Model:            OptiPlex 7780
      Serial number:    
      Manufacture year: 2017
      EDID version:     1.3
   DDC communication failed

but the command sudo ddcutil capabilities still gives Display not found. Any ideas?