Scarlett 8i6 input not showing in settings

Hi there,

I’ve been searching the internet for days now trying to find out how to get my Scarlett 8i6 interface input to be recognized in my gnome settings.
This is a fresh install of Manjaro after a few months using Pop_OS and for some reason it’s not recognizing my audio input anymore (was working before).
I’ve installed the scarlett-mixer gui, jack2 and pulse audio volume control which don’t work and touching any config files without guidance is not an option at the moment since I’m not too familiar with that when it comes to system files.
Could someone help or point me in the right direction please.

Thanks in advance.


Just passed by to tell you never ever post in arch linux forum about issues on your Manjaro install.

Probably you installed this AUR (en) - scarlett-mixer-git see there is a comment there

Other than that, fill an issue report to them and ask for more assistance on Issues · x42/scarlett-mixer · GitHub


Hi there,

I’ve tried scarlett-mixer no luck.

Scarlett 8i6 (3rd gen) interface is supported in kernel v5.14 and support has also been back-ported to LTS kernel v5.10, but the interface has to be enabled at boot time

There has been an ongoing discussion about support for 2nd gen and 3rd gen devices in another forum
Focusrite Scarlett 2nd and 3rd Gen mixer driver - LinuxMusicians
Users with these devices should follow this discussion as there might be an ALSA mixer and patchbay GUI released in the near future

To enable the driver when system is booted and audio module loaded requires a modprobe option device_setup=1 with the correct Vendor and product ID code to identify the device

Use this command to create the modprobe file:

echo `options snd_usb_audio vid=0x1235 pid=0x8213 device_setup=1` | sudo tee --append /etc/modprobe.d/scarlett8i6.conf

Release Linux 5.14.0 · geoffreybennett/scarlett-gen2 · GitHub

Reboot system to ensure the modprobe option is loaded

The modprobe option should allow ALSA to detect all the interface channels in ALSA
All the channels should be accessible (and patchable) in JACK
However, PulseAudio will probably need a custom profile to access more than one channel


Hi nikgnomic,

Sorry for the late response I was moving.
I have a Scarlette 8i6 3rd generation.

OS: Manjaro Linux x86_64
██████████████████ ████████ Host: Z170X-Gaming 7
████████ ████████ Kernel: 5.14.10-1-MANJARO
████████ ████████ ████████ Uptime: 43 mins
████████ ████████ ████████ Packages: 1302 (pacman), 5 (flatpak)
████████ ████████ ████████ Shell: zsh 5.8
████████ ████████ ████████ Resolution: 2560x1440
████████ ████████ ████████ DE: GNOME 40.5
████████ ████████ ████████ WM: Mutter
████████ ████████ ████████ WM Theme: Adwaita-maia-compact-dark
████████ ████████ ████████ Theme: Adwaita-maia-compact-dark [GTK2/3]
████████ ████████ ████████ Icons: Papirus-Dark-Maia [GTK2/3]
Terminal: gnome-terminal
CPU: Intel i7-6700K (8) @ 4.400GHz
GPU: NVIDIA GeForce GTX 980 Ti
Memory: 1765MiB / 15961MiB

This is the output I got using your command.

echo ‘options snd_usb_audio vid=0x1235 pid=0x8213 device_setup=1’ | sudo tee --append /
[sudo] password for ghost:
tee: /: Is a directory
options snd_usb_audio vid=0x1235 pid=0x8213 device_setup=1

1 Like

I omitted the correct file location from the command in previous post
command has now been edited from sudo tee --append /
to sudo tee --append /etc/modprobe.d/scarlett8i6.conf

1 Like

Hi nikgnomic,

Your command worked but I still don’t see the scarlette as input device in my settings.
Only Built-in Line input.
I’ve followed the arch forum link you sent and went into alsamixer and made sure all my inputs are enabled.
Any other commands I could run to troubleshoot?

Check the audio devices available in PulseAudio

pactl list cards

Data for the USB device should show available Profiles

  • Analog Stereo Input
  • Analog Stereo Output
  • Analog Stereo Duplex (input & output)

PulseAudio should work with any Profile shown as available=yes or available=unknown, but it would avoid using any Profile shown as - available=no

If no input or output devices are visible in Gnome audio settings, the Active Profile is probably set to Off. Changing the PulseAudio Profile should allow the USB device to support audio playback/capture for one pair of stereo channels in PulseAudio

Hi there,

I looks to me the profile is enabled, but you’ll be able to judge much better than me :slight_smile:
Output below.

Card #4
Name: alsa_card.usb-Focusrite_Scarlett_8i6_USB_F8MYPQ80881B3B-00
Driver: module-alsa-card.c
Owner Module: 37
alsa.card = “5”
alsa.card_name = “Scarlett 8i6 USB”
alsa.long_card_name = “Focusrite Scarlett 8i6 USB at usb-0000:00:14.0-, high speed”
alsa.driver_name = “snd_usb_audio”
device.bus_path = “pci-0000:00:14.0-usb-0:”
sysfs.path = “/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.4/1-5.4.4/1-” = “usb-Focusrite_Scarlett_8i6_USB_F8MYPQ80881B3B-00”
device.bus = “usb” = “1235” = “Focusrite-Novation” = “8213” = “Scarlett 8i6 USB”
device.serial = “Focusrite_Scarlett_8i6_USB_F8MYPQ80881B3B”
device.string = “5”
device.description = “Scarlett 8i6 USB”
module-udev-detect.discovered = “1”
device.icon_name = “audio-card-usb”
input:multichannel-input: Multichannel Input (sinks: 0, sources: 1, priority: 1, available: yes)
output:analog-surround-21: Analog Surround 2.1 Output (sinks: 1, sources: 0, priority: 1300, available: yes)
output:analog-surround-21+input:multichannel-input: Analog Surround 2.1 Output + Multichannel Input (sinks: 1, sources: 1, priority: 1301, available: yes)
output:analog-surround-41: Analog Surround 4.1 Output (sinks: 1, sources: 0, priority: 1300, available: yes)
output:analog-surround-41+input:multichannel-input: Analog Surround 4.1 Output + Multichannel Input (sinks: 1, sources: 1, priority: 1301, available: yes)
output:analog-surround-50: Analog Surround 5.0 Output (sinks: 1, sources: 0, priority: 1200, available: yes)
output:analog-surround-50+input:multichannel-input: Analog Surround 5.0 Output + Multichannel Input (sinks: 1, sources: 1, priority: 1201, available: yes)
output:analog-surround-51: Analog Surround 5.1 Output (sinks: 1, sources: 0, priority: 1300, available: yes)
output:analog-surround-51+input:multichannel-input: Analog Surround 5.1 Output + Multichannel Input (sinks: 1, sources: 1, priority: 1301, available: yes)
off: Off (sinks: 0, sources: 0, priority: 0, available: yes)
Active Profile: output:analog-surround-21+input:multichannel-input
analog-output: Analog Output (type: Analog, priority: 9900, latency offset: 0 usec, availability unknown)
Part of profile(s): output:analog-surround-21, output:analog-surround-21+input:multichannel-input, output:analog-surround-41, output:analog-surround-41+input:multichannel-input, output:analog-surround-50, output:analog-surround-50+input:multichannel-input, output:analog-surround-51, output:analog-surround-51+input:multichannel-input

Btw I got no sound what so ever.
It’s working fine on my Mac though

The Github information in previous post suggests:

Run alsamixer -cUSB and you should see lots of controls.
Use F3, F4, arrows keys, space bar, and “M” to display the controls, move around, and change values.
To understand what the controls do, you will need to study the ASCII-art diagram at the top of the mixer_scarlett_gen2.c source code and the mixer driver feature list. You’ll probably also need to study the Focusrite manual for your interface as well. Good luck!

Scarlett 8i6 3rd Gen User Guide V2.pdf |

Any issues, please come say hi at the Computer Related Hardware forum at LinuxMusicians: Computer Related Hardware - LinuxMusicians or email me.

But if you need to post information online to get help, posting screenshots of alsamixer controls would not be very informative

I would suggest using a different command to show the information about audio controls in text format

amixer --card=USB