Samsung C27JG5X on 5700XT missing resolution in multi display environment

Hey guys I just installed Manjaro and noticed that my screens resolution is wrong.

The monitor supports 2560x1440 at 144hz but the resolution does not appear in the Display configurator.
The highest resolution it gives me is 1280x800 at 60hz.
I’ve tried manually adding the resolution using cvt and xrandr as described elsewhere, but I get the error message “xrandr: Configure crtc 0 failed”
inxi -Fza:

  Kernel: 5.7.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=e52355c3-fc9e-41d7-8217-c68f6fd78024 rw quiet apparmor=1 
  security=apparmor resume=UUID=c6246d6e-04a0-4a53-bf7f-3896b4b208da 
  Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-F GAMING v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 1405 date: 11/19/2019 
  ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 3.8/N/A 
  model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A 
  serial: <filter> status: Discharging 
  Topology: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP 
  arch: Zen 2 family: 17 (23) model-id: 71 (113) stepping: N/A 
  microcode: 8701013 L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 115024 
  Speed: 2190 MHz min/max: 2200/3600 MHz boost: enabled 
  Core speeds (MHz): 1: 2197 2: 2193 3: 2187 4: 2191 5: 2195 6: 2192 
  7: 2191 8: 2189 9: 2196 10: 2196 11: 2197 12: 2192 13: 2197 14: 2194 
  15: 2196 16: 2193 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 0b:00.0 
  chip ID: 1002:731f 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: amdgpu 
  FAILED: ati unloaded: modesetting,radeon alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 3520x1080 s-dpi: 96 s-size: 928x285mm (36.5x11.2") 
  s-diag: 971mm (38.2") 
  Monitor-1: DisplayPort-0 res: 1600x900 hz: 60 dpi: 68 
  size: 597x336mm (23.5x13.2") diag: 685mm (27") 
  Monitor-2: HDMI-A-0 res: 1920x1080 hz: 60 dpi: 93 
  size: 522x294mm (20.6x11.6") diag: 599mm (23.6") 
  OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.37.0 
  5.7.14-1-MANJARO LLVM 10.0.1) 
  v: 4.6 Mesa 20.1.5 direct render: Yes 
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0b:00.1 chip ID: 1002:ab38 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0d:00.4 chip ID: 1022:1487 
  Device-3: Kingston HyperX 7.1 Audio type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-3:3 
  chip ID: 0951:16a4 serial: <filter> 
  Sound Server: ALSA v: k5.7.14-1-MANJARO 
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb 
  v: 5.6.0-k port: f000 bus ID: 05:00.0 chip ID: 8086:1539 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.70 TiB used: 1.27 TiB (47.1%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Corsair model: Force MP510 size: 894.25 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: ECFM22.6 scheme: GPT 
  ID-2: /dev/nvme1n1 vendor: Corsair model: Force MP510 size: 894.25 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: ECFM12.2 scheme: GPT 
  ID-3: /dev/sda vendor: Seagate model: ST2000DM001-1ER164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC25 scheme: MBR 
  ID-4: /dev/sdb type: USB vendor: Kingston model: DataTraveler 3.0 
  size: 7.23 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: PMAP scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: 859.48 GiB size: 844.99 GiB (98.31%) 
  used: 8.38 GiB (1.0%) fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 34.48 GiB used: 0 KiB (0.0%) 
  priority: -2 dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 58.9 C mobo: N/A gpu: amdgpu temp: 46 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
  Processes: 314 Uptime: 11m Memory: 31.34 GiB used: 2.12 GiB (6.8%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: pacman: 1186 
  lib: 318 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.05 

Hello and welcome,

There was prepared a nice how to provide good information, so we can know how we an help based on some important information.

Edit you OP and add that information accordingly.

Hi, you solved this?

I am on exactly same situation here with my LG Ultrawide Monitor 25 in N53ta ASUS Laptop (ATI Radeon® HD 6720G2).

The maximum resolution that is shown is 1920 x 1080, but I was able to use it normally at 2560x1080 on Windows 10.

I tried to set a new mode in xrandr, I tried to change the kernel version in Manjaro XFCE and other ways by searching forums and Google. But nothing worked.

1 Like