[RX 6900XT] No sensor data

Hey guys,

got a little problem with my GPU sensors on my RX 6900XT. For whatever reason I cannot seem to get any data out of them. I tried to go for radeon-profile and CoreCtrl. CoreCtrl shows a [GPU 0] but every sensor shows 0 MHz / 0 W / 0 % except “Used memory”. radeon-profile doesn’t even get my GPU at all and crashes when I refresh in order to look for devices.

Now, as they both seem to have problems with my setup and someone over at Reddit posted that his GPU was picking up fine (didn’t get any answer from him yet), I wonder if either my software is at fault or even my whole graphics card.

I’ve seen this thread where someone had the same issues as I had, apparently, but he didn’t post a solution. It seemed to just “randomly work” suddenly.

Can anyone verify that hey have the same issues? I tried to go for kernel 5.10 (which at least showed me my mem clock @ 1000MHz), over 5.11 to the current version of 5.12 (test branch) which both resulted in no information on sensors.

I am pretty new to the whole AMD GPU stuff as I had a GTX 980 before that - so I might even miss some packages, which I don’t really know what it could be.

Here’s my inxi:

System:    Kernel: 5.12.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.12-x86_64 root=UUID=ccca6ae4-42b9-4201-91d9-3dbe6689b0a8 rw quiet 
           Desktop: KDE Plasma 5.21.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_wayland vt: 2 dm: SDDM Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: B550 AORUS ELITE V2 v: x.x serial: <filter> UEFI: American Megatrends LLC. 
           v: F13c date: 02/17/2021 
CPU:       Info: 8-Core model: AMD Ryzen 7 5800X bits: 64 type: MT MCP arch: Zen 3 family: 19 (25) model-id: 21 (33) 
           stepping: N/A microcode: A201009 cache: L2: 4 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 121423 
           Speed: 2277 MHz min/max: 2200/3800 MHz boost: enabled Core speeds (MHz): 1: 2277 2: 2217 3: 2291 4: 2368 5: 2213 
           6: 2285 7: 2221 8: 2218 9: 2221 10: 2414 11: 2304 12: 2417 13: 2218 14: 2216 15: 2207 16: 2207 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: always-on, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu v: kernel 
           bus-ID: 07:00.0 chip-ID: 1002:73bf class-ID: 0300 
           Display: wayland server: X.Org compositor: kwin_wayland driver: loaded: amdgpu,ati 
           unloaded: modesetting,radeon alternate: fbdev,vesa display-ID: :1 screens: 1 
           Screen-1: 0 s-res: 5120x1440 s-dpi: 96 s-size: 1355x381mm (53.3x15.0") s-diag: 1408mm (55.4") 
           Monitor-1: XWAYLAND0 res: 5120x1440 hz: 120 dpi: 109 size: 1190x340mm (46.9x13.4") diag: 1238mm (48.7") 
           OpenGL: renderer: AMD SIENNA_CICHLID (DRM 3.40.0 5.12.0-1-MANJARO LLVM 11.1.0) v: 4.6 Mesa 20.3.4 
           direct render: Yes 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel v: kernel bus-ID: 07:00.1 chip-ID: 1002:ab28 
           class-ID: 0403 
           Device-2: Yamaha MG-XU type: USB driver: snd-usb-audio bus-ID: 5-2.1:4 chip-ID: 0499:1703 class-ID: 0102 
           Device-3: Logitech HD Webcam B910 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 5-3.2.3:7 chip-ID: 046d:0823 
           class-ID: 0e02 serial: <filter> 
           Sound Server-1: ALSA v: k5.12.0-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: no 
           Sound Server-4: PipeWire v: 0.3.23 running: yes 
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: Gigabyte driver: r8169 v: kernel port: f000 bus-ID: 04:00.0 
           chip-ID: 10ec:8125 class-ID: 0200 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB driver: btusb v: 0.8 bus-ID: 5-3.2.2:6 
           chip-ID: 0a12:0001 class-ID: e001 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 3.43 TiB used: 1.15 TiB (33.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> rev: 2B2QEXE7 scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 512GB size: 476.94 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 4B6Q scheme: GPT 
           ID-3: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 840 PRO Series size: 238.47 GiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 5B0Q scheme: GPT 
           ID-4: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST32000641AS size: 1.82 TiB block-size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: CC13 scheme: MBR 
Partition: ID-1: / raw-size: 238.17 GiB size: 233.43 GiB (98.01%) used: 172.68 GiB (74.0%) fs: ext4 dev: /dev/sdb2 
           maj-min: 8:18 
           ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB (0.1%) fs: vfat dev: /dev/sdb1 
           maj-min: 8:17 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 44.9 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 357 Uptime: 26m wakeups: 0 Memory: 31.36 GiB used: 6.62 GiB (21.1%) Init: systemd v: 247 tool: systemctl 
           Compilers: gcc: 10.2.0 clang: 11.1.0 Packages: 1459 pacman: 1454 lib: 434 flatpak: 5 Shell: fish v: 3.1.2 
           running-in: konsole inxi: 3.3.03 

Thanks, guys. :slight_smile:

Output of sensors?

Adapter: PCI adapter
vddgfx:      793.00 mV 
ERROR: Can't get value of subfeature fan1_input: I/O error
fan1:             N/A  (min =    0 RPM, max = 3300 RPM)
edge:             N/A  (crit = +100.0°C, hyst = -273.1°C)
                       (emerg = +105.0°C)
junction:         N/A  (crit = +110.0°C, hyst = -273.1°C)
                       (emerg = +115.0°C)
mem:              N/A  (crit = +100.0°C, hyst = -273.1°C)
                       (emerg = +105.0°C)
power1:           N/A  (cap = 255.00 W)

Adapter: ACPI interface
temp1:        +16.8°C  (crit = +20.8°C)

Adapter: PCI adapter
Tctl:         +53.6°C  
Tdie:         +53.6°C  
Tccd1:        +42.5°C  

Adapter: PCI adapter
Composite:    +58.9°C  (low  = -273.1°C, high = +84.8°C)
                       (crit = +84.8°C)
Sensor 1:     +58.9°C  (low  = -273.1°C, high = +65261.8°C)
Sensor 2:     +60.9°C  (low  = -273.1°C, high = +65261.8°C)

That’s exactly the problem. The guy on Reddit also answered now but he doesn’t have that card anymore…

Seams to be there some kernel components missing which can communicate with the sensors of the GPU? :man_shrugging: (Not sure)

Which Kernel you use 5.11?

Used 5.10 to 5.12. 5.10 reported mem clocks, the other ones didn’t show anything.

  1. Output of lsmod.

  2. Have you run sudo sensors-detect?


foregone@foregone-pc ~> lsmod
Module                  Size  Used by
udp_diag               16384  0
tcp_diag               16384  0
inet_diag              24576  2 tcp_diag,udp_diag
snd_seq_dummy          16384  0
snd_hrtimer            16384  1
snd_seq                90112  7 snd_seq_dummy
rfcomm                 90112  16
uvcvideo              118784  0
videobuf2_vmalloc      20480  1 uvcvideo
videobuf2_memops       20480  1 videobuf2_vmalloc
videobuf2_v4l2         36864  1 uvcvideo
videobuf2_common       65536  4 videobuf2_vmalloc,videobuf2_v4l2,uvcvideo,videobuf2_memops
videodev              278528  3 videobuf2_v4l2,uvcvideo,videobuf2_common
cmac                   16384  3
algif_hash             16384  1
algif_skcipher         16384  1
af_alg                 32768  6 algif_hash,algif_skcipher
mousedev               24576  0
joydev                 28672  0
bnep                   28672  2
btusb                  69632  0
btrtl                  28672  1 btusb
btbcm                  20480  1 btusb
btintel                32768  1 btusb
bluetooth             765952  45 btrtl,btintel,btbcm,bnep,btusb,rfcomm
ecdh_generic           16384  2 bluetooth
ecc                    36864  1 ecdh_generic
rfkill                 28672  6 bluetooth
snd_usb_audio         331776  4
snd_usbmidi_lib        40960  1 snd_usb_audio
snd_rawmidi            45056  1 snd_usbmidi_lib
vfat                   24576  1
snd_seq_device         16384  2 snd_seq,snd_rawmidi
fat                    86016  1 vfat
mc                     65536  5 videodev,snd_usb_audio,videobuf2_v4l2,uvcvideo,videobuf2_common
r8169                  98304  0
realtek                32768  1
mdio_devres            16384  1 r8169
of_mdio                24576  1 mdio_devres
fixed_phy              16384  1 of_mdio
libphy                151552  5 r8169,mdio_devres,of_mdio,realtek,fixed_phy
usbhid                 65536  0
intel_rapl_msr         20480  0
intel_rapl_common      28672  1 intel_rapl_msr
edac_mce_amd           32768  0
snd_hda_codec_hdmi     73728  1
kvm_amd               131072  0
snd_hda_intel          57344  1
snd_intel_dspcfg       28672  1 snd_hda_intel
ccp                   118784  1 kvm_amd
snd_intel_sdw_acpi     20480  1 snd_intel_dspcfg
rng_core               16384  1 ccp
kvm                   999424  1 kvm_amd
snd_hda_codec         172032  2 snd_hda_codec_hdmi,snd_hda_intel
snd_hda_core          106496  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
irqbypass              16384  1 kvm
snd_hwdep              16384  2 snd_usb_audio,snd_hda_codec
crct10dif_pclmul       16384  1
crc32_pclmul           16384  0
ghash_clmulni_intel    16384  0
snd_pcm               147456  7 snd_hda_codec_hdmi,snd_hda_intel,snd_usb_audio,snd_hda_codec,snd_hda_core
aesni_intel           376832  4
snd_timer              45056  3 snd_seq,snd_hrtimer,snd_pcm
crypto_simd            16384  1 aesni_intel
wmi_bmof               16384  0
cryptd                 24576  3 crypto_simd,ghash_clmulni_intel
snd                   114688  21 snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_usb_audio,snd_usbmidi_lib,snd_hda_codec,snd_timer,snd_pcm,snd_rawmidi
rapl                   16384  0
soundcore              16384  1 snd
sp5100_tco             20480  0
pcspkr                 16384  0
i2c_piix4              28672  0
k10temp                16384  0
wmi                    36864  1 wmi_bmof
gpio_amdpt             20480  0
pinctrl_amd            32768  1
acpi_cpufreq           28672  0
mac_hid                16384  0
uinput                 20480  0
i2c_dev                24576  18
sg                     40960  0
crypto_user            20480  0
fuse                  159744  5
ip_tables              32768  0
x_tables               53248  1 ip_tables
ext4                  942080  4
crc32c_generic         16384  0
crc16                  16384  2 bluetooth,ext4
mbcache                16384  1 ext4
jbd2                  151552  1 ext4
crc32c_intel           24576  8
xhci_pci               20480  0
amdgpu               6815744  81
drm_ttm_helper         16384  1 amdgpu
ttm                    81920  2 amdgpu,drm_ttm_helper
gpu_sched              40960  1 amdgpu
i2c_algo_bit           16384  1 amdgpu
drm_kms_helper        290816  5 amdgpu
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper
cec                    73728  1 drm_kms_helper
drm                   585728  34 gpu_sched,drm_kms_helper,amdgpu,drm_ttm_helper,ttm
agpgart                45056  2 ttm,drm

Yes, I tried sudo sensors-detect. It also shows me adapter for “AMDGPU DM”, but it doesn’t solve anything. Here’s the output:

foregone@foregone-pc ~> sudo sensors-detect
[sudo] password for foregone: 
# sensors-detect version 3.6.0+git
# System: Gigabyte Technology Co., Ltd. B550 AORUS ELITE V2 [Default string]
# Kernel: 5.12.0-1-MANJARO x86_64
# Processor: AMD Ryzen 7 5800X 8-Core Processor (25/33/0)

This program will help you determine which kernel modules you need
to load to use lm_sensors most effectively. It is generally safe
and recommended to accept the default answers to all questions,
unless you know what you're doing.

Some south bridges, CPUs or memory controllers contain embedded sensors.
Do you want to scan for them? This is totally safe. (YES/no): y
Silicon Integrated Systems SIS5595...                       No
VIA VT82C686 Integrated Sensors...                          No
VIA VT8231 Integrated Sensors...                            No
AMD K8 thermal sensors...                                   No
AMD Family 10h thermal sensors...                           No
AMD Family 11h thermal sensors...                           No
AMD Family 12h and 14h thermal sensors...                   No
AMD Family 15h thermal sensors...                           No
AMD Family 16h thermal sensors...                           No
AMD Family 17h thermal sensors...                           Success!
    (driver `k10temp')
AMD Family 15h power sensors...                             No
AMD Family 16h power sensors...                             No
Hygon Family 18h thermal sensors...                         No
AMD Family 19h thermal sensors...                           No
Intel digital thermal sensor...                             No
Intel AMB FB-DIMM thermal sensor...                         No
Intel 5500/5520/X58 thermal sensor...                       No
VIA C7 thermal sensor...                                    No
VIA Nano thermal sensor...                                  No

Some Super I/O chips contain embedded sensors. We have to write to
standard I/O ports to probe them. This is usually safe.
Do you want to scan for Super I/O sensors? (YES/no): YES
Probing for Super-I/O at 0x2e/0x2f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      Yes
Found unknown chip with ID 0x8688
Probing for Super-I/O at 0x4e/0x4f
Trying family `National Semiconductor/ITE'...               No
Trying family `SMSC'...                                     No
Trying family `VIA/Winbond/Nuvoton/Fintek'...               No
Trying family `ITE'...                                      No

Some systems (mainly servers) implement IPMI, a set of common interfaces
through which system health data may be retrieved, amongst other things.
We first try to get the information from SMBIOS. If we don't find it
there, we have to read from arbitrary I/O ports to probe for such
interfaces. This is normally safe. Do you want to scan for IPMI
interfaces? (YES/no): YES
Probing for `IPMI BMC KCS' at 0xca0...                      No
Probing for `IPMI BMC SMIC' at 0xca8...                     No

Some hardware monitoring chips are accessible through the ISA I/O ports.
We have to write to arbitrary I/O ports to probe them. This is usually
safe though. Yes, you do have ISA I/O ports even if you do not have any
ISA slots! Do you want to scan the ISA I/O ports? (YES/no): YES
Probing for `National Semiconductor LM78' at 0x290...       No
Probing for `National Semiconductor LM79' at 0x290...       No
Probing for `Winbond W83781D' at 0x290...                   No
Probing for `Winbond W83782D' at 0x290...                   No

Lastly, we can probe the I2C/SMBus adapters for connected hardware
monitoring devices. This is the most risky part, and while it works
reasonably well on most systems, it has been reported to cause trouble
on some systems.
Do you want to probe the I2C/SMBus adapters now? (YES/no): YES
Using driver `i2c-piix4' for device 0000:00:14.0: AMD KERNCZ SMBus

Next adapter: AMDGPU SMU (i2c-0)
Do you want to scan it? (yes/NO/selectively): YES

Next adapter: AMDGPU DM i2c hw bus 0 (i2c-1)
Do you want to scan it? (yes/NO/selectively): YES

Next adapter: AMDGPU DM i2c hw bus 1 (i2c-2)
Do you want to scan it? (yes/NO/selectively): YES

Next adapter: AMDGPU DM i2c hw bus 2 (i2c-3)
Do you want to scan it? (yes/NO/selectively): YES

Next adapter: AMDGPU DM i2c hw bus 3 (i2c-4)
Do you want to scan it? (yes/NO/selectively): YES

Next adapter: AMDGPU DM aux hw bus 0 (i2c-5)
Do you want to scan it? (yes/NO/selectively): YES

Next adapter: AMDGPU DM aux hw bus 1 (i2c-6)
Do you want to scan it? (yes/NO/selectively): yes

Next adapter: AMDGPU DM aux hw bus 2 (i2c-7)
Do you want to scan it? (yes/NO/selectively): yes

Now follows a summary of the probes I have just done.
Just press ENTER to continue: 

Driver `k10temp' (autoloaded):
  * Chip `AMD Family 17h thermal sensors' (confidence: 9)

No modules to load, skipping modules configuration.

I reinstalled Manjaro completely now. Works… I have no clue why.

Thanks for the replies, people!

Interesting. And the sensor data is gone again. I haven’t fiddled around with ANYTHING. I only installed a couple of packages which haven’t got anything to do with it.

When opening up CoreCtrl now it gives me the following warnings:

[26-03-21 22:16:37.017][W] Empty sysfs entry /sys/class/drm/renderD128/device/pp_dpm_sclk
[26-03-21 22:16:37.017][W] Empty sysfs entry /sys/class/drm/renderD128/device/pp_power_profile_mode
[26-03-21 22:16:37.017][W] Empty sysfs entry /sys/class/drm/renderD128/device/hwmon/hwmon3/pwm1
[26-03-21 22:16:37.018][W] Empty sysfs entry /sys/class/drm/renderD128/device/hwmon/hwmon3/pwm1
[26-03-21 22:16:37.018][W] Empty sysfs entry /sys/class/drm/renderD128/device/hwmon/hwmon3/temp1_input
[26-03-21 22:16:37.018][W] Empty sysfs entry /sys/class/drm/renderD128/device/hwmon/hwmon3/fan1_input

These do belong to my graphics card. I also get another error which I had before I reinstalled Manjaro. This always happens when I am shutting down or restarting my PC. It would then (in the case of shutting down), restart instead and only shut down when pressing “Shut Down” from the login screen.

Mär 26 22:15:56 foregone-pc kernel: mce: [Hardware Error]: CPU 8: Machine Check: 0 Bank 5: bea0000000000108
Mär 26 22:15:56 foregone-pc kernel: mce: [Hardware Error]: TSC 0 ADDR ffffffc0bbc27e MISC d012000100000000 SYND 4d000000 IPID 500b000000000 
Mär 26 22:15:56 foregone-pc kernel: mce: [Hardware Error]: PROCESSOR 2:a20f10 TIME 1616793349 SOCKET 0 APIC 1 microcode a201009

Update: I installed Arch Linux directly and it works now.

For whatever reason Manjaro seemingly refused.

This one isn’t fixed, however I’ll be using Arch for now, as this issue doesn’t seem to happen there.

Thank you all for the replies! I’ll mark this as the “solution”.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.