/ running out of space

During installation, I allowed 32 GB for Manjaro system /; actuall less than 1 GB is left free and almost once an hour a warning shows up. I Tried to understand the issue and found, that /var/cache/pacman/pkg takes about 7.9 GB.

I tried to reduce paccache, but this was already done:

$ paccache --remove --keep 2 --verbose
==> no candidate packages found for pruning

How can I solve this?

You can do two things. :arrow_down:

  1. Completely clean out the package cache. :arrow_down:
sudo paccache -rvk0
  1. Split off some stuff from the root filesystem, as per this tutorial. :arrow_down:

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

  • What filesystems do you use ?
  • Do you have spare space on the hd ?
  • Do you have a backup ?
1 Like

Thank you @Aragorn, the second proposal seems too difficult for myself. For the first one I had in mind

$ paccache --dryrun --keep 1 --verbose
==> finished dry run: 1286 candidates (disk space saved: 3.17 GiB)

Would this be OK?
But I would really like to understand the reason. After instalation, I could keep three paccache-versions.Only few additional software has been installed since then. So: What is eating the disk space?


$ inxi --admin --verbosity=7 --filter --no-host --width
  Kernel: 5.15.85-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=3fb81935-3c2a-4b83-ae67-7b8f75e23839 rw text apparmor=1
    security=apparmor resume=UUID=338139c5-0361-42c0-9573-dbd00f711a01
    udev.log_priority=3 noplymouth acpi_backlight=none
  Desktop: KDE Plasma v: 5.26.4 tk: Qt v: 5.15.7 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 20UH001QGE v: ThinkPad T14s Gen 1
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20UH001QGE v: SDK0J40697 WIN
    serial: <superuser required> UEFI: LENOVO v: R1CET65W(1.34 ) date: 06/17/2021
  ID-1: BAT0 charge: 17.8 Wh (38.0%) condition: 46.8/57.0 Wh (82.1%)
    volts: 11.2 min: 11.5 model: SMP 5B10W139 type: Li-poly serial: <filter>
    status: discharging cycles: 918
  RAM: total: 30.59 GiB used: 4.13 GiB (13.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: AMD Ryzen 7 PRO 4750U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 level: v3 note: check built: 2020-22
    process: TSMC n7 (7nm) family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600106
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1582 high: 2431 min/max: 1400/1700 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1637 2: 1530
    3: 1538 4: 1610 5: 1347 6: 1301 7: 1340 8: 1366 9: 1561 10: 2209 11: 1329
    12: 1352 13: 1292 14: 1327 15: 2157 16: 2431 bogomips: 54319
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel arch: GCN-5.1
    code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1
    bus-ID: 06:00.0 chip-ID: 1002:1636 class-ID: 0300 temp: 34.0 C
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo
    bus-ID: 2-2:2 chip-ID: 13d3:5405 class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa dri: radeonsi
    gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: ChiMei InnoLux 0x14f2 built: 2018
    res: 1920x1080 hz: 60 dpi: 158 gamma: 1.2 size: 309x173mm (12.17x6.81")
    diag: 354mm (13.9") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon Graphics (renoir LLVM
    14.0.6 DRM 3.42 5.15.85-1-MANJARO) direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 06:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x
    pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 06:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound API: ALSA v: k5.15.85-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: 2400 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0f0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 6-4:3
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.82 TiB used: 1.14 TiB (62.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 31.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 32 GiB size: 31.2 GiB (97.50%) used: 28.85 GiB (92.5%)
    fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 label: Manjaro
    uuid: 3fb81935-3c2a-4b83-ae67-7b8f75e23839
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 17.5 MiB (3.4%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
    label: UEFI-ESP uuid: F8E8-132F
  ID-3: /home raw-size: 32 GiB size: 31.2 GiB (97.50%)
    used: 13.82 GiB (44.3%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
    label: home uuid: 36be0edf-49c4-4ee0-96a3-4da6bc64a86c
  ID-4: /home/<filter>/VirtualBoxVMs raw-size: 300 GiB
    size: 294.23 GiB (98.08%) used: 152.14 GiB (51.7%) fs: ext4
    dev: /dev/nvme0n1p5 maj-min: 259:5 label: Virtual
    uuid: c29b5da5-b959-4989-87ed-6db493b9c3a0
  ID-5: /mnt/Daten raw-size: 1.21 TiB size: 1.19 TiB (98.34%)
    used: 969.44 GiB (79.9%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7
    label: Daten uuid: 249b9b5a-332c-4176-8a2e-9cef91138ce6
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 64 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p2 maj-min: 259:2 label: Swap
    uuid: 338139c5-0361-42c0-9573-dbd00f711a01
  ID-1: /dev/nvme0n1p6 maj-min: 259:6 size: 200 GiB fs: ext4 label: TimeShift
    uuid: ee73659c-5cf3-46d2-a7c8-29db485d1b85
  Hub-1: 1-0:1 info: Full speed or root hub ports: 1 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 2-2:2 info: IMC Networks Integrated Camera type: Video
    driver: uvcvideo interfaces: 5 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 13d3:5405 class-ID: fe01 serial: <filter>
  Hub-3: 3-0:1 info: Super-speed hub ports: 2 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-4: 4-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 4-3:2 info: Alcor Micro AU9540 Smartcard Reader type: Smart Card
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 50mA
    chip-ID: 058f:9540 class-ID: 0b00
  Hub-5: 5-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-6: 6-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 6-3:5 info: Synaptics Prometheus MIS Touch Fingerprint Reader
    type: <vendor specific> driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 06cb:00bd class-ID: ff00 serial: <filter>
  Device-2: 6-4:3 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Hub-7: 7-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 35.0 C mobo: N/A gpu: amdgpu temp: 34.0 C
  Fan Speeds (RPM): fan-1: 0
  Processes: 356 Uptime: 22h 55m wakeups: 8 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1811 libs: 416 tools: pamac Shell: Bash v: 5.1.16
  running-in: konsole inxi: 3.3.24

Filesystem is ext4

I would suggest:

  • backup everything
  • remove swap
  • move/resize “/” (Manjaro ) to fill the gap
  • shrink one other partition by 64GB
  • recreate swap at the free place

or better:

  • backup everything
  • remove swap
  • move “/home” to the free space
  • resize “/” (Manjaro ) to fill the gap
  • shrink one other partition by 64GB
  • recreate swap at the free place

If you had used btrfs it would have been possible to:

  • backup everything
  • shrink one partition by 64GB
  • create an empty partition at the free space
  • join this new partition to the filesystem of “/”
  • enable compression on “/” subvolume

And analyse again, what you have installed :wink:

  • Is “baloo” indexing snapshots of Timeshift ?

and :100: :


I don’t really see why; it contains the literal instructions. :man_shrugging:

That is for you to decide upon. It says that it would free 3.17 GiB of space, but you know that /var/cache/pacman/pkg takes up 7.9 GiB of space.

  1. Packages grow as they evolve. Sometimes additional packages are being pushed out as well.

  2. If you have any Snap and/or FlatPak packages installed, those use up a lot of space because they come bundled with all of the shared libraries used inside their container.

Is there a way to add -d “dryrun” to this?

sudo paccache -dk0

-r removes the packages from the cache. -d shows you how much space would be freed if you remove the packages from the cache, without actually removing them. You cannot use -r and -d together.

Besides, you already know how much free space it will yield, because your /var/cache/pacman/pkg takes up 7.9 GiB of space.


The partitioning is not setup correctly.

64GB for swap? Why so much?

In ancient times there was a rule to have twice as much swap as RAM :wink:

Today: swap == RAM (if you want to hibernate)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.